Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)

6 posts in Java J2EE specific Last posting was on 2007-08-16 20:47:01.0Z
helen.robie Posted on 2007-03-05 16:31:35.0Z
From: helen.robie@activant.com
Newsgroups: sybase.public.easerver.j2ee
Subject: Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)
Date: 5 Mar 2007 08:31:35 -0800
Organization: http://groups.google.com
Lines: 74
Message-ID: <1173112295.042942.48330@n33g2000cwc.googlegroups.com>
NNTP-Posting-Host: 208.15.237.100
Mime-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
X-Trace: posting.google.com 1173112308 12485 127.0.0.1 (5 Mar 2007 16:31:48 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 5 Mar 2007 16:31:48 +0000 (UTC)
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727),gzip(gfe),gzip(gfe)
Complaints-To: groups-abuse@google.com
Injection-Info: n33g2000cwc.googlegroups.com; posting-host=208.15.237.100; posting-account=CBLa3Q0AAAA2P_4nAW24GrjC6WMGdpG1
Path: forums-1-dub!forums-master!newswest.sybase.com!newsfeed2.dallas1.level3.net!news.level3.com!postnews.google.com!n33g2000cwc.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.easerver.j2ee:7764
Article PK: 208194

Hello,

After upgrading EAServer 5.2 to EAServer 5.5, I'm having trouble
deploying my EJB jar file.


If I attempt to deploy the EJB jar file using EAServer Manager, it
fails outright with messages below. However, if I attempt to deploy
using the jagant jag_deploy task it seems to function (there are
warning messages that I've asked about in a separate post).

Why can't I deploy with EAServer Manager?


SYSTEM PARTICULARS:
EAServer 5.5 with EBF EBF14146 -- Developer Edition
Running Jaguar with -jdk15
"About Sybase Central" screen of EAServer Manager reports:
Sybase Central 4.3.0.2314
Plug-ins: EAServer Manager Version 5.5.0
Security Manager Version 5.5.0
Have rebuild all files in my jar file using JDK 1.5.0_09
Windows x86 system

EASERVER MANAGER MESSAGE BOX:
A problem occurred whild deploying file
'C:\P21\images\TPCXJava\TPCXJava.jar':
Unsupported major.minor version 49.0

ASSOCIATED JAGMGR.LOG MESSAGES:
Mar 05 11:28:10 2007: Warning: You have attempted to log a message
with an API that requires localization, but the localized key was not
found in a resouce bundle.
Key: 109999
java.lang.RuntimeException: Unsupported major.minor version 49.0
at
com.sun.enterprise.deployment.EjbDescriptor.getMethodDescriptors(EjbDescriptor.java:
1141)
at
com.sun.enterprise.deployment.EjbDescriptor.convertMethodPermissions(EjbDescriptor.java:
685)
at
com.sun.enterprise.deployment.EjbDescriptor.getExcludedMethodDescriptors(EjbDescriptor.java:
671)
at
com.sybase.jaguar.importer.JEarImporter.installBeansinJaguar(JEarImporter.java:
2641)
at
com.sybase.jaguar.importer.JEarImporter.deployEJBBundle(JEarImporter.java:
805)
at
com.sybase.jaguar.management.deploytool.EarImporterCallClass.run(EarImporterCallClass.java:
348)
at java.lang.Thread.run(Thread.java:534)

Mar 05 11:28:10 2007: Warning: You have attempted to log a message
with an API that requires localization, but the localized key was not
found in a resouce bundle.
Key:
com.sybase.jaguar.util.JException: Unsupported major.minor version
49.0
at
com.sybase.jaguar.importer.JEarImporter.deployEJBBundle(JEarImporter.java:
836)
at
com.sybase.jaguar.management.deploytool.EarImporterCallClass.run(EarImporterCallClass.java:
348)
at java.lang.Thread.run(Thread.java:534)


Thanks,

-=Helen=-


Sandip Ghayal <sghayal Posted on 2007-03-05 18:10:35.0Z
From: Sandip Ghayal <sghayal@no_spam.com>
Reply-To: sghayal@no_spam.com
Organization: Sybase Inc.
User-Agent: Thunderbird 1.5.0.10 (Windows/20070221)
MIME-Version: 1.0
Newsgroups: sybase.public.easerver.j2ee
Subject: Re: Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)
References: <1173112295.042942.48330@n33g2000cwc.googlegroups.com>
In-Reply-To: <1173112295.042942.48330@n33g2000cwc.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: sghayal-xp2.sybase.com
X-Original-NNTP-Posting-Host: sghayal-xp2.sybase.com
Message-ID: <45ec5d1b$1@forums-1-dub>
Date: 5 Mar 2007 10:10:35 -0800
X-Trace: forums-1-dub 1173118235 10.25.107.10 (5 Mar 2007 10:10:35 -0800)
X-Original-Trace: 5 Mar 2007 10:10:35 -0800, sghayal-xp2.sybase.com
Lines: 92
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.easerver.j2ee:7766
Article PK: 208201

The reason for the issue is most probably your EAServer Manager is
running with JDK1.4 and its trying to read class files that are compiled
with JDK1.5. EAServer Manager opens up the ear (or jar) files and does
some processing and tries to load some of the classes.

With jagtool/jagant this does not happen as this tools don't look inside
the ear (or jar) files.

Possible solution to issue
1) try to compile your classes with JDK1.4
2) try to run EAServer Manager with JDK1.5 (not sure if EAServer Manager
is supported to run with jdk1.5)

Thanks,

Sandip Ghayal

helen.robie@activant.com wrote:
> Hello,
>
> After upgrading EAServer 5.2 to EAServer 5.5, I'm having trouble
> deploying my EJB jar file.
>
>
> If I attempt to deploy the EJB jar file using EAServer Manager, it
> fails outright with messages below. However, if I attempt to deploy
> using the jagant jag_deploy task it seems to function (there are
> warning messages that I've asked about in a separate post).
>
> Why can't I deploy with EAServer Manager?
>
>
> SYSTEM PARTICULARS:
> EAServer 5.5 with EBF EBF14146 -- Developer Edition
> Running Jaguar with -jdk15
> "About Sybase Central" screen of EAServer Manager reports:
> Sybase Central 4.3.0.2314
> Plug-ins: EAServer Manager Version 5.5.0
> Security Manager Version 5.5.0
> Have rebuild all files in my jar file using JDK 1.5.0_09
> Windows x86 system
>
> EASERVER MANAGER MESSAGE BOX:
> A problem occurred whild deploying file
> 'C:\P21\images\TPCXJava\TPCXJava.jar':
> Unsupported major.minor version 49.0
>
> ASSOCIATED JAGMGR.LOG MESSAGES:
> Mar 05 11:28:10 2007: Warning: You have attempted to log a message
> with an API that requires localization, but the localized key was not
> found in a resouce bundle.
> Key: 109999
> java.lang.RuntimeException: Unsupported major.minor version 49.0
> at
> com.sun.enterprise.deployment.EjbDescriptor.getMethodDescriptors(EjbDescriptor.java:
> 1141)
> at
> com.sun.enterprise.deployment.EjbDescriptor.convertMethodPermissions(EjbDescriptor.java:
> 685)
> at
> com.sun.enterprise.deployment.EjbDescriptor.getExcludedMethodDescriptors(EjbDescriptor.java:
> 671)
> at
> com.sybase.jaguar.importer.JEarImporter.installBeansinJaguar(JEarImporter.java:
> 2641)
> at
> com.sybase.jaguar.importer.JEarImporter.deployEJBBundle(JEarImporter.java:
> 805)
> at
> com.sybase.jaguar.management.deploytool.EarImporterCallClass.run(EarImporterCallClass.java:
> 348)
> at java.lang.Thread.run(Thread.java:534)
>
> Mar 05 11:28:10 2007: Warning: You have attempted to log a message
> with an API that requires localization, but the localized key was not
> found in a resouce bundle.
> Key:
> com.sybase.jaguar.util.JException: Unsupported major.minor version
> 49.0
> at
> com.sybase.jaguar.importer.JEarImporter.deployEJBBundle(JEarImporter.java:
> 836)
> at
> com.sybase.jaguar.management.deploytool.EarImporterCallClass.run(EarImporterCallClass.java:
> 348)
> at java.lang.Thread.run(Thread.java:534)
>
>
> Thanks,
>
> -=Helen=-
>


helen.robie Posted on 2007-03-05 18:40:37.0Z
From: helen.robie@activant.com
Newsgroups: sybase.public.easerver.j2ee
Subject: Re: Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)
Date: 5 Mar 2007 10:40:37 -0800
Organization: http://groups.google.com
Lines: 7
Message-ID: <1173120037.626078.257900@s48g2000cws.googlegroups.com>
References: <1173112295.042942.48330@n33g2000cwc.googlegroups.com> <45ec5d1b$1@forums-1-dub>
NNTP-Posting-Host: 208.15.237.100
Mime-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
X-Trace: posting.google.com 1173120062 28244 127.0.0.1 (5 Mar 2007 18:41:02 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 5 Mar 2007 18:41:02 +0000 (UTC)
In-Reply-To: <45ec5d1b$1@forums-1-dub>
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727),gzip(gfe),gzip(gfe)
Complaints-To: groups-abuse@google.com
Injection-Info: s48g2000cws.googlegroups.com; posting-host=208.15.237.100; posting-account=CBLa3Q0AAAA2P_4nAW24GrjC6WMGdpG1
Path: forums-1-dub!forums-master!newswest.sybase.com!newsfeed2.dallas1.level3.net!news.level3.com!postnews.google.com!s48g2000cws.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.easerver.j2ee:7767
Article PK: 208200

I will gladly try running EAServer Manager with something other than
the default JDK -- how do I do that?

Thanks,

-=Helen=-


helen.robie Posted on 2007-03-06 17:00:37.0Z
From: helen.robie@activant.com
Newsgroups: sybase.public.easerver.j2ee
Subject: Re: Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)
Date: 6 Mar 2007 09:00:37 -0800
Organization: http://groups.google.com
Lines: 14
Message-ID: <1173200437.675439.173770@j27g2000cwj.googlegroups.com>
References: <1173112295.042942.48330@n33g2000cwc.googlegroups.com> <45ec5d1b$1@forums-1-dub> <1173120037.626078.257900@s48g2000cws.googlegroups.com>
NNTP-Posting-Host: 208.15.237.100
Mime-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
X-Trace: posting.google.com 1173200453 17468 127.0.0.1 (6 Mar 2007 17:00:53 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 6 Mar 2007 17:00:53 +0000 (UTC)
In-Reply-To: <1173120037.626078.257900@s48g2000cws.googlegroups.com>
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727),gzip(gfe),gzip(gfe)
Complaints-To: groups-abuse@google.com
Injection-Info: j27g2000cwj.googlegroups.com; posting-host=208.15.237.100; posting-account=CBLa3Q0AAAA2P_4nAW24GrjC6WMGdpG1
Path: forums-1-dub!forums-master!newswest.sybase.com!newsfeed2.dallas1.level3.net!news.level3.com!postnews.google.com!j27g2000cwj.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.easerver.j2ee:7768
Article PK: 208203

I have tried setting JAVA_HOME in jagmgr.bat (to JAGUAR_JDK15, which
is %JAGUAR%\jdk\jdk1.5.0_09).

No change. It seems one cannot deploy from the EAServer Manager plug-
in when using EAServer V5.5 and JDK 1.5.

If I learn differently, I'll update...

Thanks to everyone for suggestions and help (both here and in the
"general" forum where I posted before realizing that this j2ee forum
was really the more correct location),

-=Helen=-


Sandip Ghayal <sghayal Posted on 2007-03-14 16:42:22.0Z
From: Sandip Ghayal <sghayal@no_spam.com>
Reply-To: sghayal@no_spam.com
Organization: Sybase Inc.
User-Agent: Thunderbird 1.5.0.10 (Windows/20070221)
MIME-Version: 1.0
Newsgroups: sybase.public.easerver.j2ee
Subject: Re: Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)
References: <1173112295.042942.48330@n33g2000cwc.googlegroups.com> <45ec5d1b$1@forums-1-dub> <1173120037.626078.257900@s48g2000cws.googlegroups.com> <1173200437.675439.173770@j27g2000cwj.googlegroups.com>
In-Reply-To: <1173200437.675439.173770@j27g2000cwj.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: sghayal-xp2.sybase.com
X-Original-NNTP-Posting-Host: sghayal-xp2.sybase.com
Message-ID: <45f825ee$1@forums-1-dub>
Date: 14 Mar 2007 08:42:22 -0800
X-Trace: forums-1-dub 1173890542 10.25.107.10 (14 Mar 2007 08:42:22 -0800)
X-Original-Trace: 14 Mar 2007 08:42:22 -0800, sghayal-xp2.sybase.com
Lines: 52
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.easerver.j2ee:7774
Article PK: 208207

Hi Helen,

You can try this work around (Though it is not a supported configuration
by Sybase)

Try this out.

go to

Shared\Sybase Central 4.3\win32

then run

scjview -batch

it will create sybasecentral.bat

edit this file to point to jdk1.5

then go back to your $JAGUAR/bin directory and open jagmgr.bat file and

replace

call "<something>\Shared\Sybase Central 4.3\win32\scjview"

with

call "<something>\Shared\Sybase Central 4.3\win32\sybasecentral.bat"

Hope this solves your problem.

Please back up your original files before changing them.

Thanks,

Sandip

helen.robie@activant.com wrote:
> I have tried setting JAVA_HOME in jagmgr.bat (to JAGUAR_JDK15, which
> is %JAGUAR%\jdk\jdk1.5.0_09).
>
> No change. It seems one cannot deploy from the EAServer Manager plug-
> in when using EAServer V5.5 and JDK 1.5.
>
> If I learn differently, I'll update...
>
> Thanks to everyone for suggestions and help (both here and in the
> "general" forum where I posted before realizing that this j2ee forum
> was really the more correct location),
>
> -=Helen=-
>


Helen Robie Posted on 2007-08-16 20:47:01.0Z
Sender: 6778.46c4b3fa.1804289383@sybase.com
From: Helen Robie
Newsgroups: sybase.public.easerver.j2ee
Subject: Re: Cannot deploy EJB jar with EAServer Manager (EAServer 5.5 w/ jdk1.5)
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <46c4b7c5.67d6.1681692777@sybase.com>
References: <45f825ee$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 16 Aug 2007 13:47:01 -0700
X-Trace: forums-1-dub 1187297221 10.22.241.41 (16 Aug 2007 13:47:01 -0700)
X-Original-Trace: 16 Aug 2007 13:47:01 -0700, 10.22.241.41
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.easerver.j2ee:7828
Article PK: 208258

Thank you for the suggestion -- I did try that.

Unfortunately, it didn't work. It caused problems with the
Jaguar Manager even being able to load. From the error
messages it looked like the use of the AWT/Swing classes in
JDK 1.5 was incompatible.

Since my original post, I was in touch with Sybase. It
sounds as though they do not plan to address this
limitation, since as of V6.0, the EAServer Manager has been
rewritten/replaced.

Just for everyone's information...

-=Helen=-