Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

PB 11.5.1 and SqlAnywhere 5.5

2 posts in DataWindow Last posting was on 2009-11-30 18:19:35.0Z
Jerry Posted on 2009-11-30 17:07:36.0Z
From: Jerry <jerry@speednetdirect.com>
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: PB 11.5.1 and SqlAnywhere 5.5
Date: Mon, 30 Nov 2009 09:07:36 -0800 (PST)
Organization: http://groups.google.com
Lines: 11
Message-ID: <284d3a65-ba07-4dff-a295-f5c334e113cd@p33g2000vbn.googlegroups.com>
NNTP-Posting-Host: 97.106.127.128
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
X-Trace: posting.google.com 1259600856 27679 127.0.0.1 (30 Nov 2009 17:07:36 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 30 Nov 2009 17:07:36 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: p33g2000vbn.googlegroups.com; posting-host=97.106.127.128; posting-account=af9nCAoAAADbnUQBQWzBPVKe25EgWdyq
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.3; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!p33g2000vbn.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90373
Article PK: 409978

When I open a datawindow in the datawindow painter and click
Design>Data Source I get the following error message: SQLSTATE = 37000
[Sybase][ODBC Driver] Syntax error: unknown function 'user_id'

The heading on the message is GetTriggers. I do not have any triggers
on this database. I get the same error regardless of the datawindow I
open when I click Data Source. I click OK and it seems to be okay but
not 100% sure. Any help would be appreciated.

Thanks
Jerry


Chris Keating (Sybase iAnywhere) Posted on 2009-11-30 18:19:35.0Z
From: "Chris Keating (Sybase iAnywhere)" <keating_nospam@sybase.com>
User-Agent: Thunderbird 2.0.0.23 (Windows/20090812)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.datawindow
Subject: Re: PB 11.5.1 and SqlAnywhere 5.5
References: <284d3a65-ba07-4dff-a295-f5c334e113cd@p33g2000vbn.googlegroups.com>
In-Reply-To: <284d3a65-ba07-4dff-a295-f5c334e113cd@p33g2000vbn.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Message-ID: <4b140cb7$1@forums-1-dub>
Date: 30 Nov 2009 10:19:35 -0800
X-Trace: forums-1-dub 1259605175 10.22.241.152 (30 Nov 2009 10:19:35 -0800)
X-Original-Trace: 30 Nov 2009 10:19:35 -0800, vip152.sybase.com
Lines: 24
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.datawindow:90376
Article PK: 409981

SQL Anywhere 5.5 has not been tested against PB 11.5.1. However, there
is no reason that I can think that this would not work.

What specific version and build of SA5.5 and PB 11.0.1 are you using? I
am testing with 5.5.05 Build #2817 and PB 11.0.1.4011 and I am not able
to reproduce the behaviou using the steps to repro that you provided.

NOTE: it is not the PB internal change to UNICODE in case someone
attempts to claim that to be the issue :-)

-chris

Jerry wrote:
> When I open a datawindow in the datawindow painter and click
> Design>Data Source I get the following error message: SQLSTATE = 37000
> [Sybase][ODBC Driver] Syntax error: unknown function 'user_id'
>
> The heading on the message is GetTriggers. I do not have any triggers
> on this database. I get the same error regardless of the datawindow I
> open when I click Data Source. I click OK and it seems to be okay but
> not 100% sure. Any help would be appreciated.
>
> Thanks
> Jerry