Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem with installing database installjpubs on Solaris 10 Japanese EUC locale

7 posts in General Discussion Last posting was on 2009-07-08 11:11:05.0Z
nagardd Posted on 2009-06-29 22:43:57.0Z
From: nagardd <d_d_nagard@yahoo.com>
Newsgroups: sybase.public.ase.general
Subject: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
Date: Mon, 29 Jun 2009 15:43:57 -0700 (PDT)
Organization: http://groups.google.com
Lines: 102
Message-ID: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com>
NNTP-Posting-Host: 192.92.94.23
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1246315437 10411 127.0.0.1 (29 Jun 2009 22:43:57 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Mon, 29 Jun 2009 22:43:57 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: k15g2000yqc.googlegroups.com; posting-host=192.92.94.23; posting-account=TSOrywoAAADVSborHY-uB2oqppHEX6AE
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!k15g2000yqc.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27930
Article PK: 77173

Hi,

I have a problem with installing localized database on Solaris 10
Japanese EUC locale.

1. Create directory /tt
# mkdir /tt

2. Create the same sybase group and user

# groupadd -g 1000 sybase
# useradd -g sybase -u 999 -m -d /tt/sybase -s /bin/bash sybase

3. Create directory for Sybase binaries
# mkdir /opt/sb
# chown sybase:sybase /opt/sb

4. Login to sybase user and add account sybase variables

#!/usr/bin/bash
export PS1="[\u@\h \w]# "
alias reset='shutdown -i6 -g0 -y'
PATH=$PATH:/usr/sbin:/opt/VRTS/bin:/opt/VRTSvxfs/sbin:/opt/VRTSdbed/
bin:/opt/VRTSdb2ed/bin:/opt/VRTSsybed/bin:/opt/VRTSob/bin
PATH=$PATH:/usr/lib/vxvm/bin:/opt/VRTScps/bin
MANPATH=/usr/share/man:/opt/VRTS/man:$MANPATH
export PATH MANPATH
export SYBASE=/opt/sb
export
DISPLAY=10.160.18.222:0.0
export SYBASE_ASE=ASE-15_0
export SYBASE_OCS=OCS-15_0
export SYBROOT=/opt/sb
PATH=$PATH:$SYBASE/$SYBASE_ASE/bin:$SYBASE/$SYBASE_OCS/bin:$SYBASE/
$SYBASE_ASE/lib:$SYBASE/$SYBASE_OCS/lib
export LD_LIBRARY_PATH=$SYBASE/$SYBASE_OCS/lib3p64

5. Install Sybase binaries and lanugage options using sqllloc

6. Login to database and create another device to create Japanese
database
# isql -Usa -P -SSUN1

1> go
1> disk init name="jdb1",physname="/tt/sybase/jdb1.date",size="100M"
2> go

7. Create database
# cd /opt/sb/ASE-15_0/scripts/eucjis
# isql -Usa -P -SSUN1 -Jeucjis -i installjpubs
...
Msg 17344, Level 16, State 1:
Server 'SUN1', Procedure 'sp_bindrule', Line 281:
????????????????????
(return status = 1)
Msg 17344, Level 16, State 1:
Server 'SUN1', Procedure 'sp_bindrule', Line 281:
????????????????????
(return status = 1)
Msg 17344, Level 16, State 1:
Server 'SUN1', Procedure 'sp_bindrule', Line 281:
????????????????????
(return status = 1)
...
Server 'SUN1', Line 19:
???? ?????????owner.objectname ???????sp_help
??????????????????????? (sp_help
???????????????????)?
Msg 208, Level 16, State 2:
Server 'SUN1', Line 20:
?????? ?????????owner.objectname ???????sp_help
??????????????????????? (sp_help
???????????????????)?
Msg 208, Level 16, State 2:
Server 'SUN1', Line 21:
?????? ?????????owner.objectname ???????sp_help
??????????????????????? (sp_help
???????????????????)?
Msg 208, Level 16, State 2:
Server 'SUN1', Line 22:
???????? ?????????owner.objectname ???????sp_help
??????????????????????? (sp_help
???????????????????)?
Msg 208, Level 16, State 2:
Server 'SUN1', Line 23:
?????? ?????????owner.objectname ???????sp_help
??????????????????????? (sp_help
???????????????????)?
Msg 911, Level 11, State 2:
Server 'SUN1', Line 1:
sysdatabases ??????? 'jpubs'
?????????????????????????????????????????????????????
Msg 911, Level 11, State 2:
Server 'SUN1', Line 1:
sysdatabases ??????? 'jpubs'
?????????????????????????????????????????????????????

Do you know what is the problem and how to check if the database is
installed or installed correctly?

Kind regards,
Daniel


Neal Stack [Sybase] Posted on 2009-06-30 17:58:36.0Z
Message-ID: <4A4A524B.5060507@nospam.com>
From: "Neal Stack [Sybase]" <nstack@nospam.com>
User-Agent: Thunderbird 2.0.0.22 (Windows/20090605)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
To: nagardd <d_d_nagard@yahoo.com>
Subject: Re: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
References: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com>
In-Reply-To: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 30 Jun 2009 10:58:36 -0700
X-Trace: forums-3-dub.sybase.com 1246384716 10.22.241.152 (30 Jun 2009 10:58:36 -0700)
X-Original-Trace: 30 Jun 2009 10:58:36 -0700, vip152.sybase.com
Lines: 11
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27931
Article PK: 77174

Hello,

What version of ASE are you using (select @@version or dataserver -v)?

Both error 208 and 17344 are related to permissions/ownership.

If you do a "sp_helplanguage", do you see that the Japanese language has been installed in this ASE?
http://infocenter.sybase.com/help/topic/com.sybase.help.ase_15.0.sag1/html/sag1/sag1432.htm

Regards,
Neal


nagardd Posted on 2009-06-30 18:12:12.0Z
From: nagardd <d_d_nagard@yahoo.com>
Newsgroups: sybase.public.ase.general
Subject: Re: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
Date: Tue, 30 Jun 2009 11:12:12 -0700 (PDT)
Organization: http://groups.google.com
Lines: 62
Message-ID: <59c56167-bf9b-45de-b63f-8ab8d91cc536@y17g2000yqn.googlegroups.com>
References: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com> <4A4A524B.5060507@nospam.com>
NNTP-Posting-Host: 192.92.94.23
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1246385532 10743 127.0.0.1 (30 Jun 2009 18:12:12 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Tue, 30 Jun 2009 18:12:12 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: y17g2000yqn.googlegroups.com; posting-host=192.92.94.23; posting-account=TSOrywoAAADVSborHY-uB2oqppHEX6AE
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!y17g2000yqn.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27932
Article PK: 77175

Hi Neal,

I am using Sybase version 15:
[sybase@sun1 /opt/sb/ASE-15_0/scripts/eucjis]# dataserver -v
Adaptive Server Enterprise/15.0/EBF 12779 GA/P/Sun_svr4/OS 5.8/
ase150/2156/64-bit/FBO/Sat Aug 20 00:28:13 2005

I looks like there is Japanese language:

1> sp_helplanguage
2> go
langid dateformat datefirst upgrade name
alias
months
shortmonths
days
------ ---------- --------- ----------- ------------------------
------------------------

---------------------------------------------------------------------------------------------------------------

-----------------------------------------------------------------------------------------------------------------------
---------------------------------------
1 ymd 7 1500 japanese
japanese
??,??,??,??,??,??,??,??,??,??,???,???
Jan,Feb,Mar,Apr,May,Jun,Jul,Aug,Sep,Oct,Nov,Dec
?,?,?,?,?,?,?
(1 row affected)
master.dbo.syslanguages ??????????us_english ??????????
(return status = 0)

Do you know the reason of that issue?
I've done the same steps on English environment and everything goes
well.
Output from English env:

Creating the "pubs2" database
CREATE DATABASE: allocating 2048 logical pages (4.0 megabytes) on disk
'jdb1'.
Database option 'trunc log on chkpt' turned ON for database 'pubs2'.
Running CHECKPOINT on database 'pubs2' for option 'trunc log on chkpt'
to take
effect.
(return status = 0)
Type added.
(return status = 0)
Type added.
(return status = 0)
New primary key added.
(return status = 0)
New primary key added.
...
Rule bound to table column.
(return status = 0)
Rule bound to table column.
(return status = 0)
(return status = 0)

Kind regards,
Daniel


Neal Stack [Sybase] Posted on 2009-06-30 21:03:26.0Z
Message-ID: <4A4A7D9E.9060807@nospam.com>
From: "Neal Stack [Sybase]" <nstack@nospam.com>
User-Agent: Thunderbird 2.0.0.22 (Windows/20090605)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
To: nagardd <d_d_nagard@yahoo.com>
Subject: Re: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
References: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com> <4A4A524B.5060507@nospam.com> <59c56167-bf9b-45de-b63f-8ab8d91cc536@y17g2000yqn.googlegroups.com>
In-Reply-To: <59c56167-bf9b-45de-b63f-8ab8d91cc536@y17g2000yqn.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 30 Jun 2009 14:03:26 -0700
X-Trace: forums-3-dub.sybase.com 1246395806 10.22.241.152 (30 Jun 2009 14:03:26 -0700)
X-Original-Trace: 30 Jun 2009 14:03:26 -0700, vip152.sybase.com
Lines: 27
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27934
Article PK: 77181

Hello,

The only known bug for your version of ASE (which is fixed in 15.0.1 ESD#1 and higher):
438559 - installjpubs causes log full

The fix was simple. You can try modifying your script to match the fix for CR 438559.
Make sure your script matches the following lines:
if (@@maxpagesize = 2048)
create database jpubs on default = 4
else
create database jpubs on default
go


Also, make sure that ASE and ISQL are actually using eucjis:
isql -Usa -P -J eucjis
1> select @@client_csname
2> go

------------------------------------------------------------
eucjis

(1 row affected)


Regards,
Neal


nagardd Posted on 2009-07-01 15:09:08.0Z
From: nagardd <d_d_nagard@yahoo.com>
Newsgroups: sybase.public.ase.general
Subject: Re: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
Date: Wed, 1 Jul 2009 08:09:08 -0700 (PDT)
Organization: http://groups.google.com
Lines: 48
Message-ID: <e042283d-b80a-4e82-b0b6-6e68aa0d0ea9@j20g2000vbp.googlegroups.com>
References: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com> <4A4A524B.5060507@nospam.com> <59c56167-bf9b-45de-b63f-8ab8d91cc536@y17g2000yqn.googlegroups.com> <4A4A7D9E.9060807@nospam.com>
NNTP-Posting-Host: 62.172.234.21
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1246460948 27590 127.0.0.1 (1 Jul 2009 15:09:08 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Wed, 1 Jul 2009 15:09:08 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: j20g2000vbp.googlegroups.com; posting-host=62.172.234.21; posting-account=TSOrywoAAADVSborHY-uB2oqppHEX6AE
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!newsfeed.yul.equant.net!nntp1.roc.gblx.net!nntp.gblx.net!nntp.gblx.net!nlpi057.nbdc.sbc.com!prodigy.net!border1.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!j20g2000vbp.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27940
Article PK: 77185

I've changed the file:
[sybase@sun1 /opt/sb/ASE-15_0/scripts/eucjis]# vi installjpubs
/* primary ? foreign ????, text ? image ??????? */
use master
go
set nocount on

if exists (select * from master.dbo.sysdatabases
where name = "jpubs")
begin
drop database jpubs
end
go
print '?????? "jpubs" ?????????'
if (@@maxpagesize = 2048)
create database jpubs on default = 4
else
create database jpubs on default
go

sp_dboption jpubs, "trunc log on chkpt", true
go
set dateformat mdy
go
use jpubs
go
checkpoint
go
....


Also I checked the encoding:
[sybase@sun1 /opt/sb/ASE-15_0/scripts/eucjis]# isql -Usa -P -SSUN1
1> select @@client_csname
2> go

------------------------------
eucjis

(1 row affected)
1>

But during database creation there are still errors.
Maybe there should be additional changes in the configuration?

Regards,
Daniel


Neal Stack [Sybase] Posted on 2009-07-06 17:08:03.0Z
Message-ID: <4A522F73.40108@nospam.com>
From: "Neal Stack [Sybase]" <nstack@nospam.com>
User-Agent: Thunderbird 2.0.0.22 (Windows/20090605)
MIME-Version: 1.0
Newsgroups: sybase.public.ase.general
To: nagardd <d_d_nagard@yahoo.com>
Subject: Re: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
References: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com> <4A4A524B.5060507@nospam.com> <59c56167-bf9b-45de-b63f-8ab8d91cc536@y17g2000yqn.googlegroups.com> <4A4A7D9E.9060807@nospam.com> <e042283d-b80a-4e82-b0b6-6e68aa0d0ea9@j20g2000vbp.googlegroups.com>
In-Reply-To: <e042283d-b80a-4e82-b0b6-6e68aa0d0ea9@j20g2000vbp.googlegroups.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vip152.sybase.com
X-Original-NNTP-Posting-Host: vip152.sybase.com
Date: 6 Jul 2009 10:08:03 -0700
X-Trace: forums-3-dub.sybase.com 1246900083 10.22.241.152 (6 Jul 2009 10:08:03 -0700)
X-Original-Trace: 6 Jul 2009 10:08:03 -0700, vip152.sybase.com
Lines: 15
X-Authenticated-User: techsupp
Path: forums-1-dub!forums-master!forums-3-dub.sybase.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27963
Article PK: 77210

Hello,

I tested on my ASE 15.0.3 and it installed.

One change you might want to make to your "installjpubs" script is to
tell it to use the new device you created:
if (@@maxpagesize = 2048)
create database jpubs on jdb1 = 4
else
create database jpubs on jdb1
go


Regards,
Neal


nagardd Posted on 2009-07-08 11:11:05.0Z
From: nagardd <d_d_nagard@yahoo.com>
Newsgroups: sybase.public.ase.general
Subject: Re: Problem with installing database installjpubs on Solaris 10 Japanese EUC locale
Date: Wed, 8 Jul 2009 04:11:05 -0700 (PDT)
Organization: http://groups.google.com
Lines: 17
Message-ID: <a1be27be-1a19-4f5f-8603-b2fad7afa842@m7g2000prd.googlegroups.com>
References: <2bf84d16-db47-4be8-aa2e-f31dbdcfa759@k15g2000yqc.googlegroups.com> <4A4A524B.5060507@nospam.com> <59c56167-bf9b-45de-b63f-8ab8d91cc536@y17g2000yqn.googlegroups.com> <4A4A7D9E.9060807@nospam.com> <e042283d-b80a-4e82-b0b6-6e68aa0d0ea9@j20g2000vbp.googlegroups.com> <4A522F73.40108@nospam.com>
NNTP-Posting-Host: 62.172.234.21
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Trace: posting.google.com 1247051465 19838 127.0.0.1 (8 Jul 2009 11:11:05 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Wed, 8 Jul 2009 11:11:05 +0000 (UTC)
Complaints-To: groups-abuse@google.com
Injection-Info: m7g2000prd.googlegroups.com; posting-host=62.172.234.21; posting-account=TSOrywoAAADVSborHY-uB2oqppHEX6AE
User-Agent: G2/1.0
X-HTTP-UserAgent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8),gzip(gfe),gzip(gfe)
Path: forums-1-dub!forums-master!newssvr.sybase.com!news-sj-1.sprintlink.net!news-peer1.sprintlink.net!nntp1.phx1.gblx.net!nntp.gblx.net!nntp.gblx.net!border2.nntp.dca.giganews.com!nntp.giganews.com!postnews.google.com!m7g2000prd.googlegroups.com!not-for-mail
Xref: forums-1-dub sybase.public.ase.general:27973
Article PK: 77220

I have made the following change in the file:
[sybase@sun4 /opt/sb/ASE-15_0/scripts/eucjis]# vi installjpubs

/*create database jpubs on default=3*/
/*go*/
if (@@maxpagesize = 2048)
create database jpubs on jdb1 = 4
else
create database jpubs on jdb1
go

And Japanese database has created sucessfuly.

Thank you Neal a lot!

Regards,
Daniel