Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Can NOT connect SYBASE

2 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-04-15 17:42:48.0Z
Jackey Posted on 1997-04-10 19:15:48.0Z
Message-ID: <334D3C64.2F4E@hotmail.com>
Date: Thu, 10 Apr 1997 12:15:48 -0700
From: Jackey <jackeyzhang@hotmail.com>
Reply-To: jackeyzhang@hotmail.com
Organization: Alcatel Shanghai
X-Mailer: Mozilla 3.0 (Win95; U; 16bit)
MIME-Version: 1.0
Subject: Can NOT connect SYBASE
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 19
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:1040
Article PK: 252791

Hello!
I install "jConnect" on windows NT(Chinese version 3.51) and JDK1.1
is correctly installed on it. The sybase SQL SERVER is on HP, and SQL
SERVER's version is 10.0.2, Windows NT connects HP through LAN.
Everything is right, the HTTPD Server's configuration is right and
running correctly. So I run the Sample Applet, input the necessary
parameters that used to connect sybase, then click the "OK" button. The
result as following:
" jdbc.sql.SQLException:Cannot find the requested character set in
Syscharsets: name='iso_1'.Restart connection "
Then I login the sybase, use "sp_who" to check the process.I find
two newly added process.Could you tell me what's wrong with it? and how
can I do? Thank you!


David Clegg Posted on 1997-04-15 17:42:48.0Z
Message-ID: <3353BE18.7070760E@sybase.com>
Date: Tue, 15 Apr 1997 10:42:48 -0700
From: David Clegg <davec@sybase.com>
X-Mailer: Mozilla 2.01 (X11; I; Linux 1.2.13 i586)
MIME-Version: 1.0
To: jackeyzhang@hotmail.com
Subject: Re: Can NOT connect SYBASE
References: <334D3C64.2F4E@hotmail.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 34
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:1001
Article PK: 252754

Your server does not have the iso_1 charset installed - which is
the default which jConnect picks for you. You can look in your
syscharsets table to see what charsets are installed then use
the CHARSET connection property in the call to
DriverManager.getConnection(String url, Properties info);
to tell jConnect to use that charset.

CAREFUL - jConnect does not currently know how to translate any of
the multibyte charactersets (SJIS, EUCJIS, etc.) to UCS2 Unicode -
Hope you can use the product with one of the ASCII charsets (iso_1,
roman_8, etc.)

dave

>
> Hello!
> I install "jConnect" on windows NT(Chinese version 3.51) and JDK1.1
> is correctly installed on it. The sybase SQL SERVER is on HP, and SQL
> SERVER's version is 10.0.2, Windows NT connects HP through LAN.
> Everything is right, the HTTPD Server's configuration is right and
> running correctly. So I run the Sample Applet, input the necessary
> parameters that used to connect sybase, then click the "OK" button. The
> result as following:
> " jdbc.sql.SQLException:Cannot find the requested character set in
> Syscharsets: name='iso_1'.Restart connection "
> Then I login the sybase, use "sp_who" to check the process.I find
> two newly added process.Could you tell me what's wrong with it? and how
> can I do? Thank you!