Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

select ... where xxx=(select ...) do not work!?

2 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-05-31 11:13:21.0Z
Matthias Jakob Posted on 1997-05-31 11:13:21.0Z
Message-ID: <339007D1.54FC@Dive.Informatik.FH-Schmalkalden.de>
Date: Sat, 31 May 1997 13:13:21 +0200
From: Matthias Jakob <Matthias.Jakob@Dive.Informatik.FH-Schmalkalden.de>
Reply-To: Matthias.Jakob@Dive.Informatik.FH-Schmalkalden.de
Organization: FH-Schmalkalden
X-Mailer: Mozilla 3.01Gold (WinNT; I)
MIME-Version: 1.0
Subject: select ... where xxx=(select ...) do not work!?
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Newsgroups: sybase.public.jdbcconnect
Lines: 8
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:773
Article PK: 252524

Hi!

This SQL-Statement do not work:


select distinct RegionID, Region from Regionen where
LandIDRegionen=(select LandID from Land where LandName='Thüringen')

the problem is the second "select" it does not work!


So whats the problem?




Thank you, Matthias.


Lance Andersen Posted on 1997-05-27 13:51:22.0Z
Message-ID: <338AE6D9.6912@sybase.com>
Date: Tue, 27 May 1997 09:51:22 -0400
From: Lance Andersen <lancea@sybase.com>
X-Mailer: Mozilla 3.01Gold (X11; I; SunOS 5.5.1 sun4m)
MIME-Version: 1.0
To: Matthias.Jakob@Dive.Informatik.FH-Schmalkalden.de
Subject: Re: select ... where xxx=(select ...) do not work!?
References: <339007D1.54FC@Dive.Informatik.FH-Schmalkalden.de>
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Newsgroups: sybase.public.jdbcconnect
Lines: 25
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:770
Article PK: 252521

Hi Matthias,


Could you please provide the exact error and a sample program
which demonstrates the problem. Also, it would be create if
you could provide the revision of the driver that was used.


thankyou,

-lance

Matthias Jakob wrote:
>
> Hi!
>
> This SQL-Statement do not work:
>
> select distinct RegionID, Region from Regionen where
> LandIDRegionen=(select LandID from Land where LandName='Thüringen')
>
> the problem is the second "select" it does not work!
>
> So whats the problem?
>
> Thank you, Matthias.

--
===============================================================================
Lance J. Andersen Email: lancea@sybase.com
Sybase Technical Support Phone:(617) 564-6336
77 South Bedford Street Fax: (617) 564-6148
Burlington, MA 01803

The Dark Knight Returns!!! Let's Go Penguins!!!
===============================================================================