Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

very weird occurance

2 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-07-30 21:51:45.0Z
Alexander Spinelli Posted on 1997-06-10 18:49:20.0Z
Message-ID: <339DA1B0.2511@exmachina.com>
Date: Tue, 10 Jun 1997 14:49:20 -0400
From: Alexander Spinelli <spinelli@exmachina.com>
Organization: Air Media/Ex Machina
X-Mailer: Mozilla 3.0 (Win95; I)
MIME-Version: 1.0
Subject: very weird occurance
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 20
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:706
Article PK: 252459

I have written an applet that queries a Sybase 11 database.
After initial loading the applet is drawn. In the java console I have an
error as follows-->

java.sql.SQLException: A wrong datastream has been sent to the server.
The server was expecting token 236 but got the token 33. This is an
internal error.

If I press reload I get a can't find class excpetion. If I press reload
again my query goes through and the expected results show up in the java
console. I simply do a System.out.print().

Why is this happening? Obviously the stream that is initially being sent
to sybase is not correct. Why would reloading the applet fix the
problem.

I would like to purchase jConnect for an enterprise wide rollout but
only if I can get it working.

Please help.
--Thanks


David Clegg Posted on 1997-07-30 21:51:45.0Z
Message-ID: <33DFB771.519D2E23@sybase.com>
Date: Wed, 30 Jul 1997 14:51:45 -0700
From: David Clegg <davec@sybase.com>
X-Mailer: Mozilla 3.01 (X11; I; Linux 1.2.13 i586)
MIME-Version: 1.0
To: Alexander Spinelli <spinelli@exmachina.com>
Subject: Re: very weird occurance
References: <339DA1B0.2511@exmachina.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 26
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:428
Article PK: 252181

Have you solved this problem?
It sounds like a bug in the jConnect driver that I have not heard
of before. Do you have a reliable reproduction?

dave

Alexander Spinelli wrote:
>
> I have written an applet that queries a Sybase 11 database.
> After initial loading the applet is drawn. In the java console I have an
> error as follows-->
>
> java.sql.SQLException: A wrong datastream has been sent to the server.
> The server was expecting token 236 but got the token 33. This is an
> internal error.
>
> If I press reload I get a can't find class excpetion. If I press reload
> again my query goes through and the expected results show up in the java
> console. I simply do a System.out.print().
>
> Why is this happening? Obviously the stream that is initially being sent
> to sybase is not correct. Why would reloading the applet fix the
> problem.
>
> I would like to purchase jConnect for an enterprise wide rollout but
> only if I can get it working.
>
> Please help.
> --Thanks