Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

remote host

2 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-07-17 23:13:09.0Z
Jim Lynch Posted on 1997-07-16 20:56:28.0Z
Message-ID: <33CD357C.41C6@zazu.mcit.com>
Date: Wed, 16 Jul 1997 14:56:28 -0600
From: Jim Lynch <jlynch@zazu.mcit.com>
Organization: MCI Communications
X-Mailer: Mozilla 3.0 (X11; I; AIX 1)
MIME-Version: 1.0
Subject: remote host
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 19
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:530
Article PK: 252282

I have an applet that is giving me a java.lang.NullPointerException when
trying to connect to sybase 11.

The server is running on host 1 and I'm running the applet on host 2. I
started the httpd.sh script on host 2 since the applet is running on a
different host.

The applet works fine running on host 1. I can connect to different
servers on remote hosts but not when running on host 2.

Host 1 has a web server running but host 2 doesn't. Could this be the
problem. I thought the httpd.sh script running on host 2 would be
sufficient.

I downloaded the jConnect version on Jun 24 and I'm using JDK 1.0.2
connecting to sybase 11 on AIX.

Ideas??

Thanks much,
Jim
jlynch@rafiki.mcit.com


Lance Andersen Posted on 1997-07-17 23:13:09.0Z
Message-ID: <33CEA705.36AA@sybase.com>
Date: Thu, 17 Jul 1997 19:13:09 -0400
From: Lance Andersen <lancea@sybase.com>
Organization: Product Support Engineering
X-Mailer: Mozilla 3.01Gold (Win95; I)
MIME-Version: 1.0
To: Jim Lynch <jlynch@zazu.mcit.com>
Subject: Re: remote host
References: <33CD357C.41C6@zazu.mcit.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 29
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:515
Article PK: 252267

Jim,

The proxy needs to run on the same box as the webserver that served
the applet. If not, you should get a security exception. I suspect
you might be encountring a different problem. also always run
the proxy using jdk 1.1 (your can still use jdk102 for your applets)
as there were some issues with host lookups with jdk102

-lance

Jim Lynch wrote:
>
> I have an applet that is giving me a java.lang.NullPointerException when
> trying to connect to sybase 11.
>
> The server is running on host 1 and I'm running the applet on host 2. I
> started the httpd.sh script on host 2 since the applet is running on a
> different host.
>
> The applet works fine running on host 1. I can connect to different
> servers on remote hosts but not when running on host 2.
>
> Host 1 has a web server running but host 2 doesn't. Could this be the
> problem. I thought the httpd.sh script running on host 2 would be
> sufficient.
>
> I downloaded the jConnect version on Jun 24 and I'm using JDK 1.0.2
> connecting to sybase 11 on AIX.
>
> Ideas??
>
> Thanks much,
> Jim
> jlynch@rafiki.mcit.com