Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

localhost vs lan problem

2 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-09-04 22:00:01.0Z
Brian Bauer Posted on 1997-09-04 18:34:30.0Z
Message-ID: <340EFF36.BE7D884B@tkb.attnet.or.jp>
Date: Fri, 05 Sep 1997 03:34:30 +0900
From: Brian Bauer <bauerb@tkb.attnet.or.jp>
Reply-To: bauerb@rs.com
Organization: Renaissance Software A/P
X-Mailer: Mozilla 4.02 [en] (Win95; I)
MIME-Version: 1.0
Subject: localhost vs lan problem
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 29
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:317
Article PK: 252068

I am using the latest non-beta jdbc kit
jdk1.1.3
Client = Win95
Server = Solaris with sybase 11 on lan based UNIX machine

I have tried for days to run the sample IsqlApp,Ping,Validate,etc, from
my Win95 client, and connect to the sybase server. I ALWAYS get the
IOexception: connection failed for.....

Out of desperation I downloaded jdk and jdbc kits for Solaris. I
installed them on the unix server and on the first try connected to the
sybase server with all the sample apps.

Now, where does that leave me with the win95 client-server connection
which is what I really need.

my win95 client can ping, rsh, rcp to the unix server, so connection
permission is not an issue.

It seems that the issue may be with the URL. Of course when I conected
to the sybase server, from the sybase server machine, the URL was
"localhost:port".

win95 refuses to connect to the lan based server. Additionaly, I have
succeeded in running the browser based Isqlapplet only to the cascade db
on the net, it also failed to connect to my lan based server.

what is going on here. I am extremely frustrated.

Thanks,


David Lance Wolf Posted on 1997-09-04 22:00:01.0Z
Message-ID: <340F2F61.F11724DA@sybase.com>
Date: Thu, 04 Sep 1997 15:00:01 -0700
From: David Lance Wolf <dwolf@sybase.com>
Organization: Sybase Professional Services
X-Mailer: Mozilla 4.02 [en] (Win95; I)
MIME-Version: 1.0
Subject: Re: localhost vs lan problem
References: <340EFF36.BE7D884B@tkb.attnet.or.jp>
Content-Type: multipart/mixed; boundary="------------985B33B7148EFDCEB8A19DEF"
Newsgroups: sybase.public.jdbcconnect
Lines: 59
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:314
Article PK: 252067

Dont forget that applets can only connect to the server who served them
unless your running the cascade server.

The URL must be:

jdbc:sybase:Tds:your.ip.nam:port#

So localhost was right on the solaris machine, but should be the server name
from WIN95.

Dave Wolf
Sybase Professional Services

Brian Bauer wrote:

> I am using the latest non-beta jdbc kit
> jdk1.1.3
> Client = Win95
> Server = Solaris with sybase 11 on lan based UNIX machine
>
> I have tried for days to run the sample IsqlApp,Ping,Validate,etc, from
> my Win95 client, and connect to the sybase server. I ALWAYS get the
> IOexception: connection failed for.....
>
> Out of desperation I downloaded jdk and jdbc kits for Solaris. I
> installed them on the unix server and on the first try connected to the
> sybase server with all the sample apps.
>
> Now, where does that leave me with the win95 client-server connection
> which is what I really need.
>
> my win95 client can ping, rsh, rcp to the unix server, so connection
> permission is not an issue.
>
> It seems that the issue may be with the URL. Of course when I conected
> to the sybase server, from the sybase server machine, the URL was
> "localhost:port".
>
> win95 refuses to connect to the lan based server. Additionaly, I have
> succeeded in running the browser based Isqlapplet only to the cascade db
> on the net, it also failed to connect to my lan based server.
>
> what is going on here. I am extremely frustrated.
>
> Thanks,


Download VCard vcard.vcf