Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

version 3 beta problem

7 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-09-15 15:44:11.0Z
alan Posted on 1997-09-05 01:50:27.0Z
Message-ID: <340F6562.56BB@wliu.demon.co.uk>
Date: Thu, 04 Sep 1997 18:50:27 -0700
From: alan <alan@wliu.demon.co.uk>
X-Mailer: Mozilla 3.0 (Win16; I)
MIME-Version: 1.0
Subject: version 3 beta problem
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 21
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:316
Article PK: 252065


>I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
>sample program.
>
>It compiled with no errors but when I ran it the following error occurs:
>
>java.lang.IllegalAccessError: Unimplemented interface method
> at
> at
>com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
>ava)
> at
>com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
>ava)
> at
>com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
>ava)
> at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> at java.sql.DriverManager.getConnection(DriverManager.java:95)
> at SimpleSelect.main(SimpleSelect.java:43)
>
>Could you advise on this problem please?
>
>Regards
>Alan


David Lance Wolf Posted on 1997-09-04 21:57:21.0Z
Message-ID: <340F2EC0.DB0D7516@sybase.com>
Date: Thu, 04 Sep 1997 14:57:21 -0700
From: David Lance Wolf <dwolf@sybase.com>
Organization: Sybase Professional Services
X-Mailer: Mozilla 4.02 [en] (Win95; I)
MIME-Version: 1.0
Subject: Re: version 3 beta problem
References: <340F6562.56BB@wliu.demon.co.uk>
Content-Type: multipart/mixed; boundary="------------852FC321E4E04F94871AE5D6"
Newsgroups: sybase.public.jdbcconnect
Lines: 47
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:315
Article PK: 252066

Have you run the sql_server.sql script to compile meta-data accessors?

Dave Wolf
Sybase Professional Services

alan wrote:

> >I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
> >sample program.
> >
> >It compiled with no errors but when I ran it the following error occurs:
> >
> >java.lang.IllegalAccessError: Unimplemented interface method
> > at
> > at
> >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> >ava)
> > at
> >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> >ava)
> > at
> >com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
> >ava)
> > at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> > at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> > at java.sql.DriverManager.getConnection(DriverManager.java:95)
> > at SimpleSelect.main(SimpleSelect.java:43)
> >
> >Could you advise on this problem please?
> >
> >Regards
> >Alan


Download VCard vcard.vcf


alan Posted on 1997-09-06 03:51:38.0Z
Message-ID: <3410D349.6DD2@wliu.demon.co.uk>
Date: Fri, 05 Sep 1997 20:51:38 -0700
From: alan <alan@wliu.demon.co.uk>
X-Mailer: Mozilla 3.0 (Win16; I)
MIME-Version: 1.0
Subject: Re: version 3 beta problem
References: <340F6562.56BB@wliu.demon.co.uk> <340F2EC0.DB0D7516@sybase.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 45
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:311
Article PK: 252064

Thanks for your advice.

I'm running the example on a unix platform with Sybase system 11. The
installation procedure only refers to SQL server or SQl Anywhere for
running the sql_server.sql script.

Could you tell me whether it's necessary to run the sql_server.sql
script under unix, or is there some other problem?

Regards
Alan

David Lance Wolf wrote:
>
> Have you run the sql_server.sql script to compile meta-data accessors?
>
> Dave Wolf
> Sybase Professional Services
>
> alan wrote:
>
> > >I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
> > >sample program.
> > >
> > >It compiled with no errors but when I ran it the following error occurs:
> > >
> > >java.lang.IllegalAccessError: Unimplemented interface method
> > > at
> > > at
> > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > >ava)
> > > at
> > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > >ava)
> > > at
> > >com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
> > >ava)
> > > at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> > > at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> > > at java.sql.DriverManager.getConnection(DriverManager.java:95)
> > > at SimpleSelect.main(SimpleSelect.java:43)
> > >
> > >Could you advise on this problem please?
> > >
> > >Regards
> > >Alan
>
> ---------------------------------------------------------------
>
> Name: vcard.vcf
> Part 1.2 Type: text/x-vcard
> Encoding: 7bit
> Description: Card for David Wolf


David Lance Wolf Posted on 1997-09-06 06:11:15.0Z
Message-ID: <3410F402.74C5931@sybase.com>
Date: Fri, 05 Sep 1997 23:11:15 -0700
From: David Lance Wolf <dwolf@sybase.com>
Organization: Sybase Professional Services
X-Mailer: Mozilla 4.02 [en] (Win95; I)
MIME-Version: 1.0
Subject: Re: version 3 beta problem
References: <340F6562.56BB@wliu.demon.co.uk> <340F2EC0.DB0D7516@sybase.com> <3410D349.6DD2@wliu.demon.co.uk>
Content-Type: multipart/mixed; boundary="------------6D5341C31AC30D61879B7941"
Newsgroups: sybase.public.jdbcconnect
Lines: 72
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:310
Article PK: 252063

Alan-

If your using System XI, run the sql_server.sql script. The user running the script
MUST have the sa_role.

Dave Wolf
Sybase Professional Services

alan wrote:

> Thanks for your advice.
>
> I'm running the example on a unix platform with Sybase system 11. The
> installation procedure only refers to SQL server or SQl Anywhere for
> running the sql_server.sql script.
>
> Could you tell me whether it's necessary to run the sql_server.sql
> script under unix, or is there some other problem?
>
> Regards
> Alan
>
> David Lance Wolf wrote:
> >
> > Have you run the sql_server.sql script to compile meta-data accessors?
> >
> > Dave Wolf
> > Sybase Professional Services
> >
> > alan wrote:
> >
> > > >I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
> > > >sample program.
> > > >
> > > >It compiled with no errors but when I ran it the following error occurs:
> > > >
> > > >java.lang.IllegalAccessError: Unimplemented interface method
> > > > at
> > > > at
> > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > >ava)
> > > > at
> > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > >ava)
> > > > at
> > > >com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
> > > >ava)
> > > > at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> > > > at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> > > > at java.sql.DriverManager.getConnection(DriverManager.java:95)
> > > > at SimpleSelect.main(SimpleSelect.java:43)
> > > >
> > > >Could you advise on this problem please?
> > > >
> > > >Regards
> > > >Alan
> >
> > ---------------------------------------------------------------
> >
> > Name: vcard.vcf
> > Part 1.2 Type: text/x-vcard
> > Encoding: 7bit
> > Description: Card for David Wolf


Download VCard vcard.vcf


alan Posted on 1997-09-13 21:31:32.0Z
Message-ID: <341B050C.45D9@wliu.demon.co.uk>
Date: Sat, 13 Sep 1997 14:31:32 -0700
From: alan <alan@wliu.demon.co.uk>
X-Mailer: Mozilla 3.0 (Win16; I)
MIME-Version: 1.0
Subject: Re: version 3 beta problem
References: <340F6562.56BB@wliu.demon.co.uk> <340F2EC0.DB0D7516@sybase.com> <3410D349.6DD2@wliu.demon.co.uk> <3410F402.74C5931@sybase.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 89
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:286
Article PK: 252038

Dave

I've run the sql_server.sql script but the problem reamained.

The problem was actually caused by an earlier version of java.sql, which
worked fine with previous jConnect version and jdk1.0.2. As jdk1.0.2
does not have java.sql I had downloaded java.sql and placed it in the
CLASSPATH variable.

Compiling with jdk1.1.3 with the old java.sql taken out from the
CLASSPATH works fine when the applet is run.

The only problem now is I still couldn't get it to work under jdk1.0.2.
The documentation says that we should import jdbc.sql when compiling
with jdk1.0.2 but this package does not seem to be present in
jConnect3.0. I can see this package in the previous release of jConnect
but using that package produced the same error as before.

I've got some prototyping application using the previous jConnect
version, whose license has now expired. It would be good if I can make
this application work again. Is there any way to resurrect the old
jConnect copy?

Thanks
Alan

David Lance Wolf wrote:
>
> Alan-
>
> If your using System XI, run the sql_server.sql script. The user running the script
> MUST have the sa_role.
>
> Dave Wolf
> Sybase Professional Services
>
> alan wrote:
>
> > Thanks for your advice.
> >
> > I'm running the example on a unix platform with Sybase system 11. The
> > installation procedure only refers to SQL server or SQl Anywhere for
> > running the sql_server.sql script.
> >
> > Could you tell me whether it's necessary to run the sql_server.sql
> > script under unix, or is there some other problem?
> >
> > Regards
> > Alan
> >
> > David Lance Wolf wrote:
> > >
> > > Have you run the sql_server.sql script to compile meta-data accessors?
> > >
> > > Dave Wolf
> > > Sybase Professional Services
> > >
> > > alan wrote:
> > >
> > > > >I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
> > > > >sample program.
> > > > >
> > > > >It compiled with no errors but when I ran it the following error occurs:
> > > > >
> > > > >java.lang.IllegalAccessError: Unimplemented interface method
> > > > > at
> > > > > at
> > > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > > >ava)
> > > > > at
> > > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > > >ava)
> > > > > at
> > > > >com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
> > > > >ava)
> > > > > at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> > > > > at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> > > > > at java.sql.DriverManager.getConnection(DriverManager.java:95)
> > > > > at SimpleSelect.main(SimpleSelect.java:43)
> > > > >
> > > > >Could you advise on this problem please?
> > > > >
> > > > >Regards
> > > > >Alan
> > >
> > > ---------------------------------------------------------------
> > >
> > > Name: vcard.vcf
> > > Part 1.2 Type: text/x-vcard
> > > Encoding: 7bit
> > > Description: Card for David Wolf
>
> ---------------------------------------------------------------
>
> Name: vcard.vcf
> Part 1.2 Type: text/x-vcard
> Encoding: 7bit
> Description: Card for David Wolf

ave


Lance Andersen Posted on 1997-09-15 15:44:11.0Z
Message-ID: <341D57CB.1E57@sybase.com>
Date: Mon, 15 Sep 1997 11:44:11 -0400
From: Lance Andersen <lancea@sybase.com>
X-Mailer: Mozilla 3.01Gold (X11; I; SunOS 5.5.1 sun4m)
MIME-Version: 1.0
To: alan <alan@wliu.demon.co.uk>
Subject: Re: version 3 beta problem
References: <340F6562.56BB@wliu.demon.co.uk> <340F2EC0.DB0D7516@sybase.com> <3410D349.6DD2@wliu.demon.co.uk> <3410F402.74C5931@sybase.com> <341B050C.45D9@wliu.demon.co.uk>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 68
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:282
Article PK: 252033

Alan,

Could you please state what your current problem is.

As David Wolf points out we do not provide support for jdk102 with
jConnect 3.0.

If you are trying to use applets compiled with jdk11 you also
need a browser that can handle applets built with jdk11


If you are having the problem below

please run with java -verbose and change your classpath to point
to $JDBC_HOME/devclasses.

also if you could run java Version, that would help as well.

alan wrote:

> > > > > >I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
> > > > > >sample program.
> > > > > >
> > > > > >It compiled with no errors but when I ran it the following error occurs:
> > > > > >
> > > > > >java.lang.IllegalAccessError: Unimplemented interface method
> > > > > > at
> > > > > > at
> > > > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > > > >ava)
> > > > > > at
> > > > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > > > >ava)
> > > > > > at
> > > > > >com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
> > > > > >ava)
> > > > > > at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> > > > > > at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> > > > > > at java.sql.DriverManager.getConnection(DriverManager.java:95)
> > > > > > at SimpleSelect.main(SimpleSelect.java:43)
> > > > > >
> > > > > >Could you advise on this problem please?
> > > > > >
> > > > > >Regards
> > > > > >Alan
> > > >
> > > > ---------------------------------------------------------------
> > > >
> > > > Name: vcard.vcf
> > > > Part 1.2 Type: text/x-vcard
> > > > Encoding: 7bit
> > > > Description: Card for David Wolf
> >
> > ---------------------------------------------------------------
> >
> > Name: vcard.vcf
> > Part 1.2 Type: text/x-vcard
> > Encoding: 7bit
> > Description: Card for David Wolf
> ave

--
===============================================================================
Lance J. Andersen Email: lancea@sybase.com
Sybase Technical Support Phone:(617) 564-6336
77 South Bedford Street Fax: (617) 564-6148
Burlington, MA 01803

The Dark Knight Returns!!! Let's Go Penguins!!!
===============================================================================


David Lance Wolf Posted on 1997-09-13 17:41:54.0Z
Message-ID: <341AD062.6CB80036@sybase.com>
Date: Sat, 13 Sep 1997 10:41:54 -0700
From: David Lance Wolf <dwolf@sybase.com>
Organization: Sybase Professional Services
X-Mailer: Mozilla 4.02 [en] (Win95; I)
MIME-Version: 1.0
Subject: Re: version 3 beta problem
References: <340F6562.56BB@wliu.demon.co.uk> <340F2EC0.DB0D7516@sybase.com> <3410D349.6DD2@wliu.demon.co.uk> <3410F402.74C5931@sybase.com> <341B050C.45D9@wliu.demon.co.uk>
Content-Type: multipart/mixed; boundary="------------36DAE7DC359460D7B51E6587"
Newsgroups: sybase.public.jdbcconnect
Lines: 123
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:285
Article PK: 252037

Alan-

jConnect 3.0 only works with 1.1 targets. It uses some features that
are 1.1 specific. To get a 1.02 applet, you'll need to download the 2.2
version of jConnect. When you compile it, just on the fly add the
classpath with the -classpath setting to be positive that only the 2.2
version is used.

Dave Wolf
Sybase Professional Services

alan wrote:
>
> Dave
>
> I've run the sql_server.sql script but the problem reamained.
>
> The problem was actually caused by an earlier version of java.sql, which
> worked fine with previous jConnect version and jdk1.0.2. As jdk1.0.2
> does not have java.sql I had downloaded java.sql and placed it in the
> CLASSPATH variable.
>
> Compiling with jdk1.1.3 with the old java.sql taken out from the
> CLASSPATH works fine when the applet is run.
>
> The only problem now is I still couldn't get it to work under jdk1.0.2.
> The documentation says that we should import jdbc.sql when compiling
> with jdk1.0.2 but this package does not seem to be present in
> jConnect3.0. I can see this package in the previous release of jConnect
> but using that package produced the same error as before.
>
> I've got some prototyping application using the previous jConnect
> version, whose license has now expired. It would be good if I can make
> this application work again. Is there any way to resurrect the old
> jConnect copy?
>
> Thanks
> Alan
>
> David Lance Wolf wrote:
> >
> > Alan-
> >
> > If your using System XI, run the sql_server.sql script. The user running the script
> > MUST have the sa_role.
> >
> > Dave Wolf
> > Sybase Professional Services
> >
> > alan wrote:
> >
> > > Thanks for your advice.
> > >
> > > I'm running the example on a unix platform with Sybase system 11. The
> > > installation procedure only refers to SQL server or SQl Anywhere for
> > > running the sql_server.sql script.
> > >
> > > Could you tell me whether it's necessary to run the sql_server.sql
> > > script under unix, or is there some other problem?
> > >
> > > Regards
> > > Alan
> > >
> > > David Lance Wolf wrote:
> > > >
> > > > Have you run the sql_server.sql script to compile meta-data accessors?
> > > >
> > > > Dave Wolf
> > > > Sybase Professional Services
> > > >
> > > > alan wrote:
> > > >
> > > > > >I'm using JDK1.1.3 Final and Jconnect 3 Beta to compile the SimpleSelect.java
> > > > > >sample program.
> > > > > >
> > > > > >It compiled with no errors but when I ran it the following error occurs:
> > > > > >
> > > > > >java.lang.IllegalAccessError: Unimplemented interface method
> > > > > > at
> > > > > > at
> > > > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > > > >ava)
> > > > > > at
> > > > > >com.sybase.jdbc.SybDatabaseMetaData.getMetaDataAccessor(SybDatabaseMetaData.j
> > > > > >ava)
> > > > > > at
> > > > > >com.sybase.jdbc.SybDatabaseMetaData.configureConnection(SybDatabaseMetaData.j
> > > > > >ava)
> > > > > > at com.sybase.jdbc.SybConnection.<init>(SybConnection.java)
> > > > > > at com.sybase.jdbc.SybDriver.connect(SybDriver.java)
> > > > > > at java.sql.DriverManager.getConnection(DriverManager.java:95)
> > > > > > at SimpleSelect.main(SimpleSelect.java:43)
> > > > > >
> > > > > >Could you advise on this problem please?
> > > > > >
> > > > > >Regards
> > > > > >Alan
> > > >
> > > > ---------------------------------------------------------------
> > > >
> > > > Name: vcard.vcf
> > > > Part 1.2 Type: text/x-vcard
> > > > Encoding: 7bit
> > > > Description: Card for David Wolf
> >
> > ---------------------------------------------------------------
> >
> > Name: vcard.vcf
> > Part 1.2 Type: text/x-vcard
> > Encoding: 7bit
> > Description: Card for David Wolf
> ave


Download VCard vcard.vcf