Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

32 bits ODBC driver for Watcom 4.0 database

3 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-09-29 17:26:23.0Z
Linn C. Refset Krumsvik Posted on 1997-09-27 20:49:29.0Z
Message-ID: <342D7159.1D9A0512@stud.ntnu.no>
Date: Sat, 27 Sep 1997 22:49:29 +0200
From: "Linn C. Refset Krumsvik" <linnr@stud.ntnu.no>
X-Mailer: Mozilla 4.01 [en] (WinNT; I)
MIME-Version: 1.0
Subject: 32 bits ODBC driver for Watcom 4.0 database
X-Priority: 3 (Normal)
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 2
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:228
Article PK: 251981

Can anybody help me locate ODBC drivers for Watcom 4.0 databases?


Judd T. Salisbury Posted on 1997-09-29 14:18:30.0Z
Message-ID: <342FB8B6.AD28406@agency.com>
Date: Mon, 29 Sep 1997 10:18:30 -0400
From: "Judd T. Salisbury" <judd@agency.com>
X-Mailer: Mozilla 4.03 [en] (WinNT; I)
MIME-Version: 1.0
Subject: Re: Trouble with JavaWebServer finding JConnect Driver with Servlets
References: <342D7159.1D9A0512@stud.ntnu.no>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 23
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:225
Article PK: 251976

I am running a JavaWebServer1.0.2 on a UNIX machine and I am trying to
have a servlet connect to to a Sybase database. But I receive the error
message

Error! - java.sql.SQLException: No suitable driver It is null connected

I have created a test java application that connects using JConnect and
it is successful so I am quite sure my CLASSPATH is correctly set.

I also am running the JavaWebServer from my account so I believe it
would then use my CLASSPATH.

My class enviroment if it helps is

PATH=/usr/bin:/usr/ucb:/etc:/export/home/sybase/bin:/usr/local/jdk1.1.4/bin:.

CLASSPATH=/export/home/agency/jconnect/classes:/usr/local/jdk1.1.4/lib/classes.z

ip:/usr/local/JavaWebServer1.0.2/lib/classes.jar:.
SYBASE=/export/home/sybase
JAVA_HOME=/usr/local/jdk1.1.4
JDBC_HOME=/export/home/agency/jconnect

If anyone has any advice I would greatly appreciate it.

Judd


David Clegg Posted on 1997-09-29 17:26:23.0Z
Message-ID: <342FE4BF.69D47815@sybase.com>
Date: Mon, 29 Sep 1997 10:26:23 -0700
From: David Clegg <davec@sybase.com>
X-Mailer: Mozilla 3.01 (X11; I; Linux 1.2.13 i586)
MIME-Version: 1.0
To: "Judd T. Salisbury" <judd@agency.com>
Subject: Re: Trouble with JavaWebServer finding JConnect Driver with Servlets
References: <342D7159.1D9A0512@stud.ntnu.no> <342FB8B6.AD28406@agency.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 39
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:219
Article PK: 251970

Servlets under the JavaServer do NOT use your CLASSPATH environment
value. Copy or 'ln -s' or 'cp -r' the 'com' subdirectory from
$JDBC_HOME/classes of the jConnect distribution to the
'servlets' subdirectory of your JavaServer installation.

% ln -s $JDBC_HOME/classes/com \
/usr/local/JavaWebServer1.0.2/serlets/com

The servlet class loader should be able to find jConnect then.
Also, be sure that you have loaded the driver -- add a call to
Class.forName("com.sybase.jdbc.SybDriver") to your servlet's init()

dave

Judd T. Salisbury wrote:
>
> I am running a JavaWebServer1.0.2 on a UNIX machine and I am trying to
> have a servlet connect to to a Sybase database. But I receive the error
> message
>
> Error! - java.sql.SQLException: No suitable driver It is null connected
>
> I have created a test java application that connects using JConnect and
> it is successful so I am quite sure my CLASSPATH is correctly set.
>
> I also am running the JavaWebServer from my account so I believe it
> would then use my CLASSPATH.
>
> My class enviroment if it helps is
>
> PATH=/usr/bin:/usr/ucb:/etc:/export/home/sybase/bin:/usr/local/jdk1.1.4/bin:.
>
> CLASSPATH=/export/home/agency/jconnect/classes:/usr/local/jdk1.1.4/lib/classes.z
>
> ip:/usr/local/JavaWebServer1.0.2/lib/classes.jar:.
> SYBASE=/export/home/sybase
> JAVA_HOME=/usr/local/jdk1.1.4
> JDBC_HOME=/export/home/agency/jconnect
>
> If anyone has any advice I would greatly appreciate it.
>
> Judd