Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problems with jconnect and JDK 1.02

2 posts in JDBC Connect (product renamed to JConnect) Last posting was on 1997-10-06 14:35:11.0Z
Paul Mirpoorian Posted on 1997-10-03 16:45:41.0Z
Message-ID: <34352135.3D7437F9@bsat.com>
Date: Fri, 03 Oct 1997 12:45:41 -0400
From: Paul Mirpoorian <pmirpoorian@bsat.com>
X-Mailer: Mozilla 4.03 [en] (WinNT; I)
MIME-Version: 1.0
Subject: Problems with jconnect and JDK 1.02
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 36
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:194
Article PK: 251946

I am runnning into the following error when trying to run the Isql
sample applet provided with jconnect:

jdbc.sql.SQLException: JZ006: Caught IOException: java.io.IOException:
Gateway connection refused: HTTP/1.0 502 Bad Gateway
Restart connection.

I am trying to access Sybase SQL Server 11 running on a SUN database
server with Solaris.
My Web Server is IIS on NT 4.0 with service pack 3.
I am running the httpd gateway on the NT server.

I have installed JDK 1.02 on the web server in c:\java directory, and
set my JAVA_HOME to the c:\java (where JDK 1.02 is installed)

I jave installed jconnect in c:\jconnect directory and set my JDBC_HOME
to C:\jconnect

My class path looks like the following:
.;c:\jconnect\classes;c:\java\lib\classes.zip;

The JZ006 error seems to indicate a lower layer communication error.
Now I must say that I first ran Isql applet with JDK 1.1 installed on
the web server, and I could successfully get to my Sybase SQL Server. I
then uninstalled JDK 1.1, installed JDK 1.02 and recompiled the Isql
applet with the changes recommended (changing the import libraries and
the sybase driver). But then is when I have
gotten the error. I used the javac compiler shipped with JDK 1.02 to
recompile the applet as per Sybase jconnect instructions.

Has anybody else run into this problem? I appreciate all help. Thankx

Paul Mirpoorian


Lance Andersen Posted on 1997-10-06 14:35:11.0Z
Message-ID: <3438F71F.1C50@sybase.com>
Date: Mon, 06 Oct 1997 10:35:11 -0400
From: Lance Andersen <lancea@sybase.com>
X-Mailer: Mozilla 3.01Gold (X11; I; SunOS 5.5.1 sun4m)
MIME-Version: 1.0
To: Paul Mirpoorian <pmirpoorian@bsat.com>
Subject: Re: Problems with jconnect and JDK 1.02
References: <34352135.3D7437F9@bsat.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jdbcconnect
Lines: 55
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jdbcconnect:187
Article PK: 251939


Paul Mirpoorian wrote:
>
> I am runnning into the following error when trying to run the Isql
> sample applet provided with jconnect:
>
> jdbc.sql.SQLException: JZ006: Caught IOException: java.io.IOException:
> Gateway connection refused: HTTP/1.0 502 Bad Gateway
> Restart connection.
>
> I am trying to access Sybase SQL Server 11 running on a SUN database
> server with Solaris.
> My Web Server is IIS on NT 4.0 with service pack 3.
> I am running the httpd gateway on the NT server.
>
> I have installed JDK 1.02 on the web server in c:\java directory, and
> set my JAVA_HOME to the c:\java (where JDK 1.02 is installed)
>
> I jave installed jconnect in c:\jconnect directory and set my JDBC_HOME
> to C:\jconnect
>
> My class path looks like the following:
> .;c:\jconnect\classes;c:\java\lib\classes.zip;
>
> The JZ006 error seems to indicate a lower layer communication error.
> Now I must say that I first ran Isql applet with JDK 1.1 installed on
> the web server, and I could successfully get to my Sybase SQL Server. I
> then uninstalled JDK 1.1, installed JDK 1.02 and recompiled the Isql
> applet with the changes recommended (changing the import libraries and
> the sybase driver). But then is when I have
> gotten the error. I used the javac compiler shipped with JDK 1.02 to
> recompile the applet as per Sybase jconnect instructions.
>
> Has anybody else run into this problem? I appreciate all help. Thankx
>
> Paul Mirpoorian

Paul,

Please refer to:

http://www.sybase.com/products/internet/jconnect/jdbcfaqs6.html#q2
--
and

http://www.sybase.com/products/internet/jconnect/docs/jcinst_5.htm#HEADING5-162

This might give you the tips that you need

-lance
===============================================================================
Lance J. Andersen Email: lancea@sybase.com
Sybase Technical Support Phone:(617) 564-6336
77 South Bedford Street Fax: (617) 564-6148
Burlington, MA 01803

The Dark Knight Returns!!! Let's Go Penguins!!!
===============================================================================