Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASE 11.9.2 and jaguar cache

7 posts in General Discussion (old) Last posting was on 2000-03-17 22:20:08.0Z
Sem Kazazic Posted on 2000-03-17 17:45:24.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 12:45:24 -0500
Lines: 87
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000C_01BF900E.A9EEBAC0"
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_$ZLsAlDk$GA.261@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26185
Article PK: 156855

Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.
 


Scott McReynolds [Sybase] Posted on 2000-03-17 18:46:44.0Z
Newsgroups: sybase.public.easerver
From: "Scott McReynolds [Sybase]" <scottmc@sybase.com>
Subject: Re: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 11:46:44 -0700
Lines: 108
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0010_01BF9006.781AF7A0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: scottmc-lpt.sybase.com 157.133.56.40
Message-ID: <347_17mG6GEk$GA.34@forums.sybase.com>
References: <347_$ZLsAlDk$GA.261@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26179
Article PK: 154394

Sem,
 
What errors are you seeing when making the call?
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:$ZLsAlDk$GA.261@forums.sybase.com...
Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.
 


Sem Kazazic Posted on 2000-03-17 19:11:36.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: Re: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 14:11:36 -0500
Lines: 161
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0033_01BF901A.B4F83CA0"
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_J8dCMVEk$GA.285@forums.sybase.com>
References: <347_$ZLsAlDk$GA.261@forums.sybase.com> <347_17mG6GEk$GA.34@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26175
Article PK: 154389

----
Mar 17 11:20:11 2000: Server Message: 2409/11/2/ZZZZZ: Cannot find the requested character set in Syscharactersets: name = 'utf8'.
Mar 17 11:20:11 2000: Server Message: 2411/10/1/ZZZZZ: No conversion will be done.
 
Mar 17 11:20:11 2000: Cannot connect -  mycomponent ( this one is from my pb script)
 
It looks like one previous posting related to the character set, isn't it ?
 
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message <17mG6GEk$GA.34@forums.sybase.com>...
Sem,
 
What errors are you seeing when making the call?
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:$ZLsAlDk$GA.261@forums.sybase.com...
Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.
 


Scott McReynolds [Sybase] Posted on 2000-03-17 19:18:12.0Z
Newsgroups: sybase.public.easerver
From: "Scott McReynolds [Sybase]" <scottmc@sybase.com>
Subject: Re: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 12:18:12 -0700
Lines: 181
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_004B_01BF900A.DD0099A0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: scottmc-lpt.sybase.com 157.133.56.40
Message-ID: <347_slqsdYEk$GA.34@forums.sybase.com>
References: <347_$ZLsAlDk$GA.261@forums.sybase.com> <347_17mG6GEk$GA.34@forums.sybase.com> <347_J8dCMVEk$GA.285@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26172
Article PK: 156849

Sem,
 
Yes, change the character set to be the same as your ASE character set "iso_1"
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:J8dCMVEk$GA.285@forums.sybase.com...
----
Mar 17 11:20:11 2000: Server Message: 2409/11/2/ZZZZZ: Cannot find the requested character set in Syscharactersets: name = 'utf8'.
Mar 17 11:20:11 2000: Server Message: 2411/10/1/ZZZZZ: No conversion will be done.
 
Mar 17 11:20:11 2000: Cannot connect -  mycomponent ( this one is from my pb script)
 
It looks like one previous posting related to the character set, isn't it ?
 
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message <17mG6GEk$GA.34@forums.sybase.com>...
Sem,
 
What errors are you seeing when making the call?
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:$ZLsAlDk$GA.261@forums.sybase.com...
Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.
 


Sem Kazazic Posted on 2000-03-17 20:05:36.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: Re: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 15:05:36 -0500
Lines: 236
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000E_01BF9022.3FCB9E60"
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_Vfl7WzEk$GA.201@forums.sybase.com>
References: <347_$ZLsAlDk$GA.261@forums.sybase.com> <347_17mG6GEk$GA.34@forums.sybase.com> <347_J8dCMVEk$GA.285@forums.sybase.com> <347_slqsdYEk$GA.34@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26163
Article PK: 156842

Hi Scott,
 
Yes it solved character set error message, but I am still not able to connect from pb component to ase db(CONNECT -> SQLCA.SQLCODE <> 0)
Can you post set of SQLCA params I should have for ASE db and jaguar named connection cache?
Any comment java stub?
 
Thanks.
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message ...
Sem,
 
Yes, change the character set to be the same as your ASE character set "iso_1"
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:J8dCMVEk$GA.285@forums.sybase.com...
----
Mar 17 11:20:11 2000: Server Message: 2409/11/2/ZZZZZ: Cannot find the requested character set in Syscharactersets: name = 'utf8'.
Mar 17 11:20:11 2000: Server Message: 2411/10/1/ZZZZZ: No conversion will be done.
 
Mar 17 11:20:11 2000: Cannot connect -  mycomponent ( this one is from my pb script)
 
It looks like one previous posting related to the character set, isn't it ?
 
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message <17mG6GEk$GA.34@forums.sybase.com>...
Sem,
 
What errors are you seeing when making the call?
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:$ZLsAlDk$GA.261@forums.sybase.com...
Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.
 


Sem Kazazic Posted on 2000-03-17 21:38:06.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: Re: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 16:38:06 -0500
Lines: 278
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000F_01BF902F.2BE9D2B0"
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_8GraDnFk$GA.34@forums.sybase.com>
References: <347_$ZLsAlDk$GA.261@forums.sybase.com> <347_17mG6GEk$GA.34@forums.sybase.com> <347_J8dCMVEk$GA.285@forums.sybase.com> <347_slqsdYEk$GA.34@forums.sybase.com> <347_Vfl7WzEk$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26156
Article PK: 156833

I was looking in the posting from Ken Forbes (Feb. 22, 2000 "Help connecting to Sybase 11.5").
Changed only one SQLCA setting :
SQLCA.DBMS="SYJ"
and pb component was able to connect.
I will check again , but seems to me weekend is not so bad.
It would be great if I get an answer about java stub.
 
Regards,
Sem.
 
Sem Kazazic wrote in message ...
Hi Scott,
 
Yes it solved character set error message, but I am still not able to connect from pb component to ase db(CONNECT -> SQLCA.SQLCODE <> 0)
Can you post set of SQLCA params I should have for ASE db and jaguar named connection cache?
Any comment java stub?
 
Thanks.
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message ...
Sem,
 
Yes, change the character set to be the same as your ASE character set "iso_1"
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:J8dCMVEk$GA.285@forums.sybase.com...
----
Mar 17 11:20:11 2000: Server Message: 2409/11/2/ZZZZZ: Cannot find the requested character set in Syscharactersets: name = 'utf8'.
Mar 17 11:20:11 2000: Server Message: 2411/10/1/ZZZZZ: No conversion will be done.
 
Mar 17 11:20:11 2000: Cannot connect -  mycomponent ( this one is from my pb script)
 
It looks like one previous posting related to the character set, isn't it ?
 
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message <17mG6GEk$GA.34@forums.sybase.com>...
Sem,
 
What errors are you seeing when making the call?
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:$ZLsAlDk$GA.261@forums.sybase.com...
Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.
 


Scott McReynolds [Sybase] Posted on 2000-03-17 22:20:08.0Z
Newsgroups: sybase.public.easerver
From: "Scott McReynolds [Sybase]" <scottmc@sybase.com>
Subject: Re: ASE 11.9.2 and jaguar cache
Date: Fri, 17 Mar 2000 15:20:08 -0700
Lines: 288
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0019_01BF9024.47E29FC0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: scottmc-lpt.sybase.com 157.133.56.40
Message-ID: <347_Qp9#M#Fk$GA.261@forums.sybase.com>
References: <347_$ZLsAlDk$GA.261@forums.sybase.com> <347_17mG6GEk$GA.34@forums.sybase.com> <347_J8dCMVEk$GA.285@forums.sybase.com> <347_slqsdYEk$GA.34@forums.sybase.com> <347_Vfl7WzEk$GA.201@forums.sybase.com> <347_8GraDnFk$GA.34@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26152
Article PK: 156829

Sem,
 
The only time you need to recreate stubs is when the method signature changes. 
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:8GraDnFk$GA.34@forums.sybase.com...
I was looking in the posting from Ken Forbes (Feb. 22, 2000 "Help connecting to Sybase 11.5").
Changed only one SQLCA setting :
SQLCA.DBMS="SYJ"
and pb component was able to connect.
I will check again , but seems to me weekend is not so bad.
It would be great if I get an answer about java stub.
 
Regards,
Sem.
 
Sem Kazazic wrote in message ...
Hi Scott,
 
Yes it solved character set error message, but I am still not able to connect from pb component to ase db(CONNECT -> SQLCA.SQLCODE <> 0)
Can you post set of SQLCA params I should have for ASE db and jaguar named connection cache?
Any comment java stub?
 
Thanks.
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message ...
Sem,
 
Yes, change the character set to be the same as your ASE character set "iso_1"
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:J8dCMVEk$GA.285@forums.sybase.com...
----
Mar 17 11:20:11 2000: Server Message: 2409/11/2/ZZZZZ: Cannot find the requested character set in Syscharactersets: name = 'utf8'.
Mar 17 11:20:11 2000: Server Message: 2411/10/1/ZZZZZ: No conversion will be done.
 
Mar 17 11:20:11 2000: Cannot connect -  mycomponent ( this one is from my pb script)
 
It looks like one previous posting related to the character set, isn't it ?
 
Regards,
Sem.
 
Scott McReynolds [Sybase] wrote in message <17mG6GEk$GA.34@forums.sybase.com>...
Sem,
 
What errors are you seeing when making the call?
 
Scott
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:$ZLsAlDk$GA.261@forums.sybase.com...
Hi there,
 
we have jaguar(3.5)  connection cache for ASE 11.9.2 db.
Used jaguar open client and ping from jaguar manager is ok.
We have pb standard component with one method and very simple sql select.
On client side we use powerdynamo script java.createcomponent. We generated stub before and compiled java.
When we call this method first time , it failed, then second call is successful.
If I test connection cache using ping from jagmanager, then first method call is successful too.
It seems to me that first call is getting timeout, but connection is actived and remain open for next call.
 
1. What should be done to make first call successful?
2. During development, should I generate stub ( and compile java) every time I change something in a pb jaguar component even if I do not change method call etc..?
 
Thanks.
Regards,
Sem.