Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Help passing wildcard(%) as page parameter

3 posts in General Discussion (old) Last posting was on 2000-03-02 15:34:57.0Z
Bill Burtnik Posted on 2000-03-01 21:53:01.0Z
Newsgroups: sybase.public.easerver
From: "Bill Burtnik" <bill.burtnik@cyrus-solutions.com>
Organization: 209.167.242.235
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: Help passing wildcard(%) as page parameter
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Wed, 01 Mar 2000 16:53:01 -0500
Lines: 12
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_#I1fDi8g$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27390
Article PK: 158794

Hi, I'm trying to pass a wildcard (%) as a page parameter, but it gets chopped
off by the receiving page.

My param looks like "company_name like 'S%'" from the criteria page but when
received looks like "company_name like 'S

I understand that % is some type of special character. I've tried to wrap it
in double and single quotes without success.

Thanks in advance.
Bill Burtnik
Systems Consultant
Cyrus Solutions Inc


Tod Nguyen Posted on 2000-03-02 00:59:58.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 01 Mar 2000 17:59:58 -0700
From: Tod Nguyen <tod@asiaxpress.com>
X-Mailer: Mozilla 4.61 [en] (WinNT; I)
X-Accept-Language: en,pdf
MIME-Version: 1.0
Subject: Re: Help passing wildcard(%) as page parameter
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 21
NNTP-Posting-Host: 204.97.85.2
Message-ID: <347_38BDBD0E.105CD7BC@asiaxpress.com>
References: <347_#I1fDi8g$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27370
Article PK: 158778

How are you passing the parameter, through the command line i.e.
scrip.ssc?variable="company_name like 'S%'" or through document values when you
include a template or script file? I know there is an escape function you can call
to escape your command line variables before you send it. try escaping it before
passing it.

Tod.

Bill Burtnik wrote:

> Hi, I'm trying to pass a wildcard (%) as a page parameter, but it gets chopped
> off by the receiving page.
>
> My param looks like "company_name like 'S%'" from the criteria page but when
> received looks like "company_name like 'S
>
> I understand that % is some type of special character. I've tried to wrap it
> in double and single quotes without success.
>
> Thanks in advance.
> Bill Burtnik
> Systems Consultant
> Cyrus Solutions Inc


Bill Burtnik Posted on 2000-03-02 15:34:57.0Z
Newsgroups: sybase.public.easerver
From: "Bill Burtnik" <bill.burtnik@cyrus-solutions.com>
Organization: 209.167.242.235
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: Re: Help passing wildcard(%) as page parameter
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Thu, 02 Mar 2000 10:34:57 -0500
Lines: 16
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_j$0bdzFh$GA.251@forums.sybase.com>
References: <347_#I1fDi8g$GA.202@forums.sybase.com> <347_38BDBD0E.105CD7BC@asiaxpress.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27321
Article PK: 154523

Tod, I tried using the escape/unescape with no change to my problem.
I am passing the var as follows. Basically trying to imitate Larry Cermak's
article "Web DW as Criteria Screens".
//Criteria screen:
ls_link = "w_cy_result.htm?modstring=" + escape( data )
parent.bottom.location.href = ls_link ;
//Result Screen:
var crud = unescape( document.value.modstring );
document.WriteLn( crud );

The data string with escape now looks like:
customer.company_name%20Like%20%27S%25%27
where previously it looked like:
customer.company_name Like 'S%'

When received still looks like


>