Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

IIS uses 99% of CPU in IIS/PoweDynamo/Jaguar install

5 posts in General Discussion (old) Last posting was on 2000-02-25 14:05:55.0Z
Walter Maes Posted on 2000-02-24 15:21:05.0Z
Newsgroups: sybase.public.easerver
From: "Walter Maes" <Walter.Maes@sofico.be>
Subject: IIS uses 99% of CPU in IIS/PoweDynamo/Jaguar install
Date: Thu, 24 Feb 2000 16:21:05 +0100
Lines: 13
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: uu194-7-38-102.unknown.uunet.be 194.7.38.102
Message-ID: <347_#eqAWqtf$GA.274@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27935
Article PK: 159630

Has anyone seen the behaviour where IIS "hangs" the system by consuming 99%
of the CPU continuesly. This happens at least once per day on a system where
PowerDynamo is installed as an ISAPI filter calling Jaguar PB components
(customized HTMLGenerator component). The server (Pentium III 500,512 MB) is
never accessed by more then 2 persons at the same time. MS newsgroups
mention that this behaviour has been noticed when "3rd party" ISAPI programs
were used. No other specific software is installed besides PD,Jaguar,PB
VM,IIS .
Regards,
Walter Maes
Sofico N.V.


Michael F. Nicewarner [TeamSybase] Posted on 2000-02-25 14:05:55.0Z
Newsgroups: sybase.public.easerver
From: "Michael F. Nicewarner [TeamSybase]" <mike.nicewarner@ibpinc.com>
Subject: Re: IIS uses 99% of CPU in IIS/PoweDynamo/Jaguar install
Date: Fri, 25 Feb 2000 08:05:55 -0600
Lines: 38
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: secure.ibpinc.com 198.133.192.2
Message-ID: <347_J0mwNo5f$GA.274@forums.sybase.com>
References: <347_#eqAWqtf$GA.274@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27815
Article PK: 154589

The issue I've seen (also 99% from IIS) is when an intense query is
initiated but the user stops it (clicks stop or browser times out). At that
point the IIS thread was fine, but right after that it ramped up to 99% and
hung. This is not an infinite loop or a mishandled return code. Sybase
tech support was able to duplicate the problem, so are tentatively
acknowledging a bug in PD with terminating long-running queries. IMHO, I
think it is running the ODBC connection in Synchronous mode rather than
Async mode. This means that the PD thread handling the query can't respond
to a cancel request from the web server. Just my thoughts, of course.

--

Michael F. Nicewarner [TeamSybase]
mailto:mike.nicewarner@ibpinc.com
http://www.datamodel.org

Walter Maes <Walter.Maes@sofico.be> wrote in message
news:#eqAWqtf$GA.274@forums.sybase.com...
> Has anyone seen the behaviour where IIS "hangs" the system by consuming
99%
> of the CPU continuesly. This happens at least once per day on a system
where
> PowerDynamo is installed as an ISAPI filter calling Jaguar PB components
> (customized HTMLGenerator component). The server (Pentium III 500,512 MB)
is
> never accessed by more then 2 persons at the same time. MS newsgroups
> mention that this behaviour has been noticed when "3rd party" ISAPI
programs
> were used. No other specific software is installed besides PD,Jaguar,PB
> VM,IIS .
> Regards,
> Walter Maes
> Sofico N.V.
>
>


Aaron Wollerton Posted on 2000-02-24 15:50:58.0Z
Newsgroups: sybase.public.easerver
From: "Aaron Wollerton" <aaron_wollerton@hotmail.com>
Subject: Re: IIS uses 99% of CPU in IIS/PoweDynamo/Jaguar install
Date: Thu, 24 Feb 2000 10:50:58 -0500
Lines: 40
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: c206.135.nauticom.net 209.195.135.206
Message-ID: <347_1FGuw8tf$GA.276@forums.sybase.com>
References: <347_#eqAWqtf$GA.274@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27928
Article PK: 154603

Walter,

I have also seen this from time to time. In our case ( with a nearly
identical machine ) this was happening as a result of infinite loops in
javascipt functions.

More specificly, we had Jag components returning positive values if they
completed correctly (like how many users are online) and negative values for
error codes. The javascript functions would then process the results for
display (create a dynamic table of all online users). But the javascript
functions weren't all trapping for the error code, so they would begin a For
loop from 1 to the return from the Jag component, increasing by one each
pass. But of course, starting at one and adding one each pass would never
equal a negative value...

-Aaron Wollerton
Aliah, Inc.

"Walter Maes" <Walter.Maes@sofico.be> wrote in message
news:#eqAWqtf$GA.274@forums.sybase.com...
> Has anyone seen the behaviour where IIS "hangs" the system by consuming
99%
> of the CPU continuesly. This happens at least once per day on a system
where
> PowerDynamo is installed as an ISAPI filter calling Jaguar PB components
> (customized HTMLGenerator component). The server (Pentium III 500,512 MB)
is
> never accessed by more then 2 persons at the same time. MS newsgroups
> mention that this behaviour has been noticed when "3rd party" ISAPI
programs
> were used. No other specific software is installed besides PD,Jaguar,PB
> VM,IIS .
> Regards,
> Walter Maes
> Sofico N.V.
>
>


Walter Maes Posted on 2000-02-24 16:53:27.0Z
Newsgroups: sybase.public.easerver
From: "Walter Maes" <Walter.Maes@sofico.be>
Subject: Re: IIS uses 99% of CPU in IIS/PoweDynamo/Jaguar install
Date: Thu, 24 Feb 2000 17:53:27 +0100
Lines: 53
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: uu194-7-38-102.unknown.uunet.be 194.7.38.102
Message-ID: <347_jLTPBeuf$GA.276@forums.sybase.com>
References: <347_#eqAWqtf$GA.274@forums.sybase.com> <347_1FGuw8tf$GA.276@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27916
Article PK: 159615

Thanks for the reply. It helped alot. It was indeed also a javascript in an
infinitive "For" loop after receiving a wrong "login" return value from a
Jag component (very similar to your case).
Thanks,
Walter

Aaron Wollerton <aaron_wollerton@hotmail.com> wrote in message
news:1FGuw8tf$GA.276@forums.sybase.com...
> Walter,
>
> I have also seen this from time to time. In our case ( with a nearly
> identical machine ) this was happening as a result of infinite loops in
> javascipt functions.
>
> More specificly, we had Jag components returning positive values if they
> completed correctly (like how many users are online) and negative values
for
> error codes. The javascript functions would then process the results for
> display (create a dynamic table of all online users). But the javascript
> functions weren't all trapping for the error code, so they would begin a
For
> loop from 1 to the return from the Jag component, increasing by one each
> pass. But of course, starting at one and adding one each pass would never
> equal a negative value...
>
> -Aaron Wollerton
> Aliah, Inc.
>
>
> "Walter Maes" <Walter.Maes@sofico.be> wrote in message
> news:#eqAWqtf$GA.274@forums.sybase.com...
> > Has anyone seen the behaviour where IIS "hangs" the system by consuming
> 99%
> > of the CPU continuesly. This happens at least once per day on a system
> where
> > PowerDynamo is installed as an ISAPI filter calling Jaguar PB components
> > (customized HTMLGenerator component). The server (Pentium III 500,512
MB)
> is
> > never accessed by more then 2 persons at the same time. MS newsgroups
> > mention that this behaviour has been noticed when "3rd party" ISAPI
> programs
> > were used. No other specific software is installed besides PD,Jaguar,PB
> > VM,IIS .
> > Regards,
> > Walter Maes
> > Sofico N.V.
> >
> >
>
>


Tim Nesham Posted on 2000-02-24 15:43:01.0Z
Newsgroups: sybase.public.easerver
From: "Tim Nesham" <tim.nesham@born.com>
Subject: Re: IIS uses 99% of CPU in IIS/PoweDynamo/Jaguar install
Date: Thu, 24 Feb 2000 09:43:01 -0600
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-Mimeole: Produced By Microsoft MimeOLE V5.00.2919.6600
X-Original-NNTP-Posting-Host: 161.49.6.89
Organization: Quad/Graphics,Inc.
NNTP-Posting-Host: dns2.qgraph.com 206.158.124.2
Message-ID: <347_38b55189@news.qgraph.com>
References: <347_#eqAWqtf$GA.274@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!news.qgraph.com!161.49.6.89
Xref: forums-1-dub sybase.public.easerver:27931
Article PK: 159624

Yes, but it was dependant on what the dyna script was doing. In our case, a
resultset was very large and the dynascript was building an HTML table for
all rows. We converted over to the HTMLDW and life is good again. (Until
the next crisis ....)

"Walter Maes" <Walter.Maes@sofico.be> wrote in message
news:#eqAWqtf$GA.274@forums.sybase.com...
> Has anyone seen the behaviour where IIS "hangs" the system by consuming
99%
> of the CPU continuesly. This happens at least once per day on a system
where
> PowerDynamo is installed as an ISAPI filter calling Jaguar PB components
> (customized HTMLGenerator component). The server (Pentium III 500,512 MB)
is
> never accessed by more then 2 persons at the same time. MS newsgroups
> mention that this behaviour has been noticed when "3rd party" ISAPI
programs
> were used. No other specific software is installed besides PD,Jaguar,PB
> VM,IIS .
> Regards,
> Walter Maes
> Sofico N.V.
>
>