Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

jaguar 3.5: support of java2 and debugging problems

3 posts in General Discussion (old) Last posting was on 2000-02-27 00:23:13.0Z
Olivier Popppon Posted on 2000-02-26 02:14:13.0Z
Newsgroups: sybase.public.easerver
Date: Fri, 25 Feb 2000 18:14:13 -0800
From: Olivier Popppon <olivier.poppon@net-commerce.co.uk>
Organization: Net-Commerce limited
X-Mailer: Mozilla 4.7 [en] (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: jaguar 3.5: support of java2 and debugging problems
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 15
NNTP-Posting-Host: du-028-0107.claranet.co.uk 195.8.84.107
Message-ID: <347_38B736F5.EEE591D8@net-commerce.co.uk>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27787
Article PK: 159140

Hi,

Q1:
I have no problem running servlets with the default jaguar cts 3.5
configuration, which uses jdk118.

But when I want to use the serverstart_jdk122.bat (renaming it to
serverstart), my servlets (the same that worked earlier) can't be
loaded.
(ClassNotFoundException ???).

I tried to change the property in the jaguar manager interface as well
(kowing that when jaguar is started from a batch, it is ignored, but you
never know...).

What should I do ??

Q2:
I develop my servlet using jbuilder. Is there a way to debug my servlets
?

Thanks

Olivier


Mark J. Pfeifer[TeamSybase] Posted on 2000-02-27 00:23:13.0Z
Newsgroups: sybase.public.easerver
From: Mark J. Pfeifer[TeamSybase] <see_msg@sprynet.com>
Subject: Re: jaguar 3.5: support of java2 and debugging problems
Date: Sat, 26 Feb 2000 17:23:13 -0700
Organization: Corporate Technology Partners, Inc.
X-Newsreader: MicroPlanet Gravity v2.20
Lines: 28
NNTP-Posting-Host: dialup-206-26-107-150.mho.net 206.26.107.150
Message-ID: <347_MPG.13221c5dd9f2dd16989717@forums.sybase.com>
References: <347_38B736F5.EEE591D8@net-commerce.co.uk>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27733
Article PK: 159092

In article <38B736F5.EEE591D8@net-commerce.co.uk>, olivier.poppon@net-
commerce.co.uk says...

> Hi,
>
> Q1:
> I have no problem running servlets with the default jaguar cts 3.5
> configuration, which uses jdk118.
>
> But when I want to use the serverstart_jdk122.bat (renaming it to
> serverstart), my servlets (the same that worked earlier) can't be
> loaded.
> (ClassNotFoundException ???).

As Dave stated - make sure the files are in the proper class directories.
Then install the Servlet. Make sure you refresh and restart the servlet.
If you get errors there keep trying. Then one thing is to recycle the
server. I too had problems getting the servlets installed but trying to
refresh and restart the servlet seemed to help.

HTH
Mark

--

Mark J. Pfeifer[TeamSybase] Corporate Technology Partners, Inc.
mpfeifer @ sprynet.com Emerging Technology Solutions
www.ctpartners.com

Upcoming Events: (http://www.sybase.com/events)

* Build the Future - Phoenix, AZ and Stamford, CT
* WhistleStop - Denver, CO and Chicago, IL


Dave Wolf [Sybase] Posted on 2000-02-26 15:11:53.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: jaguar 3.5: support of java2 and debugging problems
Date: Sat, 26 Feb 2000 10:11:53 -0500
Lines: 44
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: vpn-eme-013.sybase.com 130.214.8.13
Message-ID: <347_v4awWxGg$GA.202@forums.sybase.com>
References: <347_38B736F5.EEE591D8@net-commerce.co.uk>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27747
Article PK: 159105


"Olivier Popppon" <olivier.poppon@net-commerce.co.uk> wrote in message
news:38B736F5.EEE591D8@net-commerce.co.uk...
> Hi,
>
> Q1:
> I have no problem running servlets with the default jaguar cts 3.5
> configuration, which uses jdk118.
>
> But when I want to use the serverstart_jdk122.bat (renaming it to
> serverstart), my servlets (the same that worked earlier) can't be
> loaded.
> (ClassNotFoundException ???).

Are the missing classes under html/classes or java/classes?

>
> I tried to change the property in the jaguar manager interface as well
> (kowing that when jaguar is started from a batch, it is ignored, but you
> never know...).

Tha display in JagMan is read only. Can you be sure to move all the classes
into html/classes or java/classes?

>
> What should I do ??
>
> Q2:
> I develop my servlet using jbuilder. Is there a way to debug my servlets
> ?

If jBuilder can do remote debugging to a Java2 VM then yes. I honetly dont
know if they can.

Dave Wolf
Internet Applications Division

>
> Thanks
>
> Olivier
>