Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ftp problem on dynamo 3.0.0.652?

3 posts in General Discussion (old) Last posting was on 2000-03-03 22:09:40.0Z
Tod Nguyen Posted on 2000-03-01 19:22:30.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 01 Mar 2000 12:22:30 -0700
From: Tod Nguyen <tod@asiaxpress.com>
X-Mailer: Mozilla 4.61 [en] (WinNT; I)
X-Accept-Language: en,pdf
MIME-Version: 1.0
Subject: ftp problem on dynamo 3.0.0.652?
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 10
NNTP-Posting-Host: 204.97.85.2
Message-ID: <347_38BD6DF6.50C2BD67@asiaxpress.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27410
Article PK: 154534

I have experienced a problem using the ftp object in pd 3.0.0.652, it
just won't work!

we have 2 environment, a dev and a production. the dev is on pd
3.0.0.692 and the production is on 3.0.0.652. The ftp code works great
on dev, but won't work on production. Is this a known bug in 3.0.0.652?

I'm trying to figure this out before we are forced to upgrade.

thanks.


Tod Nguyen Posted on 2000-03-02 00:27:42.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 01 Mar 2000 17:27:42 -0700
From: Tod Nguyen <tod@asiaxpress.com>
X-Mailer: Mozilla 4.61 [en] (WinNT; I)
X-Accept-Language: en,pdf
MIME-Version: 1.0
Subject: Re: ftp problem on dynamo 3.0.0.652?
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 53
NNTP-Posting-Host: 204.97.85.2
Message-ID: <347_38BDB57E.B7C2D2E5@asiaxpress.com>
References: <347_38BD6DF6.50C2BD67@asiaxpress.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27371
Article PK: 158779

Here's an update:

we upgraded production our production box to 3.5 pd hoping that the new
version of Dynamo will fix this "FTP" error bug, and it still don't work!
I'm getting the error message:

"Warning: undefined variable FTP near line 15 Error: Cannot establish ftp
connection. 63.70.221.8"

which points to this line:
ftpSession = new FTP ("63.xxx.xxx.xxx", "loginname", "password");

below is all the code up to the point of failure, here's the code snipids:
(i typed in the line # for your convenience. :)

1 <!--SCRIPT deploy_joposting.ssc created on Mon, 31 Jan 2000 16:01:46
2 //
3 //
4 //
5 args = document.value;
6
7 // Open the ftp list file to get names of file to ftp to the extranet.

8 inputFile = new File ('c:\\employment_opportunity\\ftp_list.txt', "r"
);
9 if (inputFile == null) {
10 document.writeln('Error: Cannot open
"c:\\employment_opportunity\\ftp_list.txt".');
11 exit;
12 }
13
14 // Create a FTP Object. 63.70.221.8 is one of Encore's Extranet
servers.
15 ftpSession = new FTP ("63.xxx.xxx.xxx", "loginname", "password");
16 if (ftpSession == null) {
17 document.writeln('Error: Cannot establish ftp connection.
63.70.221.8');
18 exit;
19 }
20
...more code not shown
-->

I tried just the FTP constructor in a test file to just connect and
disconnect, and it gave the same message. FTP is a reserved word, I don't
understand what Dynamo is complaining about! It works on the development
server, but not on the production server... :(

I'm running out of ideas, any suggestion is greatly appreciated.

Thanks in advanced.


Tod.

Tod Nguyen wrote:

> I have experienced a problem using the ftp object in pd 3.0.0.652, it
> just won't work!
>
> we have 2 environment, a dev and a production. the dev is on pd
> 3.0.0.692 and the production is on 3.0.0.652. The ftp code works great
> on dev, but won't work on production. Is this a known bug in 3.0.0.652?
>
> I'm trying to figure this out before we are forced to upgrade.
>
> thanks.


Tod Nguyen Posted on 2000-03-03 22:09:40.0Z
Newsgroups: sybase.public.easerver
Date: Fri, 03 Mar 2000 15:09:40 -0700
From: Tod Nguyen <tod@asiaxpress.com>
X-Mailer: Mozilla 4.61 [en] (WinNT; I)
X-Accept-Language: en,pdf
MIME-Version: 1.0
Subject: Re: ftp problem on dynamo 3.0.0.652?
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 68
NNTP-Posting-Host: 204.97.85.2
Message-ID: <347_38C03823.84B0562D@asiaxpress.com>
References: <347_38BD6DF6.50C2BD67@asiaxpress.com> <347_38BDB57E.B7C2D2E5@asiaxpress.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27182
Article PK: 158099

Last update:

Since I got no suggestions on how to fix this problem from this board, I've
chose to implement the ftp through a different approach using the system.exec()
function. Instead of ftping the files from a list of file names, I've created
an FTP batch file to ftp to the remote site. This fixed my problem, but I'm not
happy about the solution, it's a bit less clear than using the dynamo FTP
object implementation.

Tod.

Tod Nguyen wrote:

> Here's an update:
>
> we upgraded production our production box to 3.5 pd hoping that the new
> version of Dynamo will fix this "FTP" error bug, and it still don't work!
> I'm getting the error message:
>
> "Warning: undefined variable FTP near line 15 Error: Cannot establish ftp
> connection. 63.70.221.8"
>
> which points to this line:
> ftpSession = new FTP ("63.xxx.xxx.xxx", "loginname", "password");
>
> below is all the code up to the point of failure, here's the code snipids:
> (i typed in the line # for your convenience. :)
>
> 1 <!--SCRIPT deploy_joposting.ssc created on Mon, 31 Jan 2000 16:01:46
> 2 //
> 3 //
> 4 //
> 5 args = document.value;
> 6
> 7 // Open the ftp list file to get names of file to ftp to the extranet.
>
> 8 inputFile = new File ('c:\\employment_opportunity\\ftp_list.txt', "r"
> );
> 9 if (inputFile == null) {
> 10 document.writeln('Error: Cannot open
> "c:\\employment_opportunity\\ftp_list.txt".');
> 11 exit;
> 12 }
> 13
> 14 // Create a FTP Object. 63.70.221.8 is one of Encore's Extranet
> servers.
> 15 ftpSession = new FTP ("63.xxx.xxx.xxx", "loginname", "password");
> 16 if (ftpSession == null) {
> 17 document.writeln('Error: Cannot establish ftp connection.
> 63.70.221.8');
> 18 exit;
> 19 }
> 20
> ...more code not shown
> -->
>
> I tried just the FTP constructor in a test file to just connect and
> disconnect, and it gave the same message. FTP is a reserved word, I don't
> understand what Dynamo is complaining about! It works on the development
> server, but not on the production server... :(
>
> I'm running out of ideas, any suggestion is greatly appreciated.
>
> Thanks in advanced.
>
> Tod.
>
> Tod Nguyen wrote:
>
> > I have experienced a problem using the ftp object in pd 3.0.0.652, it
> > just won't work!
> >
> > we have 2 environment, a dev and a production. the dev is on pd
> > 3.0.0.692 and the production is on 3.0.0.652. The ftp code works great
> > on dev, but won't work on production. Is this a known bug in 3.0.0.652?
> >
> > I'm trying to figure this out before we are forced to upgrade.
> >
> > thanks.