Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Accessing EJB from dynamo

2 posts in General Discussion (old) Last posting was on 2000-03-17 07:50:11.0Z
Roy Patrick Tan Posted on 2000-03-17 06:45:54.0Z
Newsgroups: sybase.public.easerver
Date: Fri, 17 Mar 2000 14:45:54 +0800
From: Roy Patrick Tan <royt@8layer.com>
X-Mailer: Mozilla 4.6 [en] (Win98; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Accessing EJB from dynamo
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 15
NNTP-Posting-Host: 203.120.23.151
Message-ID: <347_38D1D4A2.84817268@8layer.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26231
Article PK: 156900

I have a stateless session bean called HelloBean in a Jaguar server.
HelloBean has one method called "HelloWorld()" which returns a "Hello
World!" String.

I try to access the bean from Dynamo thus:

<!--Script
var comp, compHome, str;
compHome = java.GetHomeInterface("HelloBean",
"iiop://localhost:9000", "jagadmin", "jagadmin");
comp = compHome.create();
str = comp.HelloWorld();
document.write(str);
-->

but instead of the "Hello World!" string being displayed on the page, I
get the word "null". What am I doing wrong?


Roy Patrick Tan Posted on 2000-03-17 07:50:11.0Z
Newsgroups: sybase.public.easerver
Date: Fri, 17 Mar 2000 15:50:11 +0800
From: Roy Patrick Tan <royt@8layer.com>
X-Mailer: Mozilla 4.6 [en] (Win98; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Accessing EJB from dynamo
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 19
NNTP-Posting-Host: 203.120.23.151
Message-ID: <347_38D1E3B3.4316E634@8layer.com>
References: <347_38D1D4A2.84817268@8layer.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26230
Article PK: 156899

Solved it. My mistake, the problem was with the EJB, not the dynamo script,
which worked fine after I deployed the fixed EJB....

Roy Patrick Tan wrote:

> I have a stateless session bean called HelloBean in a Jaguar server.
> HelloBean has one method called "HelloWorld()" which returns a "Hello
> World!" String.
>
> I try to access the bean from Dynamo thus:
>
> <!--Script
> var comp, compHome, str;
> compHome = java.GetHomeInterface("HelloBean",
> "iiop://localhost:9000", "jagadmin", "jagadmin");
> comp = compHome.create();
> str = comp.HelloWorld();
> document.write(str);
> -->
>
> but instead of the "Hello World!" string being displayed on the page, I
> get the word "null". What am I doing wrong?