Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Connection Cache Props File Problem

5 posts in General Discussion (old) Last posting was on 2000-03-29 18:58:14.0Z
Dash Wendrzyk Posted on 2000-03-29 15:18:36.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 29 Mar 2000 10:18:36 -0500
From: Dash Wendrzyk <dash@sulu.orl.lmco.com>
X-Mailer: Mozilla 4.7 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Connection Cache Props File Problem
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 19
NNTP-Posting-Host: edge2a.lmco.com 192.91.147.1
Message-ID: <347_38E21ECC.1CABD9F@sulu.orl.lmco.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25377
Article PK: 154302

I recently installed Jaguar CTS 3.5 on NT 4.0. I had been running
3.0.1.

I set up my connection cache named EC and copied my EC.props file into
the %JAGUAR%/Repository/ConnCache directory. The EC.props file is
setting the CHARSET=iso_1 to fix a sun.io.CharToByte bug that is
involved in using the com.sybase.jdbc.SybDriver.

However, the connection cache seems to ignore the EC.props file. I have
even tried to change the CHARSET_CONVERTER_CLASS to use the
TruncationConverter and it keeps using the sun.io converter. I have
rebooted several times after changing the various properties.

Is there anything that I need to set up so that the Connection Cache
will start reading the props file?

Thanks.

--
Dash


Dave Wolf [Sybase] Posted on 2000-03-29 15:32:06.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: Connection Cache Props File Problem
Date: Wed, 29 Mar 2000 10:32:06 -0500
Lines: 43
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: dwolf-nt.sybase.com 157.133.41.61
Message-ID: <347_xBwbVSZm$GA.52@forums.sybase.com>
References: <347_38E21ECC.1CABD9F@sulu.orl.lmco.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25373
Article PK: 155471

I cant reproduce this. My 3.5 seems to be reading the props file OK. I
tested by setting

com.sybase.jaguar.conncache.ssa=true and trying to ping. It failed as
expected b/c userid jagadmin is not in my database.

You can work around the issue with the props file by adding to the end of
the server URL so

jdbc:sybase:Tds:myhost:5000?CHARSET=iso_1

I dont know why your props file isnt working. Id open a case with support
but the above witll fix it for now.

Dave Wolf
Internet Applications Division

"Dash Wendrzyk" <dash@sulu.orl.lmco.com> wrote in message
news:38E21ECC.1CABD9F@sulu.orl.lmco.com...
> I recently installed Jaguar CTS 3.5 on NT 4.0. I had been running
> 3.0.1.
>
> I set up my connection cache named EC and copied my EC.props file into
> the %JAGUAR%/Repository/ConnCache directory. The EC.props file is
> setting the CHARSET=iso_1 to fix a sun.io.CharToByte bug that is
> involved in using the com.sybase.jdbc.SybDriver.
>
> However, the connection cache seems to ignore the EC.props file. I have
> even tried to change the CHARSET_CONVERTER_CLASS to use the
> TruncationConverter and it keeps using the sun.io converter. I have
> rebooted several times after changing the various properties.
>
> Is there anything that I need to set up so that the Connection Cache
> will start reading the props file?
>
> Thanks.
>
> --
> Dash
>
>


Dash Wendrzyk Posted on 2000-03-29 18:02:26.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 29 Mar 2000 13:02:26 -0500
From: Dash Wendrzyk <dash@sulu.orl.lmco.com>
X-Mailer: Mozilla 4.7 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Connection Cache Props File Problem
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 50
NNTP-Posting-Host: edge2a.lmco.com 192.91.147.1
Message-ID: <347_38E24532.C35735A6@sulu.orl.lmco.com>
References: <347_38E21ECC.1CABD9F@sulu.orl.lmco.com> <347_xBwbVSZm$GA.52@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25345
Article PK: 155445

Dave,

The work around fixed the problem for now. Thanks.

Apparently, the props file is being read, though. I put the
com.sybase.jaguar.conncache.ssa=true in the props file and it failed as
expected. I added the CHARSET=iso_1 entry along with the ssa=true and the
ping would hang. The conversion error still shows up in the srv.log, but no
error is ever returned to the Jaguar Manager and the ping never returns.

Thanks for your help.

"Dave Wolf [Sybase]" wrote:

> I cant reproduce this. My 3.5 seems to be reading the props file OK. I
> tested by setting
>
> com.sybase.jaguar.conncache.ssa=true and trying to ping. It failed as
> expected b/c userid jagadmin is not in my database.
>
> You can work around the issue with the props file by adding to the end of
> the server URL so
>
> jdbc:sybase:Tds:myhost:5000?CHARSET=iso_1
>
> I dont know why your props file isnt working. Id open a case with support
> but the above witll fix it for now.
>
> Dave Wolf
> Internet Applications Division
>
> "Dash Wendrzyk" <dash@sulu.orl.lmco.com> wrote in message
> news:38E21ECC.1CABD9F@sulu.orl.lmco.com...
> > I recently installed Jaguar CTS 3.5 on NT 4.0. I had been running
> > 3.0.1.
> >
> > I set up my connection cache named EC and copied my EC.props file into
> > the %JAGUAR%/Repository/ConnCache directory. The EC.props file is
> > setting the CHARSET=iso_1 to fix a sun.io.CharToByte bug that is
> > involved in using the com.sybase.jdbc.SybDriver.
> >
> > However, the connection cache seems to ignore the EC.props file. I have
> > even tried to change the CHARSET_CONVERTER_CLASS to use the
> > TruncationConverter and it keeps using the sun.io converter. I have
> > rebooted several times after changing the various properties.
> >
> > Is there anything that I need to set up so that the Connection Cache
> > will start reading the props file?
> >
> > Thanks.
> >
> > --
> > Dash
> >
> >


Dave Wolf [Sybase] Posted on 2000-03-29 18:14:38.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: Connection Cache Props File Problem
Date: Wed, 29 Mar 2000 13:14:38 -0500
Lines: 70
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: dwolf-nt.sybase.com 157.133.41.61
Message-ID: <347_#HrgJtam$GA.201@forums.sybase.com>
References: <347_38E21ECC.1CABD9F@sulu.orl.lmco.com> <347_xBwbVSZm$GA.52@forums.sybase.com> <347_38E24532.C35735A6@sulu.orl.lmco.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25344
Article PK: 155443

Can you open a case on this?

Dave Wolf
Internet Applications Division

"Dash Wendrzyk" <dash@sulu.orl.lmco.com> wrote in message
news:38E24532.C35735A6@sulu.orl.lmco.com...
> Dave,
>
> The work around fixed the problem for now. Thanks.
>
> Apparently, the props file is being read, though. I put the
> com.sybase.jaguar.conncache.ssa=true in the props file and it failed as
> expected. I added the CHARSET=iso_1 entry along with the ssa=true and the
> ping would hang. The conversion error still shows up in the srv.log, but
no
> error is ever returned to the Jaguar Manager and the ping never returns.
>
> Thanks for your help.
>
>
> "Dave Wolf [Sybase]" wrote:
>
> > I cant reproduce this. My 3.5 seems to be reading the props file OK. I
> > tested by setting
> >
> > com.sybase.jaguar.conncache.ssa=true and trying to ping. It failed as
> > expected b/c userid jagadmin is not in my database.
> >
> > You can work around the issue with the props file by adding to the end
of
> > the server URL so
> >
> > jdbc:sybase:Tds:myhost:5000?CHARSET=iso_1
> >
> > I dont know why your props file isnt working. Id open a case with
support
> > but the above witll fix it for now.
> >
> > Dave Wolf
> > Internet Applications Division
> >
> > "Dash Wendrzyk" <dash@sulu.orl.lmco.com> wrote in message
> > news:38E21ECC.1CABD9F@sulu.orl.lmco.com...
> > > I recently installed Jaguar CTS 3.5 on NT 4.0. I had been running
> > > 3.0.1.
> > >
> > > I set up my connection cache named EC and copied my EC.props file into
> > > the %JAGUAR%/Repository/ConnCache directory. The EC.props file is
> > > setting the CHARSET=iso_1 to fix a sun.io.CharToByte bug that is
> > > involved in using the com.sybase.jdbc.SybDriver.
> > >
> > > However, the connection cache seems to ignore the EC.props file. I
have
> > > even tried to change the CHARSET_CONVERTER_CLASS to use the
> > > TruncationConverter and it keeps using the sun.io converter. I have
> > > rebooted several times after changing the various properties.
> > >
> > > Is there anything that I need to set up so that the Connection Cache
> > > will start reading the props file?
> > >
> > > Thanks.
> > >
> > > --
> > > Dash
> > >
> > >
>


Dash Wendrzyk Posted on 2000-03-29 18:58:14.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 29 Mar 2000 13:58:14 -0500
From: Dash Wendrzyk <dash@sulu.orl.lmco.com>
X-Mailer: Mozilla 4.7 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Connection Cache Props File Problem
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 62
NNTP-Posting-Host: edge2a.lmco.com 192.91.147.1
Message-ID: <347_38E25246.B338A741@sulu.orl.lmco.com>
References: <347_38E21ECC.1CABD9F@sulu.orl.lmco.com> <347_xBwbVSZm$GA.52@forums.sybase.com> <347_38E24532.C35735A6@sulu.orl.lmco.com> <347_#HrgJtam$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25336
Article PK: 155436

Sure.

"Dave Wolf [Sybase]" wrote:

> Can you open a case on this?
>
> Dave Wolf
> Internet Applications Division
>
> "Dash Wendrzyk" <dash@sulu.orl.lmco.com> wrote in message
> news:38E24532.C35735A6@sulu.orl.lmco.com...
> > Dave,
> >
> > The work around fixed the problem for now. Thanks.
> >
> > Apparently, the props file is being read, though. I put the
> > com.sybase.jaguar.conncache.ssa=true in the props file and it failed as
> > expected. I added the CHARSET=iso_1 entry along with the ssa=true and the
> > ping would hang. The conversion error still shows up in the srv.log, but
> no
> > error is ever returned to the Jaguar Manager and the ping never returns.
> >
> > Thanks for your help.
> >
> >
> > "Dave Wolf [Sybase]" wrote:
> >
> > > I cant reproduce this. My 3.5 seems to be reading the props file OK. I
> > > tested by setting
> > >
> > > com.sybase.jaguar.conncache.ssa=true and trying to ping. It failed as
> > > expected b/c userid jagadmin is not in my database.
> > >
> > > You can work around the issue with the props file by adding to the end
> of
> > > the server URL so
> > >
> > > jdbc:sybase:Tds:myhost:5000?CHARSET=iso_1
> > >
> > > I dont know why your props file isnt working. Id open a case with
> support
> > > but the above witll fix it for now.
> > >
> > > Dave Wolf
> > > Internet Applications Division
> > >
> > > "Dash Wendrzyk" <dash@sulu.orl.lmco.com> wrote in message
> > > news:38E21ECC.1CABD9F@sulu.orl.lmco.com...
> > > > I recently installed Jaguar CTS 3.5 on NT 4.0. I had been running
> > > > 3.0.1.
> > > >
> > > > I set up my connection cache named EC and copied my EC.props file into
> > > > the %JAGUAR%/Repository/ConnCache directory. The EC.props file is
> > > > setting the CHARSET=iso_1 to fix a sun.io.CharToByte bug that is
> > > > involved in using the com.sybase.jdbc.SybDriver.
> > > >
> > > > However, the connection cache seems to ignore the EC.props file. I
> have
> > > > even tried to change the CHARSET_CONVERTER_CLASS to use the
> > > > TruncationConverter and it keeps using the sun.io converter. I have
> > > > rebooted several times after changing the various properties.
> > > >
> > > > Is there anything that I need to set up so that the Connection Cache
> > > > will start reading the props file?
> > > >
> > > > Thanks.
> > > >
> > > > --
> > > > Dash
> > > >
> > > >
> >