Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

SetAction fails with -1 when PageNext

5 posts in General Discussion (old) Last posting was on 2000-04-03 13:10:31.0Z
Tim Nesham Posted on 2000-03-30 22:46:24.0Z
Newsgroups: sybase.public.easerver
From: "Tim Nesham" <tim.nesham@born.com>
Subject: SetAction fails with -1 when PageNext
Date: Thu, 30 Mar 2000 16:46:24 -0600
Lines: 13
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
X-Original-NNTP-Posting-Host: 161.49.6.89
Organization: Quad/Graphics,Inc.
NNTP-Posting-Host: dns2.qgraph.com 206.158.124.2
Message-ID: <347_38e3d943@news.qgraph.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!news.qgraph.com!161.49.6.89
Xref: forums-1-dub sybase.public.easerver:25165
Article PK: 154264

SetAction fails with -1 when ScrollNextPage() is called. The context and
action are passed ok.

Any ideas why it gives -1? I have absolutely no other errors. Nothing in
svr.log.


TIA,

Tim


Larry Cermak[Team Sybase] Posted on 2000-03-31 02:18:52.0Z
Newsgroups: sybase.public.easerver
From: "Larry Cermak[Team Sybase]" <lcermak@ctpartners.com>
Subject: Re: SetAction fails with -1 when PageNext
Date: Thu, 30 Mar 2000 20:18:52 -0600
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: node18.dhcpchi.dslspeed.zyan.com 208.41.199.18
Message-ID: <347_ugi7Ckrm$GA.52@forums.sybase.com>
References: <347_38e3d943@news.qgraph.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25152
Article PK: 154251

Hi Tim,

That means the current context could not be reloaded. Are you doing a
retrieve and is that possibly failing when the page is refreshed?

Any service class code that might be failing on the server?

--

Larry Cermak [Team Sybase]
Corporate Technology Partners, Inc.
www.ctpartners.com
Web DataWindow Articles
(http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)

Web DataWindow Training
EAServer Training

"Tim Nesham" <tim.nesham@born.com> wrote in message
news:38e3d943@news.qgraph.com...
> SetAction fails with -1 when ScrollNextPage() is called. The context and
> action are passed ok.
>
> Any ideas why it gives -1? I have absolutely no other errors. Nothing in
> svr.log.
>
>
> TIA,
>
> Tim
>
>
>


Tim Nesham Posted on 2000-03-31 15:20:35.0Z
Newsgroups: sybase.public.easerver
From: "Tim Nesham" <tim.nesham@born.com>
Subject: Re: SetAction fails with -1 when PageNext
Date: Fri, 31 Mar 2000 09:20:35 -0600
Lines: 66
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
X-Original-NNTP-Posting-Host: 161.49.6.89
Organization: Quad/Graphics,Inc.
NNTP-Posting-Host: dns2.qgraph.com 206.158.124.2
Message-ID: <347_38e4c248@news.qgraph.com>
References: <347_38e3d943@news.qgraph.com> <347_ugi7Ckrm$GA.52@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!news.qgraph.com!161.49.6.89
Xref: forums-1-dub sybase.public.easerver:25102
Article PK: 154201

Thanks Larry,
Well since you have some prior knowledge of this problem. FYI, the image tag
I was using was inside a HTML FORM and the page params were not passed
correctly. Apparently it had to do with which FORM was involved with the
SUBMIT. I got rid of the FORM and the params are passed correctly. Now back
to the current problem.

What do you mean "am I doing a retrieve"? I am doing a PageNext, the
retrieve was always there. I get no errors from the retrieve. But I am
wondering about the SetSelfLink. Since we are getting the retrieve args
from the Session object, is the SetSelfLink ok as below?

var ls_err = dwMine.SetSelfLink(document.name,"");
var lsRetrievalArgs = QGSessionUtils.getSessionVar("ssTitleCode");
var ll_rows = dwMine.RetrieveEx(lsRetrievalArgs);
TestError(ll_rows, "Retrieve");
var dwMine_action = GetParam("dwMine_action");
var dwMine_context = GetParam("dwMine_context");
if (dwMine_action != "") {
retVal = dwMine.SetAction (dwMine_action, dwMine_context);
TestError(retVal, dwMine_action);
}
document.writeln(dwMine.Generate());

"Larry Cermak[Team Sybase]" <lcermak@ctpartners.com> wrote in message
news:ugi7Ckrm$GA.52@forums.sybase.com...
> Hi Tim,
>
> That means the current context could not be reloaded. Are you doing a
> retrieve and is that possibly failing when the page is refreshed?
>
> Any service class code that might be failing on the server?
>
> --
>
> Larry Cermak [Team Sybase]
> Corporate Technology Partners, Inc.
> www.ctpartners.com
> Web DataWindow Articles
> (http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)
>
> Web DataWindow Training
> EAServer Training
>
> "Tim Nesham" <tim.nesham@born.com> wrote in message
> news:38e3d943@news.qgraph.com...
> > SetAction fails with -1 when ScrollNextPage() is called. The context
and
> > action are passed ok.
> >
> > Any ideas why it gives -1? I have absolutely no other errors. Nothing
in
> > svr.log.
> >
> >
> > TIA,
> >
> > Tim
> >
> >
> >
>
>


Larry Cermak[Team Sybase] Posted on 2000-04-02 06:23:40.0Z
Newsgroups: sybase.public.easerver
From: "Larry Cermak[Team Sybase]" <lcermak@ctpartners.com>
Subject: Re: SetAction fails with -1 when PageNext
Date: Sun, 2 Apr 2000 00:23:40 -0600
Lines: 91
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: node18.dhcpchi.dslspeed.zyan.com 208.41.199.18
Message-ID: <347_eWkJI3Gn$GA.316@forums.sybase.com>
References: <347_38e3d943@news.qgraph.com> <347_ugi7Ckrm$GA.52@forums.sybase.com> <347_38e4c248@news.qgraph.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:24993
Article PK: 154127

OK now I see what's happening. The selflink is fine because nothing is
being passed into the page. Have you checked to see if the session variable
has possibly expired?

When you get -1, do a Describe and get the SQL statement and see if there's
anything funny there.

--

Larry Cermak [Team Sybase]
Corporate Technology Partners, Inc.
www.ctpartners.com
Web DataWindow Articles
(http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)

Web DataWindow Training
EAServer Training

"Tim Nesham" <tim.nesham@born.com> wrote in message
news:38e4c248@news.qgraph.com...
> Thanks Larry,
> Well since you have some prior knowledge of this problem. FYI, the image
tag
> I was using was inside a HTML FORM and the page params were not passed
> correctly. Apparently it had to do with which FORM was involved with the
> SUBMIT. I got rid of the FORM and the params are passed correctly. Now
back
> to the current problem.
>
> What do you mean "am I doing a retrieve"? I am doing a PageNext, the
> retrieve was always there. I get no errors from the retrieve. But I am
> wondering about the SetSelfLink. Since we are getting the retrieve args
> from the Session object, is the SetSelfLink ok as below?
>
> var ls_err = dwMine.SetSelfLink(document.name,"");
> var lsRetrievalArgs = QGSessionUtils.getSessionVar("ssTitleCode");
> var ll_rows = dwMine.RetrieveEx(lsRetrievalArgs);
> TestError(ll_rows, "Retrieve");
> var dwMine_action = GetParam("dwMine_action");
> var dwMine_context = GetParam("dwMine_context");
> if (dwMine_action != "") {
> retVal = dwMine.SetAction (dwMine_action, dwMine_context);
> TestError(retVal, dwMine_action);
> }
> document.writeln(dwMine.Generate());
>
>
> "Larry Cermak[Team Sybase]" <lcermak@ctpartners.com> wrote in message
> news:ugi7Ckrm$GA.52@forums.sybase.com...
> > Hi Tim,
> >
> > That means the current context could not be reloaded. Are you doing a
> > retrieve and is that possibly failing when the page is refreshed?
> >
> > Any service class code that might be failing on the server?
> >
> > --
> >
> > Larry Cermak [Team Sybase]
> > Corporate Technology Partners, Inc.
> > www.ctpartners.com
> > Web DataWindow Articles
> > (http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)
> >
> > Web DataWindow Training
> > EAServer Training
> >
> > "Tim Nesham" <tim.nesham@born.com> wrote in message
> > news:38e3d943@news.qgraph.com...
> > > SetAction fails with -1 when ScrollNextPage() is called. The context
> and
> > > action are passed ok.
> > >
> > > Any ideas why it gives -1? I have absolutely no other errors.
Nothing
> in
> > > svr.log.
> > >
> > >
> > > TIA,
> > >
> > > Tim
> > >
> > >
> > >
> >
> >
>
>


Tim Nesham Posted on 2000-04-03 13:10:31.0Z
Newsgroups: sybase.public.easerver
From: "Tim Nesham" <tim.nesham@born.com>
Subject: Re: SetAction fails with -1 when PageNext
Date: Mon, 3 Apr 2000 08:10:31 -0500
Lines: 107
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
X-Original-NNTP-Posting-Host: 161.49.6.89
Organization: Quad/Graphics,Inc.
NNTP-Posting-Host: dns2.qgraph.com 206.158.124.2
Message-ID: <347_38e8984c@news.qgraph.com>
References: <347_38e3d943@news.qgraph.com> <347_ugi7Ckrm$GA.52@forums.sybase.com> <347_38e4c248@news.qgraph.com> <347_eWkJI3Gn$GA.316@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!news.qgraph.com!161.49.6.89
Xref: forums-1-dub sybase.public.easerver:24952
Article PK: 154110

Interestingly the line:
dwMine.SetServerServiceClasses("n_ds_mat_paper_service;");
was causing the SetAction to fail. If I comment it out then the retrieve
works. The Service was looping through the rows on the RetrieveEnd event
and resetting the data in a column using Setitem.

Any ideas why this interferes with SetAction?

"Larry Cermak[Team Sybase]" <lcermak@ctpartners.com> wrote in message
news:eWkJI3Gn$GA.316@forums.sybase.com...
> OK now I see what's happening. The selflink is fine because nothing is
> being passed into the page. Have you checked to see if the session
variable
> has possibly expired?
>
> When you get -1, do a Describe and get the SQL statement and see if
there's
> anything funny there.
>
> --
>
> Larry Cermak [Team Sybase]
> Corporate Technology Partners, Inc.
> www.ctpartners.com
> Web DataWindow Articles
> (http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)
>
> Web DataWindow Training
> EAServer Training
>
> "Tim Nesham" <tim.nesham@born.com> wrote in message
> news:38e4c248@news.qgraph.com...
> > Thanks Larry,
> > Well since you have some prior knowledge of this problem. FYI, the image
> tag
> > I was using was inside a HTML FORM and the page params were not passed
> > correctly. Apparently it had to do with which FORM was involved with
the
> > SUBMIT. I got rid of the FORM and the params are passed correctly. Now
> back
> > to the current problem.
> >
> > What do you mean "am I doing a retrieve"? I am doing a PageNext, the
> > retrieve was always there. I get no errors from the retrieve. But I am
> > wondering about the SetSelfLink. Since we are getting the retrieve args
> > from the Session object, is the SetSelfLink ok as below?
> >
> > var ls_err = dwMine.SetSelfLink(document.name,"");
> > var lsRetrievalArgs = QGSessionUtils.getSessionVar("ssTitleCode");
> > var ll_rows = dwMine.RetrieveEx(lsRetrievalArgs);
> > TestError(ll_rows, "Retrieve");
> > var dwMine_action = GetParam("dwMine_action");
> > var dwMine_context = GetParam("dwMine_context");
> > if (dwMine_action != "") {
> > retVal = dwMine.SetAction (dwMine_action, dwMine_context);
> > TestError(retVal, dwMine_action);
> > }
> > document.writeln(dwMine.Generate());
> >
> >
> > "Larry Cermak[Team Sybase]" <lcermak@ctpartners.com> wrote in message
> > news:ugi7Ckrm$GA.52@forums.sybase.com...
> > > Hi Tim,
> > >
> > > That means the current context could not be reloaded. Are you doing a
> > > retrieve and is that possibly failing when the page is refreshed?
> > >
> > > Any service class code that might be failing on the server?
> > >
> > > --
> > >
> > > Larry Cermak [Team Sybase]
> > > Corporate Technology Partners, Inc.
> > > www.ctpartners.com
> > > Web DataWindow Articles
> > > (http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)
> > >
> > > Web DataWindow Training
> > > EAServer Training
> > >
> > > "Tim Nesham" <tim.nesham@born.com> wrote in message
> > > news:38e3d943@news.qgraph.com...
> > > > SetAction fails with -1 when ScrollNextPage() is called. The
context
> > and
> > > > action are passed ok.
> > > >
> > > > Any ideas why it gives -1? I have absolutely no other errors.
> Nothing
> > in
> > > > svr.log.
> > > >
> > > >
> > > > TIA,
> > > >
> > > > Tim
> > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>