Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

request for help on sending mail from dynamo example

5 posts in General Discussion (old) Last posting was on 2000-03-10 13:38:54.0Z
Thanh Posted on 2000-03-09 17:36:15.0Z
Newsgroups: sybase.public.easerver
From: "Thanh" <tle@firstam.com>
Subject: request for help on sending mail from dynamo example
Date: Thu, 9 Mar 2000 09:36:15 -0800
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: pixout.firstam.com 209.211.240.254
Message-ID: <347_4QnSq6ei$GA.74@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26779
Article PK: 157756

Could someone point out what I am doing wrong? I get "550 550 Not
authenticated -- check your mail first" when I run the following code. I
believe the smtp server I am using requires a username and password but I
don't know where to specify that information. Thanks in advance.

<HTML>
<TITLE>mailsend.stm</TITLE>
<BODY>
<H1>Dynamo 3.0 Mail</H1>
<!--SCRIPT
var mp = new MailPiece();

mp.subject = "Hello World";
mp.from = "someone@somewhere.com;
mp.body = "Here you go";
mp.smtpHost = "smtp.somewhere.com";
mp.AddRecipient( "someoneelse@somewhereelse.com" , "to" );
if ( !mp.Send() ) {
document.writeln( mp.GetErrorCode() );
document.writeln( mp.GetErrorInfo() );
} else {
document.writeln("Sent!");
}
-->

<a href="mailMain.stm">click here to return to the mail menu</a>
</BODY>
</HTML>


Michael F. Nicewarner [TeamSybase] Posted on 2000-03-10 13:38:54.0Z
Newsgroups: sybase.public.easerver
From: "Michael F. Nicewarner [TeamSybase]" <mike.nicewarner@ibpinc.com>
Subject: Re: request for help on sending mail from dynamo example
Date: Fri, 10 Mar 2000 07:38:54 -0600
Lines: 56
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: secure.ibpinc.com 198.133.192.2
Message-ID: <347_mFzkZapi$GA.71@forums.sybase.com>
References: <347_4QnSq6ei$GA.74@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26701
Article PK: 154425

My ISP makes me check email before sending, so I've seen that error message
from my email client if I didn't check messages first. You might get around
this by actually going through the motions of checking mail in your script
before you send the mailpiece. That sounds hokey, but it might just work.

In my test environment I launch my email client to test if the emails got
sent, and it automatically checks email when it starts, so as long as I'm in
that session with my ISP I don't have problems. In my corporate Intranet
environment I don't have to check email. When I authenticate to the network
it validates me and sending mail works just fine.

I don't feel like a guru. Just someone with more cuts from the "bleeding
edge".

--

Michael F. Nicewarner [TeamSybase]
mailto:mike.nicewarner@ibpinc.com
http://www.datamodel.org

Thanh <tle@firstam.com> wrote in message
news:4QnSq6ei$GA.74@forums.sybase.com...
> Could someone point out what I am doing wrong? I get "550 550 Not
> authenticated -- check your mail first" when I run the following code. I
> believe the smtp server I am using requires a username and password but I
> don't know where to specify that information. Thanks in advance.
>
> <HTML>
> <TITLE>mailsend.stm</TITLE>
> <BODY>
> <H1>Dynamo 3.0 Mail</H1>
> <!--SCRIPT
> var mp = new MailPiece();
>
> mp.subject = "Hello World";
> mp.from = "someone@somewhere.com;
> mp.body = "Here you go";
> mp.smtpHost = "smtp.somewhere.com";
> mp.AddRecipient( "someoneelse@somewhereelse.com" , "to" );
> if ( !mp.Send() ) {
> document.writeln( mp.GetErrorCode() );
> document.writeln( mp.GetErrorInfo() );
> } else {
> document.writeln("Sent!");
> }
> -->
>
> <a href="mailMain.stm">click here to return to the mail menu</a>
> </BODY>
> </HTML>
>
>
>


^*^GothicCastle^*^ Posted on 2000-03-09 19:45:34.0Z
Newsgroups: sybase.public.easerver
Date: Thu, 09 Mar 2000 19:45:34 +0000
From: ^*^GothicCastle^*^ <^*^GothicCastle^*^@hotmail.com>
X-Mailer: Mozilla 4.7 [en] (Win98; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: request for help on sending mail from dynamo example
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 24
NNTP-Posting-Host: du-012-0059.freeuk.com 212.126.155.59
Message-ID: <347_38C7FF5E.D327A15A@hotmail.com>
References: <347_4QnSq6ei$GA.74@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26761
Article PK: 157743

In PowerDynamo have you set your default SMTP Host?

Thanh wrote:

> Could someone point out what I am doing wrong? I get "550 550 Not
> authenticated -- check your mail first" when I run the following code. I
> believe the smtp server I am using requires a username and password but I
> don't know where to specify that information. Thanks in advance.
>
> <HTML>
> <TITLE>mailsend.stm</TITLE>
> <BODY>
> <H1>Dynamo 3.0 Mail</H1>
> <!--SCRIPT
> var mp = new MailPiece();
>
> mp.subject = "Hello World";
> mp.from = "someone@somewhere.com;
> mp.body = "Here you go";
> mp.smtpHost = "smtp.somewhere.com";
> mp.AddRecipient( "someoneelse@somewhereelse.com" , "to" );
> if ( !mp.Send() ) {
> document.writeln( mp.GetErrorCode() );
> document.writeln( mp.GetErrorInfo() );
> } else {
> document.writeln("Sent!");
> }
> -->
>
> <a href="mailMain.stm">click here to return to the mail menu</a>
> </BODY>
> </HTML>


Thanh Posted on 2000-03-09 19:58:55.0Z
Newsgroups: sybase.public.easerver
From: "Thanh" <tle@firstam.com>
Subject: Re: request for help on sending mail from dynamo example
Date: Thu, 9 Mar 2000 11:58:55 -0800
Lines: 12
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: pixout.firstam.com 209.211.240.254
Message-ID: <347_PopiYKgi$GA.111@forums.sybase.com>
References: <347_4QnSq6ei$GA.74@forums.sybase.com> <347_38C7FF5E.D327A15A@hotmail.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26756
Article PK: 157735

nope. I thought that by specifying it with

mp.smtpHost = "smtp.somewhere.com";

I did not have to set it in the Dynamo configuration. Do I still need to?
What if my smtp server requires a username/password? Where would I specify
that?

Thanks for replying.


^*^GothicCastle^*^ Posted on 2000-03-09 20:47:19.0Z
Newsgroups: sybase.public.easerver
Date: Thu, 09 Mar 2000 20:47:19 +0000
From: ^*^GothicCastle^*^ <^*^GothicCastle^*^@hotmail.com>
X-Mailer: Mozilla 4.7 [en] (Win98; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: request for help on sending mail from dynamo example
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 35
NNTP-Posting-Host: du-012-0059.freeuk.com 212.126.155.59
Message-ID: <347_38C80DD7.8493D3D9@hotmail.com>
References: <347_4QnSq6ei$GA.74@forums.sybase.com> <347_38C7FF5E.D327A15A@hotmail.com> <347_PopiYKgi$GA.111@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26751
Article PK: 157730

Thanh,

Let's put it this way my mailpeice code doesn't work until I got the right
SMTP host specified in PowerDynamo, but hey that dosn't always mean anything
:)

If you want to test your code works and if you don't know your own intenal one
is use an online one like smtp.virgin.net or whoever you use as an isp.

I used this and it worked fine but the only problem is that you have to be
connected to the isp at the time to see if it works, so it's only of use in
checking that your actual code works.

You may also want to see you adminstrator about the IP address of your
exchange server or whatever company mail exchange you use. Once you have that
(it might even be " @firstam.com" judging by your email address)

My guess is if it is password protected then you might want to try:

smtp.virgin.net?password=Damien&username=Clothier

Wild guess I'm afraid, but what you need is the resident mailpeice guru Mr
Michael NiceWarner who knows a lot more than me<g>
He may be able to put you in the right direction.

Hope this is of some use.

Davlon

Thanh wrote:

> nope. I thought that by specifying it with
>
> mp.smtpHost = "smtp.somewhere.com";
>
> I did not have to set it in the Dynamo configuration. Do I still need to?
> What if my smtp server requires a username/password? Where would I specify
> that?
>
> Thanks for replying.