Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Incorrect syntax near 'use'

8 posts in General Discussion (old) Last posting was on 2000-02-29 11:46:32.0Z
Vladimir Uzlaner Posted on 2000-02-28 18:16:07.0Z
Newsgroups: sybase.public.easerver
From: "Vladimir Uzlaner" <vuzlaner@telsource.com>
Organization: 209.123.44.169
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: Incorrect syntax near 'use'
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Mon, 28 Feb 2000 13:16:07 -0500
Lines: 10
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_7Epthfhg$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27644
Article PK: 154567

Hi, all

Did anybody get this kind of message:

Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect syntax near
'use'
?

Please, let me know - what is does mean.

Thank you,
Vladimir Uzlaner
---== Posted via the PFCGuide Web Newsreader ==---
http://www.pfcguide.com/_newsgroups/group_list.asp


Dean Jones [Team Sybase] Posted on 2000-02-29 03:10:19.0Z
Newsgroups: sybase.public.easerver
From: "Dean Jones [Team Sybase]" <dean_no_spam_@powerobjects.com>
Subject: Re: Incorrect syntax near 'use'
Date: Mon, 28 Feb 2000 21:10:19 -0600
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: dsl131.outtech.com 216.207.145.131
Message-ID: <347_n3qQKNmg$GA.295@forums.sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27601
Article PK: 158975

Post your syntax for connecting.

Even if you are using a connection cache you must specify the dbms. If you
are using Sybase ASE you should specify SYJ as your dbms.

HTH

--

Dean Jones, CPD Professional
Team Sybase
PowerTeam, Inc.
http://www.powerobjects.com

Vladimir Uzlaner <vuzlaner@telsource.com> wrote in message
news:7Epthfhg$GA.202@forums.sybase.com...
> Hi, all
>
> Did anybody get this kind of message:
>
> Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
> Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect syntax
near
> 'use'
> ?
>
> Please, let me know - what is does mean.
>
> Thank you,
> Vladimir Uzlaner
> ---== Posted via the PFCGuide Web Newsreader ==---
> http://www.pfcguide.com/_newsgroups/group_list.asp


Borre Nordbakken Posted on 2000-02-29 11:46:32.0Z
Newsgroups: sybase.public.easerver
From: "Borre Nordbakken" <bno@brreg.no>
Subject: Re: Incorrect syntax near 'use'
Date: Tue, 29 Feb 2000 12:46:32 +0100
Lines: 60
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: 193.161.193.254
Message-ID: <347_jtZStsqg$GA.295@forums.sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com> <347_n3qQKNmg$GA.295@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27542
Article PK: 158923

Before:
SQLCA.DBMS = "SYJ Adaptive Server Enterprise"
SQLCA.DBParm = "UseContextObject='No',
CacheName='erfr',Host='jagu',AppName='erfr'"
Got alot of this in srv.log
Server Message: - 102/15/1/42000: Incorrect syntax near 'use'

After:
SQLCA.DBMS = "SYJ Adaptive Server Enterprise"
SQLCA.DBParm = "UseContextObject='No',
CacheName='erfr',Host='jagu',AppName='erfr'"
SQLCA.Database = "erdb"
The errormessage did not appaer, so far....

Tanks....

--
Borre

"Dean Jones [Team Sybase]" <dean_no_spam_@powerobjects.com> wrote in message
news:n3qQKNmg$GA.295@forums.sybase.com...
> Post your syntax for connecting.
>
> Even if you are using a connection cache you must specify the dbms. If you
> are using Sybase ASE you should specify SYJ as your dbms.
>
> HTH
>
> --
>
> Dean Jones, CPD Professional
> Team Sybase
> PowerTeam, Inc.
> http://www.powerobjects.com
>
>
> Vladimir Uzlaner <vuzlaner@telsource.com> wrote in message
> news:7Epthfhg$GA.202@forums.sybase.com...
> > Hi, all
> >
> > Did anybody get this kind of message:
> >
> > Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
> > Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect
syntax
> near
> > 'use'
> > ?
> >
> > Please, let me know - what is does mean.
> >
> > Thank you,
> > Vladimir Uzlaner
> > ---== Posted via the PFCGuide Web Newsreader ==---
> > http://www.pfcguide.com/_newsgroups/group_list.asp
>
>


Jerry Leckness Posted on 2000-02-28 18:22:26.0Z
Newsgroups: sybase.public.easerver
From: "Jerry Leckness" <jleckness@protective.com>
Subject: Re: Incorrect syntax near 'use'
Date: Mon, 28 Feb 2000 12:22:26 -0600
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: proxy2.protective.com 204.17.150.155
Message-ID: <347_uX6yNmhg$GA.202@forums.sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27641
Article PK: 159011

Make sure you have properly assigned:

SQLCA.database =

Jerry

"Vladimir Uzlaner" <vuzlaner@telsource.com> wrote in message
news:7Epthfhg$GA.202@forums.sybase.com...
> Hi, all
>
> Did anybody get this kind of message:
>
> Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
> Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect syntax
near
> 'use'
> ?
>
> Please, let me know - what is does mean.
>
> Thank you,
> Vladimir Uzlaner
> ---== Posted via the PFCGuide Web Newsreader ==---
> http://www.pfcguide.com/_newsgroups/group_list.asp


Vladimir Uzlaner Posted on 2000-02-28 20:07:30.0Z
Newsgroups: sybase.public.easerver
From: "Vladimir Uzlaner" <vuzlaner@telsource.com>
Organization: 209.123.44.169
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: Re: Incorrect syntax near 'use'
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Mon, 28 Feb 2000 15:07:30 -0500
Lines: 27
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_VAJXxdig$GA.251@forums.sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com> <347_uX6yNmhg$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27634
Article PK: 159005

On Mon, 28 Feb 2000 12:22:26 -0600,
in powersoft.public.easerver

Jerry Leckness <jleckness@protective.com> wrote:
>Make sure you have properly assigned:
>
>SQLCA.database =
>
>Jerry
>
>"Vladimir Uzlaner" <vuzlaner@telsource.com> wrote in message
>news:7Epthfhg$GA.202@forums.sybase.com...
>> Hi, all
>>
>> Did anybody get this kind of message:
>>
>> Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
>> Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect syntax
>near
>> 'use'
>> ?
>>
>> Please, let me know - what is does mean.
>>
>> Thank you,
>> Vladimir Uzlaner
>> ---== Posted via the PFCGuide Web Newsreader ==---
>> http://www.pfcguide.com/_newsgroups/group_list.asp
>
>

Hi, Jerry

Actually I use ConnectionCache, where Database name shouldn't be defined (?!),
and I able to connect to my database, but I'm getting this strange message.

Thank you,
Vladimir Uzlaner
---== Posted via the PFCGuide Web Newsreader ==---
http://www.pfcguide.com/_newsgroups/group_list.asp


Jim O'Neil [Sybase] Posted on 2000-02-28 22:21:29.0Z
Newsgroups: sybase.public.easerver
Date: Mon, 28 Feb 2000 17:21:29 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Incorrect syntax near 'use'
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 40
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38BAF4E9.160D8780@sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com> <347_uX6yNmhg$GA.202@forums.sybase.com> <347_VAJXxdig$GA.251@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27623
Article PK: 158996


Vladimir Uzlaner wrote:

> On Mon, 28 Feb 2000 12:22:26 -0600,
> in powersoft.public.easerver
> Jerry Leckness <jleckness@protective.com> wrote:
> >Make sure you have properly assigned:
> >
> >SQLCA.database =
> >
> >Jerry
> >
> >"Vladimir Uzlaner" <vuzlaner@telsource.com> wrote in message
> >news:7Epthfhg$GA.202@forums.sybase.com...
> >> Hi, all
> >>
> >> Did anybody get this kind of message:
> >>
> >> Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
> >> Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect syntax
> >near
> >> 'use'
> >> ?
> >>
> >> Please, let me know - what is does mean.
> >>
> >> Thank you,
> >> Vladimir Uzlaner
> >> ---== Posted via the PFCGuide Web Newsreader ==---
> >> http://www.pfcguide.com/_newsgroups/group_list.asp
> >
> >
> Hi, Jerry
>
> Actually I use ConnectionCache, where Database name shouldn't be defined (?!),
> and I able to connect to my database, but I'm getting this strange message.
>
> Thank you,
> Vladimir Uzlaner
> ---== Posted via the PFCGuide Web Newsreader ==---
> http://www.pfcguide.com/_newsgroups/group_list.asp

PowerBuilder is issuing the use statement after it's logical connection. In the
connection cache you can't specify a database name with the Client Library option
(you can with JDBC), so that's where the problem lies. The connection cache is
really just getting you to the ASE server. Jerry was right on in his response.
--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc


Borre Nordbakken Posted on 2000-02-29 01:11:23.0Z
Newsgroups: sybase.public.easerver
From: "Borre Nordbakken" <bno@brreg.no>
Subject: Re: Incorrect syntax near 'use'
Date: Tue, 29 Feb 2000 02:11:23 +0100
Lines: 69
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6700
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6700
NNTP-Posting-Host: port50.brsund-pm3-1.eunet.no 193.75.112.146
Message-ID: <347_XbbRQKlg$GA.201@forums.sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com> <347_uX6yNmhg$GA.202@forums.sybase.com> <347_VAJXxdig$GA.251@forums.sybase.com> <347_38BAF4E9.160D8780@sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27617
Article PK: 158991

Hi,
I have the same problem !
What was the solution ?

--
Borre

"Jim O'Neil [Sybase]" <joneil@sybase.com> wrote in message
news:38BAF4E9.160D8780@sybase.com...
> Vladimir Uzlaner wrote:
>
> > On Mon, 28 Feb 2000 12:22:26 -0600,
> > in powersoft.public.easerver
> > Jerry Leckness <jleckness@protective.com> wrote:
> > >Make sure you have properly assigned:
> > >
> > >SQLCA.database =
> > >
> > >Jerry
> > >
> > >"Vladimir Uzlaner" <vuzlaner@telsource.com> wrote in message
> > >news:7Epthfhg$GA.202@forums.sybase.com...
> > >> Hi, all
> > >>
> > >> Did anybody get this kind of message:
> > >>
> > >> Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
> > >> Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect
syntax
> > >near
> > >> 'use'
> > >> ?
> > >>
> > >> Please, let me know - what is does mean.
> > >>
> > >> Thank you,
> > >> Vladimir Uzlaner
> > >> ---== Posted via the PFCGuide Web Newsreader ==---
> > >> http://www.pfcguide.com/_newsgroups/group_list.asp
> > >
> > >
> > Hi, Jerry
> >
> > Actually I use ConnectionCache, where Database name shouldn't be defined
(?!),
> > and I able to connect to my database, but I'm getting this strange
message.
> >
> > Thank you,
> > Vladimir Uzlaner
> > ---== Posted via the PFCGuide Web Newsreader ==---
> > http://www.pfcguide.com/_newsgroups/group_list.asp
>
> PowerBuilder is issuing the use statement after it's logical connection.
In the
> connection cache you can't specify a database name with the Client Library
option
> (you can with JDBC), so that's where the problem lies. The connection
cache is
> really just getting you to the ASE server. Jerry was right on in his
response.
> --
> Jim O'Neil
> Senior Technical Support Engineer
> Sybase, Inc
>
>


Jim O'Neil [Sybase] Posted on 2000-02-29 04:30:40.0Z
Newsgroups: sybase.public.easerver
Date: Mon, 28 Feb 2000 23:30:40 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Incorrect syntax near 'use'
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 56
NNTP-Posting-Host: nomad6-46.sybase.com 157.133.176.46
Message-ID: <347_38BB4B6F.EB6F1FEE@sybase.com>
References: <347_7Epthfhg$GA.202@forums.sybase.com> <347_uX6yNmhg$GA.202@forums.sybase.com> <347_VAJXxdig$GA.251@forums.sybase.com> <347_38BAF4E9.160D8780@sybase.com> <347_XbbRQKlg$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27570
Article PK: 158946


Borre Nordbakken wrote:

> Hi,
> I have the same problem !
> What was the solution ?
>
> --
> Borre
>
> "Jim O'Neil [Sybase]" <joneil@sybase.com> wrote in message
> news:38BAF4E9.160D8780@sybase.com...
> > Vladimir Uzlaner wrote:
> >
> > > On Mon, 28 Feb 2000 12:22:26 -0600,
> > > in powersoft.public.easerver
> > > Jerry Leckness <jleckness@protective.com> wrote:
> > > >Make sure you have properly assigned:
> > > >
> > > >SQLCA.database =
> > > >
> > > >Jerry
> > > >
> > > >"Vladimir Uzlaner" <vuzlaner@telsource.com> wrote in message
> > > >news:7Epthfhg$GA.202@forums.sybase.com...
> > > >> Hi, all
> > > >>
> > > >> Did anybody get this kind of message:
> > > >>
> > > >> Feb 28 12:59:30 2000: ACTIVATE for n_bo_session_state
> > > >> Feb 28 12:59:30 2000: Server Message: - 102/15/1/42000: Incorrect
> syntax
> > > >near
> > > >> 'use'
> > > >> ?
> > > >>
> > > >> Please, let me know - what is does mean.
> > > >>
> > > >> Thank you,
> > > >> Vladimir Uzlaner
> > > >> ---== Posted via the PFCGuide Web Newsreader ==---
> > > >> http://www.pfcguide.com/_newsgroups/group_list.asp
> > > >
> > > >
> > > Hi, Jerry
> > >
> > > Actually I use ConnectionCache, where Database name shouldn't be defined
> (?!),
> > > and I able to connect to my database, but I'm getting this strange
> message.
> > >
> > > Thank you,
> > > Vladimir Uzlaner
> > > ---== Posted via the PFCGuide Web Newsreader ==---
> > > http://www.pfcguide.com/_newsgroups/group_list.asp
> >
> > PowerBuilder is issuing the use statement after it's logical connection.
> In the
> > connection cache you can't specify a database name with the Client Library
> option
> > (you can with JDBC), so that's where the problem lies. The connection
> cache is
> > really just getting you to the ASE server. Jerry was right on in his
> response.
> > --
> > Jim O'Neil
> > Senior Technical Support Engineer
> > Sybase, Inc
> >
> >

Jerry answered it in the first response to this thread - set
SQLCA.Database=<your database>. This is only needed when using the SYJ driver.
--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc