Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Incorrect syntax server message

4 posts in General Discussion (old) Last posting was on 2000-02-23 04:46:05.0Z
Jerry Leckness Posted on 2000-02-23 03:31:18.0Z
Newsgroups: sybase.public.easerver
From: "Jerry Leckness" <jleckness@protective.com>
Subject: Incorrect syntax server message
Date: Tue, 22 Feb 2000 21:31:18 -0600
Lines: 11
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: proxy2.protective.com 204.17.150.155
Message-ID: <347_8jbefqUf$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28193
Article PK: 154636

I am getting this error in a Jaguar component: TLSQL2 is an installed
connection cache. The component was built with PB7, uses a datawindow, and
connects to Sybase 11.5 thru a connection cache.
I have exported the component, searched the code, and cannot find any
occurance of 'use'.

Server Message: TLSQL2 - 102/15/1/42000: Incorrect syntax near 'use'.


Beth Park Posted on 2000-02-22 15:57:38.0Z
Newsgroups: sybase.public.easerver
From: "Beth Park" <beth.park@westlbpanmure.com>
Organization: 195.50.81.67
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: Re: Incorrect syntax server message
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Tue, 22 Feb 2000 10:57:38 -0500
Lines: 20
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_RebsK2Uf$GA.202@forums.sybase.com>
References: <347_8jbefqUf$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28188
Article PK: 160068

Jerry,
I believe that every time a connection is done on the connection cache, Jag
issues a "use <dbname>" command to get into the correct database.
Have you set the database property of TLSQL2 before doing the connect?
That's all I can think of.
Beth

On Tue, 22 Feb 2000 21:31:18 -0600,
in powersoft.public.easerver

Jerry Leckness <jleckness@protective.com> wrote:
>I am getting this error in a Jaguar component: TLSQL2 is an installed
>connection cache. The component was built with PB7, uses a datawindow, and
>connects to Sybase 11.5 thru a connection cache.
>I have exported the component, searched the code, and cannot find any
>occurance of 'use'.
>
>Server Message: TLSQL2 - 102/15/1/42000: Incorrect syntax near 'use'.
>
>
>
>


Jim O'Neil [Sybase] Posted on 2000-02-22 19:15:07.0Z
Newsgroups: sybase.public.easerver
Date: Tue, 22 Feb 2000 14:15:07 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Incorrect syntax server message
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 25
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38B2E03B.695F672F@sybase.com>
References: <347_8jbefqUf$GA.202@forums.sybase.com> <347_RebsK2Uf$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28153
Article PK: 160037


Beth Park wrote:

> Jerry,
> I believe that every time a connection is done on the connection cache, Jag
> issues a "use <dbname>" command to get into the correct database.
> Have you set the database property of TLSQL2 before doing the connect?
> That's all I can think of.
> Beth
>
> On Tue, 22 Feb 2000 21:31:18 -0600,
> in powersoft.public.easerver
> Jerry Leckness <jleckness@protective.com> wrote:
> >I am getting this error in a Jaguar component: TLSQL2 is an installed
> >connection cache. The component was built with PB7, uses a datawindow, and
> >connects to Sybase 11.5 thru a connection cache.
> >I have exported the component, searched the code, and cannot find any
> >occurance of 'use'.
> >
> >Server Message: TLSQL2 - 102/15/1/42000: Incorrect syntax near 'use'.
> >
> >
> >
> >

Actually, it's PowerBuilder issuing the 'use <database>' statement, but you got
the gist of it.
--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc


Jerry Leckness Posted on 2000-02-23 04:46:05.0Z
Newsgroups: sybase.public.easerver
From: "Jerry Leckness" <jleckness@protective.com>
Subject: Re: Incorrect syntax server message
Date: Tue, 22 Feb 2000 22:46:05 -0600
Lines: 39
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: proxy2.protective.com 204.17.150.155
Message-ID: <347_cCegRUVf$GA.274@forums.sybase.com>
References: <347_8jbefqUf$GA.202@forums.sybase.com> <347_RebsK2Uf$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28177
Article PK: 160054

That was it! I didn't set "itr_trans.database" before connecting.
Now my code reads like this:

itr_trans.DBMS = "SYJ Sybase System 10/11"
itr_trans.database="myDb"
itr_trans.DBParm = "UseContextObject='yes',CacheName='myConnectionCache'"

CONNECT USING itr_trans;

Thanks Beth

"Beth Park" <beth.park@westlbpanmure.com> wrote in message
news:RebsK2Uf$GA.202@forums.sybase.com...
> Jerry,
> I believe that every time a connection is done on the connection cache,
Jag
> issues a "use <dbname>" command to get into the correct database.
> Have you set the database property of TLSQL2 before doing the connect?
> That's all I can think of.
> Beth
>
> On Tue, 22 Feb 2000 21:31:18 -0600,
> in powersoft.public.easerver
> Jerry Leckness <jleckness@protective.com> wrote:
> >I am getting this error in a Jaguar component: TLSQL2 is an installed
> >connection cache. The component was built with PB7, uses a datawindow,
and
> >connects to Sybase 11.5 thru a connection cache.
> >I have exported the component, searched the code, and cannot find any
> >occurance of 'use'.
> >
> >Server Message: TLSQL2 - 102/15/1/42000: Incorrect syntax near 'use'.
> >
> >
> >
> >