Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Jaguar Manager DLL errors

4 posts in General Discussion (old) Last posting was on 2000-02-29 09:34:08.0Z
Jonas Olsson Posted on 2000-02-23 16:11:08.0Z
Newsgroups: sybase.public.easerver
From: "Jonas Olsson" <Jonas.Olsson@cambiosys.com>
Subject: Jaguar Manager DLL errors
Date: Wed, 23 Feb 2000 17:11:08 +0100
Lines: 148
Organization: Cambio Healthcare Systems
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 195.100.184.126
Message-ID: <347_9PLUQkhf$GA.151@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28064
Article PK: 159958

Attached is a log file from a EAS 3.0.1 when connecting with Jaguar Manager.
This is only when connecting to the server from the server itself. A number
(7-8) of dialogs complaining of PseudoJava_GetJNIEnv (something or other)
appears.
Any ideas?

--
Jonas Olsson
Software Development Engineer
Cambio Healthcare Systems


Jim O'Neil [Sybase] Posted on 2000-02-23 17:51:17.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 23 Feb 2000 12:51:17 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Jaguar Manager DLL errors
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 26
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38B41E15.D5EA8177@sybase.com>
References: <347_9PLUQkhf$GA.151@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28042
Article PK: 159947


Jonas Olsson wrote:

> Attached is a log file from a EAS 3.0.1 when connecting with Jaguar Manager.
> This is only when connecting to the server from the server itself. A number
> (7-8) of dialogs complaining of PseudoJava_GetJNIEnv (something or other)
> appears.
> Any ideas?
>
> --
> Jonas Olsson
> Software Development Engineer
> Cambio Healthcare Systems
>
> Name: srv.log
> srv.log Type: Text Document (application/x-unknown-content-type-txtfile)
> Encoding: x-uuencode

I get this same problem and thought it was related to having 3.0 and 3.5 on the
same box and me just being to lazy to fix up the path. I still get the problem
with 3.0 JagMan, but I don't use it enough for it to have become enough of a
nuisance for me yet ;>) Let me see if I can figure out what the conflict here is
- there's a mismatch of DLLs coming from somewhere. Do you have EAServer 3.5 also
installed on that machine?
--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc


Jim O'Neil [Sybase] Posted on 2000-02-26 02:33:56.0Z
Newsgroups: sybase.public.easerver
Date: Fri, 25 Feb 2000 21:33:56 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Jaguar Manager DLL errors
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 63
NNTP-Posting-Host: nomad6-6.sybase.com 157.133.176.6
Message-ID: <347_38B73B94.C4030D1E@sybase.com>
References: <347_9PLUQkhf$GA.151@forums.sybase.com> <347_38B41E15.D5EA8177@sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27760
Article PK: 159117


"Jim O'Neil [Sybase]" wrote:

> Jonas Olsson wrote:
>
> > Attached is a log file from a EAS 3.0.1 when connecting with Jaguar Manager.
> > This is only when connecting to the server from the server itself. A number
> > (7-8) of dialogs complaining of PseudoJava_GetJNIEnv (something or other)
> > appears.
> > Any ideas?
> >
> > --
> > Jonas Olsson
> > Software Development Engineer
> > Cambio Healthcare Systems
> >
> > Name: srv.log
> > srv.log Type: Text Document (application/x-unknown-content-type-txtfile)
> > Encoding: x-uuencode
>
> I get this same problem and thought it was related to having 3.0 and 3.5 on the
> same box and me just being to lazy to fix up the path. I still get the problem
> with 3.0 JagMan, but I don't use it enough for it to have become enough of a
> nuisance for me yet ;>) Let me see if I can figure out what the conflict here is
> - there's a mismatch of DLLs coming from somewhere. Do you have EAServer 3.5 also
> installed on that machine?
> --
> Jim O'Neil
> Senior Technical Support Engineer
> Sybase, Inc

Sorry for the delay, I've been teaching a class this week and haven't had a chance to
pursue. What's happening here is a versioning issue with libjcc.dll. PowerBuilder
uses libjcc for its client side ORB and Jaguar, of course, uses it as well. The
Jaguar libjcc.dll is located in the Jaguar/dll directory and the PowerBuilder one is
located in the Shared/PowerBuilder directory, so if you have different versions it
actually turns out that the serverstart.bat file that you use to start the server will
put the shared/PowerBuilder directory ahead of the Jaguar/dll directory in the PATH.
If you've applied any of the builds of PowerBuilder from the FTP site, you'll more
than likely have a differing versions of libjcc.dll that would lead to this.

My suggestion would be to change the serverstart.bat file to include the following two
lines instead of what they are set to now:

set PATH=.;%JDK_LATEST%\bin;%PATH%;
set ADD_PATH=%JAGUAR%\cpplib;%JAGUAR%\bin;%JAGUAR%\dll;%SYBASE_SHARED%\Powerbuilder;

basically, I moved %JAGUAR%\dll from the first set statement to before the
%SYBASE_SHARED%\PowerBuilder in the second set statement, because as you'll see the
subsequent statement in the batch file puts ADD_PATH BEFORE versus after the current
PATH.

Hope all that makes sense!


--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc


Jonas Olsson Posted on 2000-02-29 09:34:08.0Z
Newsgroups: sybase.public.easerver
From: "Jonas Olsson" <Jonas.Olsson@cambiosys.com>
Subject: Re: Jaguar Manager DLL errors
Date: Tue, 29 Feb 2000 10:34:08 +0100
Lines: 93
Organization: Cambio Healthcare Systems
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 195.100.184.126
Message-ID: <347_Lz1qYipg$GA.295@forums.sybase.com>
References: <347_9PLUQkhf$GA.151@forums.sybase.com> <347_38B41E15.D5EA8177@sybase.com> <347_38B73B94.C4030D1E@sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27550
Article PK: 158932

Got it! Thanks!

The conflicting machine did not have 3.5, but had 3.0 upgraded to 3.0.1 so I
think the 3.0.1 installer has something to do with it (?).

/jonas

Jim O'Neil [Sybase] wrote in message <38B73B94.C4030D1E@sybase.com>...
>"Jim O'Neil [Sybase]" wrote:
>
>> Jonas Olsson wrote:
>>
>> > Attached is a log file from a EAS 3.0.1 when connecting with Jaguar
Manager.
>> > This is only when connecting to the server from the server itself. A
number
>> > (7-8) of dialogs complaining of PseudoJava_GetJNIEnv (something or
other)
>> > appears.
>> > Any ideas?
>> >
>> > --
>> > Jonas Olsson
>> > Software Development Engineer
>> > Cambio Healthcare Systems
>> >
>> > Name: srv.log
>> > srv.log Type: Text Document
(application/x-unknown-content-type-txtfile)
>> > Encoding: x-uuencode
>>
>> I get this same problem and thought it was related to having 3.0 and 3.5
on the
>> same box and me just being to lazy to fix up the path. I still get the
problem
>> with 3.0 JagMan, but I don't use it enough for it to have become enough
of a
>> nuisance for me yet ;>) Let me see if I can figure out what the conflict
here is
>> - there's a mismatch of DLLs coming from somewhere. Do you have EAServer
3.5 also
>> installed on that machine?
>> --
>> Jim O'Neil
>> Senior Technical Support Engineer
>> Sybase, Inc
>
>Sorry for the delay, I've been teaching a class this week and haven't had a
chance to
>pursue. What's happening here is a versioning issue with libjcc.dll.
PowerBuilder
>uses libjcc for its client side ORB and Jaguar, of course, uses it as well.
The
>Jaguar libjcc.dll is located in the Jaguar/dll directory and the
PowerBuilder one is
>located in the Shared/PowerBuilder directory, so if you have different
versions it
>actually turns out that the serverstart.bat file that you use to start the
server will
>put the shared/PowerBuilder directory ahead of the Jaguar/dll directory in
the PATH.
>If you've applied any of the builds of PowerBuilder from the FTP site,
you'll more
>than likely have a differing versions of libjcc.dll that would lead to
this.
>
>My suggestion would be to change the serverstart.bat file to include the
following two
>lines instead of what they are set to now:
>
>set PATH=.;%JDK_LATEST%\bin;%PATH%;
>set

ADD_PATH=%JAGUAR%\cpplib;%JAGUAR%\bin;%JAGUAR%\dll;%SYBASE_SHARED%\Powerbuil
der;
>
>basically, I moved %JAGUAR%\dll from the first set statement to before the
>%SYBASE_SHARED%\PowerBuilder in the second set statement, because as you'll
see the
>subsequent statement in the batch file puts ADD_PATH BEFORE versus after
the current
>PATH.
>
>Hope all that makes sense!
>
>
>--
>Jim O'Neil
>Senior Technical Support Engineer
>Sybase, Inc
>
>