Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

String handling in PD

2 posts in General Discussion (old) Last posting was on 2000-02-22 22:11:54.0Z
Saulius Kriukelis Posted on 2000-02-22 14:25:54.0Z
Newsgroups: sybase.public.easerver
From: "Saulius Kriukelis" <saulius@dbit.lt>
Subject: String handling in PD
Date: Tue, 22 Feb 2000 15:25:54 +0100
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: dialup303.vln.takas.lt 212.59.15.63
Message-ID: <347_FP3B9kTf$GA.261@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28216
Article PK: 160091

The problem arises when executing select statement from Informix database
using Openlink ODBC driver.
It is impossible to retrieve strings from database into PowerDynamo. Other
applications that use same ODBC
handle string in usual way.
Instead of string in the result I receive NULL.

My PowerDynamo source:

<!--SCRIPT
rezas=connection.CreateQuery("SELECT serno,number FROM cards WHERE
number='xxxxxxxxxxxxxxxx'")
while(rezas.MoveNext()){
document.WriteLn(rezas.GetValue("serno")+"
"+rezas.GetValue("number"))
}
-->

And the result in a browser:

1160222 null

Is there any workaraound?

Best regards,

Saulius Kriukelis
saulius@dbit.lt


Alex Whitney Posted on 2000-02-22 22:11:54.0Z
Newsgroups: sybase.public.easerver
From: "Alex Whitney" <awhitney@dyn-data.com>
Subject: Re: String handling in PD
Date: Tue, 22 Feb 2000 16:11:54 -0600
Lines: 49
Organization: Dynamic Data Solutions
X-Newsreader: Microsoft Outlook Express 4.72.3612.1700
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3612.1700
NNTP-Posting-Host: 208.150.236.141
Message-ID: <347_O1yfIKYf$GA.251@forums.sybase.com>
References: <347_FP3B9kTf$GA.261@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28127
Article PK: 160013

It might be unhappy with the column name of "number". That may be a reserved
word somewhere. I'd try a different column name or the altervative syntax of
the column number instead of the column name.

Alex

--
_________________________________________________________

Alex Whitney
CPD Professional
Dynamic Data Solutions, Inc.
Enterprise Application Studio 3.0 Consulting and Training
http://www.dyn-data.com

Saulius Kriukelis wrote in message ...
>The problem arises when executing select statement from Informix database
>using Openlink ODBC driver.
>It is impossible to retrieve strings from database into PowerDynamo. Other
>applications that use same ODBC
>handle string in usual way.
>Instead of string in the result I receive NULL.
>
>My PowerDynamo source:
>
><!--SCRIPT
> rezas=connection.CreateQuery("SELECT serno,number FROM cards WHERE
>number='xxxxxxxxxxxxxxxx'")
> while(rezas.MoveNext()){
> document.WriteLn(rezas.GetValue("serno")+"
>"+rezas.GetValue("number"))
> }
>-->
>
>And the result in a browser:
>
>1160222 null
>
>Is there any workaraound?
>
>Best regards,
>
>Saulius Kriukelis
>saulius@dbit.lt
>
>