Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Master/detail link not working

4 posts in General Discussion (old) Last posting was on 2000-02-17 19:16:33.0Z
Syed Posted on 2000-02-16 09:22:21.0Z
Newsgroups: sybase.public.easerver
From: "Syed" <syedibrahim@hotmail.com>
Subject: Master/detail link not working
Date: Wed, 16 Feb 2000 17:22:21 +0800
Lines: 12
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 202.187.63.1
Message-ID: <347_Ngm6oBGe$GA.184@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28590
Article PK: 160730

When clicked at the master record I am passing the key parameter to the
detail html datawindow webpage however no data retrieve in the detail except
the column name. I have set the linkage properly. I have defined the
hyperlink destination and the link to properties in the master html
datawindow DTC properties. in the detail I have the retrieval argument
defined appropriately.

I wonder what went wrong. Your help appreciated.

Syed.


Ido Millet Posted on 2000-02-16 21:07:18.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 16 Feb 2000 15:07:18 -0600
From: Ido Millet <ixm7@mail.psu.edu>
Reply-To: ixm7@psu.edu
Organization: Penn State Erie
X-Mailer: Mozilla 4.51 [en] (WinNT; U)
X-Accept-Language: en,pdf
MIME-Version: 1.0
Subject: Re: Master/detail link not working
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 14
NNTP-Posting-Host: sobpc02.bd.psu.edu 146.186.176.195
Message-ID: <347_38AB1185.45E5C3D3@mail.psu.edu>
References: <347_Ngm6oBGe$GA.184@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28551
Article PK: 160697

What's the data type of the retrieval argument?

hth,
- Ido

Syed wrote:

> When clicked at the master record I am passing the key parameter to the
> detail html datawindow webpage however no data retrieve in the detail except
> the column name. I have set the linkage properly. I have defined the
> hyperlink destination and the link to properties in the master html
> datawindow DTC properties. in the detail I have the retrieval argument
> defined appropriately.
>
> I wonder what went wrong. Your help appreciated.
>
> Syed.


Syed Posted on 2000-02-17 01:30:05.0Z
Newsgroups: sybase.public.easerver
From: "Syed" <syedibrahim@hotmail.com>
Subject: Re: Master/detail link not working
Date: Thu, 17 Feb 2000 09:30:05 +0800
Lines: 26
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 202.187.63.1
Message-ID: <347_16CkbeOe$GA.223@forums.sybase.com>
References: <347_Ngm6oBGe$GA.184@forums.sybase.com> <347_38AB1185.45E5C3D3@mail.psu.edu>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28534
Article PK: 154681

The data type is integer meanwhile in the datawindow object I use retrieval
argument of type number, can I use page parameter value type for retrieval
argument when passing the parameter in the html datawindow?

Ido Millet wrote in message <38AB1185.45E5C3D3@mail.psu.edu>...
>What's the data type of the retrieval argument?
>
>hth,
>- Ido
>
>Syed wrote:
>
>> When clicked at the master record I am passing the key parameter to the
>> detail html datawindow webpage however no data retrieve in the detail
except
>> the column name. I have set the linkage properly. I have defined the
>> hyperlink destination and the link to properties in the master html
>> datawindow DTC properties. in the detail I have the retrieval argument
>> defined appropriately.
>>
>> I wonder what went wrong. Your help appreciated.
>>
>> Syed.
>


Ido Millet Posted on 2000-02-17 19:16:33.0Z
Newsgroups: sybase.public.easerver
Date: Thu, 17 Feb 2000 13:16:33 -0600
From: Ido Millet <ixm7@mail.psu.edu>
Reply-To: ixm7@psu.edu
Organization: Penn State Erie
X-Mailer: Mozilla 4.51 [en] (WinNT; U)
X-Accept-Language: en,pdf
MIME-Version: 1.0
Subject: Re: Master/detail link not working
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 29
NNTP-Posting-Host: sobpc02.bd.psu.edu 146.186.176.195
Message-ID: <347_38AC4910.6664F2B6@mail.psu.edu>
References: <347_Ngm6oBGe$GA.184@forums.sybase.com> <347_38AB1185.45E5C3D3@mail.psu.edu> <347_16CkbeOe$GA.223@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28477
Article PK: 160634

Try to specify your link argument so it evaluates to
a String. In the DataWindow painter HTML attributes
for the column, you would use something like:

link_arg = 'String(Your_Numeric_Key_Column)'

Cheers,
- Ido

Syed wrote:

> The data type is integer meanwhile in the datawindow object I use retrieval
> argument of type number, can I use page parameter value type for retrieval
> argument when passing the parameter in the html datawindow?
>
> Ido Millet wrote in message <38AB1185.45E5C3D3@mail.psu.edu>...
> >What's the data type of the retrieval argument?
> >
> >hth,
> >- Ido
> >
> >Syed wrote:
> >
> >> When clicked at the master record I am passing the key parameter to the
> >> detail html datawindow webpage however no data retrieve in the detail
> except
> >> the column name. I have set the linkage properly. I have defined the
> >> hyperlink destination and the link to properties in the master html
> >> datawindow DTC properties. in the detail I have the retrieval argument
> >> defined appropriately.
> >>
> >> I wonder what went wrong. Your help appreciated.
> >>
> >> Syed.
> >