Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Unable to start Servlet Service

5 posts in General Discussion (old) Last posting was on 2000-02-29 15:24:54.0Z
Develop Informatica Posted on 2000-02-25 13:39:12.0Z
Newsgroups: sybase.public.easerver
From: "Develop Informatica" <suporte@develop.com.br>
Subject: Unable to start Servlet Service
Date: Fri, 25 Feb 2000 10:39:12 -0300
Lines: 25
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 200.248.92.2
Message-ID: <347_OHNsUz4f$GA.276@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27825
Article PK: 159171

Hi,

I'm getting this error, when starting Jaguar. The servlet we have was able
to run, but now I can't make it work.

Does anybody know what this message means ?

TIA.
Diego.

java.lang.UnsatisfiedLinkError: getServerInfo
Feb 25 09:45:35 2000: at
com.sybase.jaguar.servlet.JagServletContext.<init>(JagServletContext.java:15
)
Feb 25 09:45:35 2000: at
com.sybase.jaguar.servlet.ServletEngine.start(ServletEngine.java:314)
Feb 25 09:45:35 2000: at
com.sybase.jaguar.servlet.ServletServiceImpl.start(ServletServiceImpl.java:1
18)
Feb 25 09:45:35 2000: at
com.sybase.jaguar.servlet._sk_CtsServlet_ServletService.invoke(_sk_CtsServle
t_ServletService.java:211)
Feb 25 09:45:35 2000: Unable to start ServletService.


Dave Wolf [Sybase] Posted on 2000-02-26 15:13:58.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: Unable to start Servlet Service
Date: Sat, 26 Feb 2000 10:13:58 -0500
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: vpn-eme-013.sybase.com 130.214.8.13
Message-ID: <347_h2YqhyGg$GA.202@forums.sybase.com>
References: <347_OHNsUz4f$GA.276@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27745
Article PK: 154580

Check your PATH

Dave Wolf
Internet Applications Division

"Develop Informatica" <suporte@develop.com.br> wrote in message
news:OHNsUz4f$GA.276@forums.sybase.com...
> Hi,
>
> I'm getting this error, when starting Jaguar. The servlet we have was able
> to run, but now I can't make it work.
>
> Does anybody know what this message means ?
>
> TIA.
> Diego.
>
> java.lang.UnsatisfiedLinkError: getServerInfo
> Feb 25 09:45:35 2000: at
>
com.sybase.jaguar.servlet.JagServletContext.<init>(JagServletContext.java:15
> )
> Feb 25 09:45:35 2000: at
> com.sybase.jaguar.servlet.ServletEngine.start(ServletEngine.java:314)
> Feb 25 09:45:35 2000: at
>
com.sybase.jaguar.servlet.ServletServiceImpl.start(ServletServiceImpl.java:1
> 18)
> Feb 25 09:45:35 2000: at
>
com.sybase.jaguar.servlet._sk_CtsServlet_ServletService.invoke(_sk_CtsServle
> t_ServletService.java:211)
> Feb 25 09:45:35 2000: Unable to start ServletService.
>
>


Develop Informatica Posted on 2000-02-29 13:24:28.0Z
Newsgroups: sybase.public.easerver
From: "Develop Informatica" <suporte@develop.com.br>
Subject: Re: Unable to start Servlet Service
Date: Tue, 29 Feb 2000 10:24:28 -0300
Lines: 58
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 200.248.92.2
Message-ID: <347_L60NOfrg$GA.202@forums.sybase.com>
References: <347_OHNsUz4f$GA.276@forums.sybase.com> <347_h2YqhyGg$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27534
Article PK: 158921

This is weird. The problem is happening on solaris. I also have Jaguar on
NT. I have just copied the $JAGUAR/html/classes/com directory from NT to
solaris, and it worked again. The files were the same. How could the classes
in solaris be broken ?

One thing that is bothering is when deploying Java components to Jaguar,
PowerJ deploys the com and org classes to $JAG/java/classes. If we don't
delete those deployed classes, jaguar hangs. Does anyone know why ?


TIA.

Diego.

Dave Wolf [Sybase] wrote in message ...
>Check your PATH
>
>Dave Wolf
>Internet Applications Division
>
>"Develop Informatica" <suporte@develop.com.br> wrote in message
>news:OHNsUz4f$GA.276@forums.sybase.com...
>> Hi,
>>
>> I'm getting this error, when starting Jaguar. The servlet we have was
able
>> to run, but now I can't make it work.
>>
>> Does anybody know what this message means ?
>>
>> TIA.
>> Diego.
>>
>> java.lang.UnsatisfiedLinkError: getServerInfo
>> Feb 25 09:45:35 2000: at
>>
>com.sybase.jaguar.servlet.JagServletContext.<init>(JagServletContext.java:1
5
>> )
>> Feb 25 09:45:35 2000: at
>> com.sybase.jaguar.servlet.ServletEngine.start(ServletEngine.java:314)
>> Feb 25 09:45:35 2000: at
>>
>com.sybase.jaguar.servlet.ServletServiceImpl.start(ServletServiceImpl.java:
1
>> 18)
>> Feb 25 09:45:35 2000: at
>>
>com.sybase.jaguar.servlet._sk_CtsServlet_ServletService.invoke(_sk_CtsServl
e
>> t_ServletService.java:211)
>> Feb 25 09:45:35 2000: Unable to start ServletService.
>>
>>
>
>


Dave Wolf [Sybase] Posted on 2000-02-29 15:24:54.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: Unable to start Servlet Service
Date: Tue, 29 Feb 2000 10:24:54 -0500
Lines: 71
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: 158.159.8.29
Message-ID: <347_Conhqmsg$GA.251@forums.sybase.com>
References: <347_OHNsUz4f$GA.276@forums.sybase.com> <347_h2YqhyGg$GA.202@forums.sybase.com> <347_L60NOfrg$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27512
Article PK: 154550

Uncheck to deployed dependant classes. It will stop that.

Dave Wolf
Internet Applications Division

"Develop Informatica" <suporte@develop.com.br> wrote in message
news:L60NOfrg$GA.202@forums.sybase.com...
> This is weird. The problem is happening on solaris. I also have Jaguar on
> NT. I have just copied the $JAGUAR/html/classes/com directory from NT to
> solaris, and it worked again. The files were the same. How could the
classes
> in solaris be broken ?
>
> One thing that is bothering is when deploying Java components to Jaguar,
> PowerJ deploys the com and org classes to $JAG/java/classes. If we don't
> delete those deployed classes, jaguar hangs. Does anyone know why ?
>
>
> TIA.
>
> Diego.
>
> Dave Wolf [Sybase] wrote in message ...
> >Check your PATH
> >
> >Dave Wolf
> >Internet Applications Division
> >
> >"Develop Informatica" <suporte@develop.com.br> wrote in message
> >news:OHNsUz4f$GA.276@forums.sybase.com...
> >> Hi,
> >>
> >> I'm getting this error, when starting Jaguar. The servlet we have was
> able
> >> to run, but now I can't make it work.
> >>
> >> Does anybody know what this message means ?
> >>
> >> TIA.
> >> Diego.
> >>
> >> java.lang.UnsatisfiedLinkError: getServerInfo
> >> Feb 25 09:45:35 2000: at
> >>
>
>com.sybase.jaguar.servlet.JagServletContext.<init>(JagServletContext.java:1
> 5
> >> )
> >> Feb 25 09:45:35 2000: at
> >> com.sybase.jaguar.servlet.ServletEngine.start(ServletEngine.java:314)
> >> Feb 25 09:45:35 2000: at
> >>
>
>com.sybase.jaguar.servlet.ServletServiceImpl.start(ServletServiceImpl.java:
> 1
> >> 18)
> >> Feb 25 09:45:35 2000: at
> >>
>
>com.sybase.jaguar.servlet._sk_CtsServlet_ServletService.invoke(_sk_CtsServl
> e
> >> t_ServletService.java:211)
> >> Feb 25 09:45:35 2000: Unable to start ServletService.
> >>
> >>
> >
> >
>
>


Develop Informatica Posted on 2000-02-25 13:48:58.0Z
Newsgroups: sybase.public.easerver
From: "Develop Informatica" <suporte@develop.com.br>
Subject: Re: Unable to start Servlet Service
Date: Fri, 25 Feb 2000 10:48:58 -0300
Lines: 12
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 200.248.92.2
Message-ID: <347_$NDtx44f$GA.276@forums.sybase.com>
References: <347_OHNsUz4f$GA.276@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27824
Article PK: 154591

Before that message, there is another one in srv.log:

Exception
Feb 25 10:46:32 2000: in thread
Feb 25 10:46:32 2000: "main"
Feb 25 10:46:32 2000:
Feb 25 10:46:32 2000: java.lang.NoSuchMethodError: setServletExtension
Feb 25 10:46:32 2000: java.lang.NoSuchMethodError: setServletExtension
Feb 25 10:46:32 2000: JavaJaguarServletInit: RegisterNatives Failedfor
com.sybase.jaguar.servlet.JaguarServer