Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Alarming eas 3.5 - Jaguar dr. Watson

6 posts in General Discussion (old) Last posting was on 2000-03-14 22:06:31.0Z
Sem Kazazic Posted on 2000-03-14 20:32:31.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: Alarming eas 3.5 - Jaguar dr. Watson
Date: Tue, 14 Mar 2000 15:32:31 -0500
Lines: 92
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0007_01BF8DCA.83900FF0"
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_VTIsXUfj$GA.285@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26433
Article PK: 157101

Hi there,
 
After all, I did upgrade to 3.5 , and have been running with no problem  for few weeks.
We have ase 11.9.2 on same pc (win nt server 4 sp5).
Today I wanted to create new connection cache for ase db and everything looked ok before I restarted jaguar server (it 's not nt service)
When I restarted jaguar I got dr. Watson.
1. in jaguar log I found cm_odbc_error:SQLState 08S01, [Sybase] [ODBC Driver][Adaptive Server Anywhere] Communication link failure; connection was terminated.
2. I tried to Carson/Dave posting about JAGUAR_RANDOMSEED , but found nothing in c:\random.txt file
3. After that found in jaguar log AFLIB message 18011/11/0;dll lookup for 'af_dlllookup()' failed, OS Message.
Even if I did something wrong during connection cache setup, I don't believe that could cause this kind of problem?
 
And the most disturbing thing, when I checked directory for jaguar repository, all connection caches I had there disappeared.
Does anybody has an idea what happened, and what I am supposed to do next?
 
Thanks.
Regards,
Sem.
 


John Childs Posted on 2000-03-14 21:33:47.0Z
Newsgroups: sybase.public.easerver
From: "John Childs" <john.childs@sybase.com>
Subject: Re: Alarming eas 3.5 - Jaguar dr. Watson
Organization: Sybase
X-Newsreader: Microsoft Internet News 4.70.1161
Date: Tue, 14 Mar 2000 16:33:47 -0500
Lines: 46
NNTP-Posting-Host: childs-pc.sybase.com 172.31.141.190
Message-ID: <347_01bf8dfc$5eb97270$be8d1fac@childs-pc>
References: <347_VTIsXUfj$GA.285@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26427
Article PK: 157097

Sem, I would suggest giving tech support a call on this one (to try and
get things running again).

As for what happened. It looks like you've tried to create an ase cache
using an odbc (ASA) dll. There was a bug fix made for an upcoming 3.5 EBF
which should address this problem (server not starting when invalid cache
defined).

The original issue was described as:
"Description: Jaguar would not start up when a connection cache was
improperly specified in Jaguar Manager."

FYI
--
John Childs
Sybase
---
Please keep questions to the newsgroups. Bugs should be
reported to technical support.
---

Sem Kazazic <semk@vytalnet.com> wrote in article
<VTIsXUfj$GA.285@forums.sybase.com>...
Hi there,

After all, I did upgrade to 3.5 , and have been running with no problem
for few weeks.
We have ase 11.9.2 on same pc (win nt server 4 sp5).
Today I wanted to create new connection cache for ase db and everything
looked ok before I restarted jaguar server (it 's not nt service)
When I restarted jaguar I got dr. Watson.
1. in jaguar log I found cm_odbc_error:SQLState 08S01, [Sybase] [ODBC
Driver][Adaptive Server Anywhere] Communication link failure; connection
was terminated.
2. I tried to Carson/Dave posting about JAGUAR_RANDOMSEED , but found
nothing in c:\random.txt file
3. After that found in jaguar log AFLIB message 18011/11/0;dll lookup for
'af_dlllookup()' failed, OS Message.
Even if I did something wrong during connection cache setup, I don't
believe that could cause this kind of problem?

And the most disturbing thing, when I checked directory for jaguar
repository, all connection caches I had there disappeared.
Does anybody has an idea what happened, and what I am supposed to do next?

Thanks.
Regards,
Sem.


----------


Sem Kazazic Posted on 2000-03-14 21:40:01.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: Re: Alarming eas 3.5 - Jaguar dr. Watson
Date: Tue, 14 Mar 2000 16:40:01 -0500
Lines: 60
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_ePAFG6fj$GA.201@forums.sybase.com>
References: <347_VTIsXUfj$GA.285@forums.sybase.com> <347_01bf8dfc$5eb97270$be8d1fac@childs-pc>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26424
Article PK: 157093

Jim, Dave, John
Thanks. I appreciate extremely fast and useful reply.
Regards,
Sem.

John Childs wrote in message <01bf8dfc$5eb97270$be8d1fac@childs-pc>...
>Sem, I would suggest giving tech support a call on this one (to try and
>get things running again).
>
>As for what happened. It looks like you've tried to create an ase cache
>using an odbc (ASA) dll. There was a bug fix made for an upcoming 3.5 EBF
>which should address this problem (server not starting when invalid cache
>defined).
>
>The original issue was described as:
>"Description: Jaguar would not start up when a connection cache was
>improperly specified in Jaguar Manager."
>
>FYI
>--
>John Childs
>Sybase
>---
>Please keep questions to the newsgroups. Bugs should be
>reported to technical support.
>---
>
>Sem Kazazic <semk@vytalnet.com> wrote in article
><VTIsXUfj$GA.285@forums.sybase.com>...
>Hi there,
>
>After all, I did upgrade to 3.5 , and have been running with no problem
>for few weeks.
>We have ase 11.9.2 on same pc (win nt server 4 sp5).
>Today I wanted to create new connection cache for ase db and everything
>looked ok before I restarted jaguar server (it 's not nt service)
>When I restarted jaguar I got dr. Watson.
>1. in jaguar log I found cm_odbc_error:SQLState 08S01, [Sybase] [ODBC
>Driver][Adaptive Server Anywhere] Communication link failure; connection
>was terminated.
>2. I tried to Carson/Dave posting about JAGUAR_RANDOMSEED , but found
>nothing in c:\random.txt file
>3. After that found in jaguar log AFLIB message 18011/11/0;dll lookup for
>'af_dlllookup()' failed, OS Message.
>Even if I did something wrong during connection cache setup, I don't
>believe that could cause this kind of problem?
>
>And the most disturbing thing, when I checked directory for jaguar
>repository, all connection caches I had there disappeared.
>Does anybody has an idea what happened, and what I am supposed to do next?
>
>Thanks.
>Regards,
>Sem.
>
>
>----------
>


Sem Kazazic Posted on 2000-03-14 22:06:31.0Z
Newsgroups: sybase.public.easerver
From: "Sem Kazazic" <semk@vytalnet.com>
Subject: Re: Alarming eas 3.5 - Jaguar dr. Watson
Date: Tue, 14 Mar 2000 17:06:31 -0500
Lines: 77
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: 209.121.88.73
Message-ID: <347_D7ab5Igj$GA.151@forums.sybase.com>
References: <347_VTIsXUfj$GA.285@forums.sybase.com> <347_01bf8dfc$5eb97270$be8d1fac@childs-pc> <347_ePAFG6fj$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26419
Article PK: 157091

Hi there,
I am here and very happy to say I got a great lesson;
- I wanted to check what Jim suggested , deleted afconfig.dat then renamed
afconfig.dat.bak to afconfig.dat (of course I did a copy of afconfig.dat.bak
and afconfig.dat before).
- restarted jaguar and everything is ok again.
Unbelievable, I got three answers in 30 min. or so.
This group is really the best one.
I am convinced that the others can use this info too.
Thanks again.
Regards,
Sem.

Sem Kazazic wrote in message ...
>Jim, Dave, John
>Thanks. I appreciate extremely fast and useful reply.
>Regards,
>Sem.
>
>John Childs wrote in message <01bf8dfc$5eb97270$be8d1fac@childs-pc>...
>>Sem, I would suggest giving tech support a call on this one (to try and
>>get things running again).
>>
>>As for what happened. It looks like you've tried to create an ase cache
>>using an odbc (ASA) dll. There was a bug fix made for an upcoming 3.5
EBF
>>which should address this problem (server not starting when invalid cache
>>defined).
>>
>>The original issue was described as:
>>"Description: Jaguar would not start up when a connection cache was
>>improperly specified in Jaguar Manager."
>>
>>FYI
>>--
>>John Childs
>>Sybase
>>---
>>Please keep questions to the newsgroups. Bugs should be
>>reported to technical support.
>>---
>>
>>Sem Kazazic <semk@vytalnet.com> wrote in article
>><VTIsXUfj$GA.285@forums.sybase.com>...
>>Hi there,
>>
>>After all, I did upgrade to 3.5 , and have been running with no problem
>>for few weeks.
>>We have ase 11.9.2 on same pc (win nt server 4 sp5).
>>Today I wanted to create new connection cache for ase db and everything
>>looked ok before I restarted jaguar server (it 's not nt service)
>>When I restarted jaguar I got dr. Watson.
>>1. in jaguar log I found cm_odbc_error:SQLState 08S01, [Sybase] [ODBC
>>Driver][Adaptive Server Anywhere] Communication link failure; connection
>>was terminated.
>>2. I tried to Carson/Dave posting about JAGUAR_RANDOMSEED , but found
>>nothing in c:\random.txt file
>>3. After that found in jaguar log AFLIB message 18011/11/0;dll lookup for
>>'af_dlllookup()' failed, OS Message.
>>Even if I did something wrong during connection cache setup, I don't
>>believe that could cause this kind of problem?
>>
>>And the most disturbing thing, when I checked directory for jaguar
>>repository, all connection caches I had there disappeared.
>>Does anybody has an idea what happened, and what I am supposed to do next?
>>
>>Thanks.
>>Regards,
>>Sem.
>>
>>
>>----------
>>
>
>


Dave Wolf [Sybase] Posted on 2000-03-14 21:32:34.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: Alarming eas 3.5 - Jaguar dr. Watson
Date: Tue, 14 Mar 2000 16:32:34 -0500
Lines: 131
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0009_01BF8DD2.E6C0D930"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: vpn-eme-056.sybase.com 130.214.8.56
Message-ID: <347_9GRlt1fj$GA.285@forums.sybase.com>
References: <347_VTIsXUfj$GA.285@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26425
Article PK: 157099

A few things.
 
1) If when setting up the cache the afconfig.dat got hosed this can cause the server to crash at boot.
2) The random.txt file is a file you create.  This is generally when you see a GPF just as "Enabling 40 bit Encryption" is showing and
3) The connection cachine info is stored ecnrypted in %JAGUAR%\ini\afconfig.dat not the repository

Dave Wolf
Internet Applications Division
 
"Sem Kazazic" <semk@vytalnet.com> wrote in message news:VTIsXUfj$GA.285@forums.sybase.com...
Hi there,
 
After all, I did upgrade to 3.5 , and have been running with no problem  for few weeks.
We have ase 11.9.2 on same pc (win nt server 4 sp5).
Today I wanted to create new connection cache for ase db and everything looked ok before I restarted jaguar server (it 's not nt service)
When I restarted jaguar I got dr. Watson.
1. in jaguar log I found cm_odbc_error:SQLState 08S01, [Sybase] [ODBC Driver][Adaptive Server Anywhere] Communication link failure; connection was terminated.
2. I tried to Carson/Dave posting about JAGUAR_RANDOMSEED , but found nothing in c:\random.txt file
3. After that found in jaguar log AFLIB message 18011/11/0;dll lookup for 'af_dlllookup()' failed, OS Message.
Even if I did something wrong during connection cache setup, I don't believe that could cause this kind of problem?
 
And the most disturbing thing, when I checked directory for jaguar repository, all connection caches I had there disappeared.
Does anybody has an idea what happened, and what I am supposed to do next?
 
Thanks.
Regards,
Sem.
 


Jim O'Neil [Sybase] Posted on 2000-03-14 21:28:16.0Z
Newsgroups: sybase.public.easerver
Date: Tue, 14 Mar 2000 16:28:16 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Alarming eas 3.5 - Jaguar dr. Watson
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 60
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38CEAEF0.7E464C5A@sybase.com>
References: <347_VTIsXUfj$GA.285@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26428
Article PK: 157100


Sem Kazazic wrote:

> Hi there, After all, I did upgrade to 3.5 , and have been running
> with no problem for few weeks.We have ase 11.9.2 on same pc (win nt
> server 4 sp5).Today I wanted to create new connection cache for ase db
> and everything looked ok before I restarted jaguar server (it 's not
> nt service)When I restarted jaguar I got dr. Watson.1. in jaguar log I
> found cm_odbc_error:SQLState 08S01, [Sybase] [ODBC Driver][Adaptive
> Server Anywhere] Communication link failure; connection was
> terminated.2. I tried to Carson/Dave posting about JAGUAR_RANDOMSEED ,
> but found nothing in c:\random.txt file3. After that found in jaguar
> log AFLIB message 18011/11/0;dll lookup for 'af_dlllookup()' failed,
> OS Message.Even if I did something wrong during connection cache
> setup, I don't believe that could cause this kind of problem? And the
> most disturbing thing, when I checked directory for jaguar repository,
> all connection caches I had there disappeared.Does anybody has an idea
> what happened, and what I am supposed to do next? Thanks.Regards,Sem.

A couple of things here:

1. The ASA error would indicate some error that caused your ASA server
to terminate the connection that Jaguar had established - not sure what
may have happened there.

2. What random.txt file? when using JAGUAR_RANDOMSEED you set it to a
file of your choosing.

3. The connection cache definitions do not appear under the connection
cache folder in the repository, they are kept in the afconfig.dat file
in the INI subdirectory and this file is encrypted.

Now all that said, I have seen Jaguar 3.5 crash when the connection
cache data in the INI file is corrupted. If that's the case, one option
is to open an issue with support and have then decrypt your afconfig.dat
to see if indeed the connection cache information is corrupted (e.g.,
lots of bogus unprintable characters and not specifiying a valid library
name, for example, ODBC32.DLL, are two things that I've seen result in
server crashes on start up).

You should also have an afconfig.dat.bak that you can copy back over the
current afconfig.dat to see if that's really what's causing the problem
and perhaps you'll have the chance to recreate the new connection cache.

--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc