Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

class loader loading java componet from html\classes??

6 posts in General Discussion (old) Last posting was on 2000-03-08 16:15:57.0Z
Alan Lehman Posted on 2000-03-06 20:06:52.0Z
Newsgroups: sybase.public.easerver
From: "Alan Lehman" <alan.lehman@midata.com>
Subject: class loader loading java componet from html\classes??
Date: Mon, 6 Mar 2000 14:06:52 -0600
Lines: 8
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: efg1.mids.com 207.250.224.4
Message-ID: <347_YSPhWg6h$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27062
Article PK: 157997

Why is jaguar loading my classes fromthe html\classes when thay are deployed
to java\classes

Loading:
/ecom/EAStudio/JaguarCTS35/html/classes/org_access_package/_sk_Org_access_pa
ckage_org_access.class


Dave Wolf [Sybase] Posted on 2000-03-07 00:30:56.0Z
Newsgroups: sybase.public.easerver
From: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: class loader loading java componet from html\classes??
Date: Mon, 6 Mar 2000 19:30:56 -0500
Lines: 20
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: PPPa22-ResaleDialinx8008-4R1010.saturn.bbn.com 4.16.20.177
Message-ID: <347_bwC84z8h$GA.201@forums.sybase.com>
References: <347_YSPhWg6h$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27027
Article PK: 154477

It must have found the copies there. Delete them if you dont want those
versions loaded.

Dave Wolf
Internet Applications Divsion

"Alan Lehman" <alan.lehman@midata.com> wrote in message
news:YSPhWg6h$GA.202@forums.sybase.com...
> Why is jaguar loading my classes fromthe html\classes when thay are
deployed
> to java\classes
>
> Loading:
>
/ecom/EAStudio/JaguarCTS35/html/classes/org_access_package/_sk_Org_access_pa
> ckage_org_access.class
>
>


Evan Ireland Posted on 2000-03-07 20:10:41.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 08 Mar 2000 09:10:41 +1300
From: Evan Ireland <eireland@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
To: "Dave Wolf [Sybase]" <dwolf@sybase.com>
Subject: Re: class loader loading java componet from html\classes??
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 23
NNTP-Posting-Host: vpn-eme-038.sybase.com 130.214.8.38
Message-ID: <347_38C56241.D976EE00@sybase.com>
References: <347_YSPhWg6h$GA.202@forums.sybase.com> <347_bwC84z8h$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26956
Article PK: 154468


"Dave Wolf [Sybase]" wrote:
>
> It must have found the copies there. Delete them if you dont want those
> versions loaded.

The class loader should look first in java/classes before looking in
html/classes. I would open a case on this.

> Dave Wolf
> Internet Applications Divsion
>
> "Alan Lehman" <alan.lehman@midata.com> wrote in message
> news:YSPhWg6h$GA.202@forums.sybase.com...
> > Why is jaguar loading my classes fromthe html\classes when thay are
> deployed
> > to java\classes
> >
> > Loading:
> >
> /ecom/EAStudio/JaguarCTS35/html/classes/org_access_package/_sk_Org_access_pa
> > ckage_org_access.class
> >
> >

--
________________________________________________________________________________

Evan Ireland Sybase EA Server Engineering eireland@sybase.com
Wellington - New Zealand +64 4 934-5856


Alan Lehman Posted on 2000-03-08 16:15:57.0Z
Newsgroups: sybase.public.easerver
From: "Alan Lehman" <alan.lehman@midata.com>
Subject: Re: class loader loading java componet from html\classes??
Date: Wed, 8 Mar 2000 10:15:57 -0600
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: efg1.mids.com 207.250.224.4
Message-ID: <347_80N8soRi$GA.202@forums.sybase.com>
References: <347_YSPhWg6h$GA.202@forums.sybase.com> <347_bwC84z8h$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26887
Article PK: 157847

It looks like the powerj deployment process is deploying the jar file to
both the html\classes and the Java\classes.
Is there some option in the deployment that would cause this?

alan

Dave Wolf [Sybase] <dwolf@sybase.com> wrote in message
news:bwC84z8h$GA.201@forums.sybase.com...
> It must have found the copies there. Delete them if you dont want those
> versions loaded.
>
> Dave Wolf
> Internet Applications Divsion
>
> "Alan Lehman" <alan.lehman@midata.com> wrote in message
> news:YSPhWg6h$GA.202@forums.sybase.com...
> > Why is jaguar loading my classes fromthe html\classes when thay are
> deployed
> > to java\classes
> >
> > Loading:
> >
>
/ecom/EAStudio/JaguarCTS35/html/classes/org_access_package/_sk_Org_access_pa
> > ckage_org_access.class
> >
> >
>
>


Evan Ireland Posted on 2000-03-06 20:39:47.0Z
Newsgroups: sybase.public.easerver
Date: Tue, 07 Mar 2000 09:39:47 +1300
From: Evan Ireland <eireland@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: class loader loading java componet from html\classes??
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 14
NNTP-Posting-Host: vpn-eme-062.sybase.com 130.214.8.62
Message-ID: <347_38C41793.F9BED5AB@sybase.com>
References: <347_YSPhWg6h$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27056
Article PK: 154481

Which version of Jaguar are you referring to?

Alan Lehman wrote:
>
> Why is jaguar loading my classes fromthe html\classes when thay are deployed
> to java\classes
>
> Loading:
> /ecom/EAStudio/JaguarCTS35/html/classes/org_access_package/_sk_Org_access_pa
> ckage_org_access.class

--
________________________________________________________________________________

Evan Ireland Sybase EA Server Engineering eireland@sybase.com
Wellington - New Zealand +64 4 934-5856


Alan Lehman Posted on 2000-03-06 20:47:32.0Z
Newsgroups: sybase.public.easerver
From: "Alan Lehman" <alan.lehman@midata.com>
Subject: Re: class loader loading java componet from html\classes??
Date: Mon, 6 Mar 2000 14:47:32 -0600
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: efg1.mids.com 207.250.224.4
Message-ID: <347_w042D36h$GA.202@forums.sybase.com>
References: <347_YSPhWg6h$GA.202@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27054
Article PK: 157992

eas 3.5

Alan Lehman <alan.lehman@midata.com> wrote in message
news:YSPhWg6h$GA.202@forums.sybase.com...
> Why is jaguar loading my classes fromthe html\classes when thay are
deployed
> to java\classes
>
> Loading:
>
/ecom/EAStudio/JaguarCTS35/html/classes/org_access_package/_sk_Org_access_pa
> ckage_org_access.class
>
>