Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Dynamo / Jaguar / PB NVO help.

5 posts in General Discussion (old) Last posting was on 2000-03-09 10:17:19.0Z
äë Posted on 2000-03-07 16:33:17.0Z
Newsgroups: sybase.public.easerver
Reply-To: "äë" <jloubriel@hotmail.com>
From: "äë" <jloubriel@hotmail.com>
Subject: Dynamo / Jaguar / PB NVO help.
Date: Tue, 7 Mar 2000 09:33:17 -0700
Lines: 58
Organization: Bridge Resources
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: 204.131.108.118
Message-ID: <347_cGqvIOFi$GA.111@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26978
Article PK: 157924

I'm configuring Jaguar 3.0.1 and Powersite.
I can successfuly create java objects for the Surfside video sample app.
I created my own PB NVO and cannot get it to work.

Bellow are the details:

I created and deployed to jaguar a PB Package.
Next I went to Jag Manager and created Java Stubs (%JAGUAR%\html\classes\my
package dir.)
Next I compiled the Java Stubs in the same directory they were generated.
set
CLASSPATH=%JAGUAR%\html\classes;%JAGUAR%\html\classes\JagAppPK;%CLASSPATH%
javac *.java
I deleted the .java sources.

Directory of K:\Program Files\Sybase\Jaguar CTS 3.0\html\classes\JagAppPK

03/07/00 09:19a <DIR> .
03/07/00 09:19a <DIR> ..
03/07/00 08:37a 324 n_jagapps.class
03/07/00 08:37a 1,018 n_jagappsHelper.class
03/07/00 08:37a 390 n_jagappsHolder.class
03/07/00 08:37a 1,903 _st_n_jagapps.class

I try to create the java object in a Dynamo script:

var jagConn = java.CreateComponent( "JagAppPK/n_jagapps",
"iiop://websrv1:9000", "jagadmin", "","JagAppPK/n_jagapps");
if (jagConn == null)
{
jagError = site.GetErrorInfo ();
HTDW_DocWrite ("ERROR: Creating Jaguar component" + jagError +
"<BR>\n");
}

And I get the following error:

ERROR: Creating Jaguar componentException thrown:
java.lang.ClassNotFoundException: JagAppPK/n_jagappsHelper in method
loadClass of class DynamoClassLoader. Unable to find class:
JagAppPK/n_jagappsHelperUnable to narrow the component to the required
interface: "JagAppPK/n_jagappsHelper".

What am I missing?

My server CLASSPATH Env Var is:

Bq@;C:\Program Files\Sybase\Shared\PowerBuilder\classes.zip;C:\Program
Files\Sybase\Shared\PowerBuilder\classes111.zip;C:\Program
Files\Sybase\Shared\Sun\JDK118\lib\classes.zip;.

Do I need to change the classpath env var and reboot the server?

Thanks
Ulises
uloubrie@gmgw.com


Jim O'Neil [Sybase] Posted on 2000-03-07 19:00:24.0Z
Newsgroups: sybase.public.easerver
Date: Tue, 07 Mar 2000 14:00:24 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Dynamo / Jaguar / PB NVO help.
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Lines: 60
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38C551C7.E3F56E4B@sybase.com>
References: <347_cGqvIOFi$GA.111@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26965
Article PK: 157912


"äë" wrote:

> I'm configuring Jaguar 3.0.1 and Powersite.
> I can successfuly create java objects for the Surfside video sample app.
> I created my own PB NVO and cannot get it to work.
>
> Bellow are the details:
>
> I created and deployed to jaguar a PB Package.
> Next I went to Jag Manager and created Java Stubs (%JAGUAR%\html\classes\my
> package dir.)
> Next I compiled the Java Stubs in the same directory they were generated.
> set
> CLASSPATH=%JAGUAR%\html\classes;%JAGUAR%\html\classes\JagAppPK;%CLASSPATH%
> javac *.java
> I deleted the .java sources.
>
> Directory of K:\Program Files\Sybase\Jaguar CTS 3.0\html\classes\JagAppPK
>
> 03/07/00 09:19a <DIR> .
> 03/07/00 09:19a <DIR> ..
> 03/07/00 08:37a 324 n_jagapps.class
> 03/07/00 08:37a 1,018 n_jagappsHelper.class
> 03/07/00 08:37a 390 n_jagappsHolder.class
> 03/07/00 08:37a 1,903 _st_n_jagapps.class
>
> I try to create the java object in a Dynamo script:
>
> var jagConn = java.CreateComponent( "JagAppPK/n_jagapps",
> "iiop://websrv1:9000", "jagadmin", "","JagAppPK/n_jagapps");
> if (jagConn == null)
> {
> jagError = site.GetErrorInfo ();
> HTDW_DocWrite ("ERROR: Creating Jaguar component" + jagError +
> "<BR>\n");
> }
>
> And I get the following error:
>
> ERROR: Creating Jaguar componentException thrown:
> java.lang.ClassNotFoundException: JagAppPK/n_jagappsHelper in method
> loadClass of class DynamoClassLoader. Unable to find class:
> JagAppPK/n_jagappsHelperUnable to narrow the component to the required
> interface: "JagAppPK/n_jagappsHelper".
>
> What am I missing?
>
> My server CLASSPATH Env Var is:
>
> Bq@;C:\Program Files\Sybase\Shared\PowerBuilder\classes.zip;C:\Program
> Files\Sybase\Shared\PowerBuilder\classes111.zip;C:\Program
> Files\Sybase\Shared\Sun\JDK118\lib\classes.zip;.
>
> Do I need to change the classpath env var and reboot the server?
>
> Thanks
> Ulises
> uloubrie@gmgw.com

K:\Program Files\Sybase\Jaguar CTS 3.0\html\classes\JagAppPK would definitely
need to be in your CLASSPATH. You don't have to reboot the server though, just
set the class path and restart your webserver.
--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc


Dean Jones [Team Sybase] Posted on 2000-03-08 17:36:56.0Z
Newsgroups: sybase.public.easerver
From: "Dean Jones [Team Sybase]" <dean_no_spam_@powerobjects.com>
Subject: Re: Dynamo / Jaguar / PB NVO help.
Date: Wed, 8 Mar 2000 11:36:56 -0600
Lines: 97
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: modem10.outtech.com 216.207.144.240
Message-ID: <347_otHkuVSi$GA.201@forums.sybase.com>
References: <347_cGqvIOFi$GA.111@forums.sybase.com> <347_38C551C7.E3F56E4B@sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26875
Article PK: 157838

He does not need to add his package to the classpath. Just make sure
%jaguar%\html\classes is in the classpath.

After creating a new Java Stub he needs to restart PD.

HTH

--

Dean Jones, CPD Professional
Team Sybase
PowerTeam, Inc.

Seminar on April 26 and 27, Don't Miss it!
www.powerobjects.com/seminar

http://www.powerobjects.com

Jim O'Neil [Sybase] <joneil@sybase.com> wrote in message
news:38C551C7.E3F56E4B@sybase.com...
> "äë" wrote:
>
> > I'm configuring Jaguar 3.0.1 and Powersite.
> > I can successfuly create java objects for the Surfside video sample app.
> > I created my own PB NVO and cannot get it to work.
> >
> > Bellow are the details:
> >
> > I created and deployed to jaguar a PB Package.
> > Next I went to Jag Manager and created Java Stubs
(%JAGUAR%\html\classes\my
> > package dir.)
> > Next I compiled the Java Stubs in the same directory they were
generated.
> > set
> >
CLASSPATH=%JAGUAR%\html\classes;%JAGUAR%\html\classes\JagAppPK;%CLASSPATH%
> > javac *.java
> > I deleted the .java sources.
> >
> > Directory of K:\Program Files\Sybase\Jaguar CTS
3.0\html\classes\JagAppPK
> >
> > 03/07/00 09:19a <DIR> .
> > 03/07/00 09:19a <DIR> ..
> > 03/07/00 08:37a 324 n_jagapps.class
> > 03/07/00 08:37a 1,018 n_jagappsHelper.class
> > 03/07/00 08:37a 390 n_jagappsHolder.class
> > 03/07/00 08:37a 1,903 _st_n_jagapps.class
> >
> > I try to create the java object in a Dynamo script:
> >
> > var jagConn = java.CreateComponent( "JagAppPK/n_jagapps",
> > "iiop://websrv1:9000", "jagadmin", "","JagAppPK/n_jagapps");
> > if (jagConn == null)
> > {
> > jagError = site.GetErrorInfo ();
> > HTDW_DocWrite ("ERROR: Creating Jaguar component" + jagError +
> > "<BR>\n");
> > }
> >
> > And I get the following error:
> >
> > ERROR: Creating Jaguar componentException thrown:
> > java.lang.ClassNotFoundException: JagAppPK/n_jagappsHelper in method
> > loadClass of class DynamoClassLoader. Unable to find class:
> > JagAppPK/n_jagappsHelperUnable to narrow the component to the required
> > interface: "JagAppPK/n_jagappsHelper".
> >
> > What am I missing?
> >
> > My server CLASSPATH Env Var is:
> >
> > Bq@;C:\Program Files\Sybase\Shared\PowerBuilder\classes.zip;C:\Program
> > Files\Sybase\Shared\PowerBuilder\classes111.zip;C:\Program
> > Files\Sybase\Shared\Sun\JDK118\lib\classes.zip;.
> >
> > Do I need to change the classpath env var and reboot the server?
> >
> > Thanks
> > Ulises
> > uloubrie@gmgw.com
>
> K:\Program Files\Sybase\Jaguar CTS 3.0\html\classes\JagAppPK would
definitely
> need to be in your CLASSPATH. You don't have to reboot the server though,
just
> set the class path and restart your webserver.
> --
> Jim O'Neil
> Senior Technical Support Engineer
> Sybase, Inc
>
>


Jim O'Neil [Sybase] Posted on 2000-03-08 20:15:31.0Z
Newsgroups: sybase.public.easerver
Date: Wed, 08 Mar 2000 15:15:31 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Dynamo / Jaguar / PB NVO help.
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
Lines: 83
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38C6B4E2.A3B2D122@sybase.com>
References: <347_cGqvIOFi$GA.111@forums.sybase.com> <347_38C551C7.E3F56E4B@sybase.com> <347_otHkuVSi$GA.201@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26866
Article PK: 157831


"Dean Jones [Team Sybase]" wrote:

> He does not need to add his package to the classpath. Just make sure
> %jaguar%\html\classes is in the classpath.
>
> After creating a new Java Stub he needs to restart PD.
>
> HTH
>
> --
>
> Dean Jones, CPD Professional
> Team Sybase
> PowerTeam, Inc.
>
> Seminar on April 26 and 27, Don't Miss it!
> www.powerobjects.com/seminar
>
> http://www.powerobjects.com
>
> Jim O'Neil [Sybase] <joneil@sybase.com> wrote in message
> news:38C551C7.E3F56E4B@sybase.com...
> > "äë" wrote:
> >
> > > I'm configuring Jaguar 3.0.1 and Powersite.
> > > I can successfuly create java objects for the Surfside video sample app.
> > > I created my own PB NVO and cannot get it to work.
> > >
> > > Bellow are the details:
> > >
> > > I created and deployed to jaguar a PB Package.
> > > Next I went to Jag Manager and created Java Stubs
> (%JAGUAR%\html\classes\my
> > > package dir.)
> > > Next I compiled the Java Stubs in the same directory they were
> generated.
> > > set
> > >
> CLASSPATH=%JAGUAR%\html\classes;%JAGUAR%\html\classes\JagAppPK;%CLASSPATH%
> > > javac *.java
> > > I deleted the .java sources.
> > >
> > > Directory of K:\Program Files\Sybase\Jaguar CTS
> 3.0\html\classes\JagAppPK
> > >
> > > 03/07/00 09:19a <DIR> .
> > > 03/07/00 09:19a <DIR> ..
> > > 03/07/00 08:37a 324 n_jagapps.class
> > > 03/07/00 08:37a 1,018 n_jagappsHelper.class
> > > 03/07/00 08:37a 390 n_jagappsHolder.class
> > > 03/07/00 08:37a 1,903 _st_n_jagapps.class
> > >
> > > I try to create the java object in a Dynamo script:
> > >
> > > var jagConn = java.CreateComponent( "JagAppPK/n_jagapps",
> > > "iiop://websrv1:9000", "jagadmin", "","JagAppPK/n_jagapps");
> > > if (jagConn == null)
> > > {
> > > jagError = site.GetErrorInfo ();
> > > HTDW_DocWrite ("ERROR: Creating Jaguar component" + jagError +
> > > "<BR>\n");
> > > }
> > >
> > > And I get the following error:
> > >
> > > ERROR: Creating Jaguar componentException thrown:
> > > java.lang.ClassNotFoundException: JagAppPK/n_jagappsHelper in method
> > > loadClass of class DynamoClassLoader. Unable to find class:
> > > JagAppPK/n_jagappsHelperUnable to narrow the component to the required
> > > interface: "JagAppPK/n_jagappsHelper".
> > >
> > > What am I missing?
> > >
> > > My server CLASSPATH Env Var is:
> > >
> > > Bq@;C:\Program Files\Sybase\Shared\PowerBuilder\classes.zip;C:\Program
> > > Files\Sybase\Shared\PowerBuilder\classes111.zip;C:\Program
> > > Files\Sybase\Shared\Sun\JDK118\lib\classes.zip;.
> > >
> > > Do I need to change the classpath env var and reboot the server?
> > >
> > > Thanks
> > > Ulises
> > > uloubrie@gmgw.com
> >
> > K:\Program Files\Sybase\Jaguar CTS 3.0\html\classes\JagAppPK would
> definitely
> > need to be in your CLASSPATH. You don't have to reboot the server though,
> just
> > set the class path and restart your webserver.
> > --
> > Jim O'Neil
> > Senior Technical Support Engineer
> > Sybase, Inc
> >
> >

Yup, sorry, went overboard with the cut and paste.


--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc


Hans Mejdahl Jeppesen Posted on 2000-03-09 10:17:19.0Z
Newsgroups: sybase.public.easerver
Reply-To: "Hans Mejdahl Jeppesen" <hmj@datakontoret.dk>
From: "Hans Mejdahl Jeppesen" <hmj@datakontoret.dk>
Subject: Sv: Dynamo / Jaguar / PB NVO help.
Date: Thu, 9 Mar 2000 11:17:19 +0100
Lines: 19
Organization: Kingfisher A/S
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: mail.datakontoret.dk 193.89.23.2
Message-ID: <347_VKYvnEbi$GA.251@forums.sybase.com>
References: <347_cGqvIOFi$GA.111@forums.sybase.com> <347_38C551C7.E3F56E4B@sybase.com> <347_otHkuVSi$GA.201@forums.sybase.com> <347_38C6B4E2.A3B2D122@sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:26814
Article PK: 157787

This whas just what i needed !

Thanks !

But where did you get the information of using the stub generator in
Jagadmin
and the use of javac *.java ?

Regards Hans Mejdahl Jeppesen

Jim O'Neil [Sybase] <joneil@sybase.com> skrev i en
nyhedsmeddelelse:38C6B4E2.A3B2D122@sybase.com...

> "Dean Jones [Team Sybase]" wrote:
>
> > He does not need to add his package to the classpath. Just make sure
> > %jaguar%\html\classes is in the classpath.

--- 8< -- cut