Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Saving Page Parameters

2 posts in General Discussion (old) Last posting was on 2000-03-30 01:50:41.0Z
Stephen C. DeLuca Posted on 2000-03-29 15:31:39.0Z
Newsgroups: sybase.public.easerver
Reply-To: "Stephen C. DeLuca" <sdeluca@riteaid.com>
From: "Stephen C. DeLuca" <sdeluca@riteaid.com>
Subject: Saving Page Parameters
Date: Wed, 29 Mar 2000 10:31:39 -0500
Lines: 15
Organization: Rite Aid, Corp.
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: fw1.riteaid.com 204.28.140.2
Message-ID: <347_gCLK5RZm$GA.290@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25374
Article PK: 154297

I have an HTML Page which contains the Web Datawindow DTC and a submit
button. The datawindow contains selection parameters. When the submit
button is clicked, I get the values from the datawindow and pass them to
another HTML page, which uses the values as retrivial arguments to another
datawindow which produces a report. When I navigate back to the HTML Page
with the
datawindow containing the selection parameters, the original values are
still there, but if the submit button is clicked again, the values aren't
saved (or passed to the report HTML page again). I've tried every variation
of the "selflink" and "setselflink" methods, but can't get them to work.
Any ideas on what I'm missing?

TIA.


Larry Cermak[Team Sybase] Posted on 2000-03-30 01:50:41.0Z
Newsgroups: sybase.public.easerver
From: "Larry Cermak[Team Sybase]" <lcermak@ctpartners.com>
Subject: Re: Saving Page Parameters
Date: Wed, 29 Mar 2000 19:50:41 -0600
Lines: 37
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: node18.dhcpchi.dslspeed.zyan.com 208.41.199.18
Message-ID: <347_En$zkvem$GA.298@forums.sybase.com>
References: <347_gCLK5RZm$GA.290@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:25274
Article PK: 154283

This has been around a while and was supposed to be fixed in PB 7021 but I
still see it. What you have to do is use the HTMLContextApplied event to
populate the HTML with the fields yourself. This can be done in a service
class.

--

Larry Cermak [Team Sybase]
Corporate Technology Partners, Inc.
www.ctpartners.com
Web DataWindow Articles
(http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)

Web DataWindow Training
EAServer Training

"Stephen C. DeLuca" <sdeluca@riteaid.com> wrote in message
news:gCLK5RZm$GA.290@forums.sybase.com...
> I have an HTML Page which contains the Web Datawindow DTC and a submit
> button. The datawindow contains selection parameters. When the submit
> button is clicked, I get the values from the datawindow and pass them to
> another HTML page, which uses the values as retrivial arguments to another
> datawindow which produces a report. When I navigate back to the HTML
Page
> with the
> datawindow containing the selection parameters, the original values are
> still there, but if the submit button is clicked again, the values aren't
> saved (or passed to the report HTML page again). I've tried every
variation
> of the "selflink" and "setselflink" methods, but can't get them to work.
> Any ideas on what I'm missing?
>
> TIA.
>
>