Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Using Web DataWindow in ASP or MTS

3 posts in General Discussion (old) Last posting was on 2000-02-21 13:28:06.0Z
Rafa³ Blecharz Posted on 2000-02-16 13:35:35.0Z
Newsgroups: sybase.public.easerver
From: "Rafa³ Blecharz" <rafal@glowka.pol.pl>
Subject: Using Web DataWindow in ASP or MTS
Date: Wed, 16 Feb 2000 14:35:35 +0100
Lines: 36
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2615.200
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2615.200
NNTP-Posting-Host: 195.116.105.180
Message-ID: <347_kgH8nKIe$GA.149@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28583
Article PK: 160725

Hey All

I have a questions about Using Web DataWindow in ASP or MTS.

When I write script in ASP pages:
<%@ Language=JavaScript %>
<HTML>
<HEAD>
<META NAME="GENERATOR" Content="Microsoft Visual Studio 6.0">
</HEAD>
<BODY>

<%
var retVal

dwMine=Server.CreateObject("PowerBuilder.HTMLDataWindow");
..........

I get this Error In Web Browser :

Server object error 'ASP 0177 : ffffdf8f'
Server.CreateObject Failed
/testing/webDb_test.asp, line 11
ffffdf8f

1) I run regsvr32.exe pbdwr70.dll
2) I add my web in IIS Virtual Directory
3) I add Package in MTS and import component
PowerBuilder.HTMLDataWindow.1.0

Any suggestions.

Thanks
Rafal


Jay S. Posted on 2000-02-17 16:44:37.0Z
Newsgroups: sybase.public.easerver
From: "Jay S." <ash477@hotmail.com>
Subject: Re: Using Web DataWindow in ASP or MTS
Date: Thu, 17 Feb 2000 11:44:37 -0500
Lines: 52
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: 209.10.134.2
Message-ID: <347_L5NiaaWe$GA.149@forums.sybase.com>
References: <347_kgH8nKIe$GA.149@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28496
Article PK: 160650

Mine looks like this and works fine. Try this code, swap out the dwo & path
on the setdwobject() method, & let me know if you're still having the
problem. What is on your line '11' in your error being returned to IIS?

Here's my code:

<%
dwMine = Server.CreateObject("PowerBuilder.HTMLDataWindow");
retVal =
dwMine.SetDWObject("c:/Inetpub/wwwroot/intranet/powersite_workplace/html_dws
.pbl", "d_partner")

if (retVal == 1) {
retVal = dwMine.SetHTMLObjectName("dwMine");
var browser = Request.ServerVariables("HTTP_USER_AGENT");
dwMine.SetBrowser(browser);

yata yata yata
%>

Good luck,
Jay Shohet ash477@yahoo.com

"Rafa³ Blecharz" <rafal@glowka.pol.pl> wrote in message
news:kgH8nKIe$GA.149@forums.sybase.com...

> <%
> var retVal
>
> dwMine=Server.CreateObject("PowerBuilder.HTMLDataWindow");
> ..........
>
> I get this Error In Web Browser :
>
> Server object error 'ASP 0177 : ffffdf8f'
> Server.CreateObject Failed
> /testing/webDb_test.asp, line 11
> ffffdf8f
>
> 1) I run regsvr32.exe pbdwr70.dll
> 2) I add my web in IIS Virtual Directory
> 3) I add Package in MTS and import component
> PowerBuilder.HTMLDataWindow.1.0
>
> Any suggestions.
>
> Thanks
> Rafal
>
>


Rafa³ Blecharz Posted on 2000-02-21 13:28:06.0Z
Newsgroups: sybase.public.easerver
From: "Rafa³ Blecharz" <rafal@glowka.pol.pl>
Subject: Re: Using Web DataWindow in ASP or MTS
Date: Mon, 21 Feb 2000 14:28:06 +0100
Lines: 63
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2615.200
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2615.200
NNTP-Posting-Host: 195.116.105.180
Message-ID: <347_ZvQyJNQf$GA.273@forums.sybase.com>
References: <347_kgH8nKIe$GA.149@forums.sybase.com> <347_L5NiaaWe$GA.149@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28228
Article PK: 160105

Thanks for your help.

I set independ path in the setdwobject() method, and it's working.

Jay S. <ash477@hotmail.com> wrote in message
news:L5NiaaWe$GA.149@forums.sybase.com...
> Mine looks like this and works fine. Try this code, swap out the dwo &
path
> on the setdwobject() method, & let me know if you're still having the
> problem. What is on your line '11' in your error being returned to IIS?
>
> Here's my code:
>
> <%
> dwMine = Server.CreateObject("PowerBuilder.HTMLDataWindow");
> retVal =
> dwMine.SetDWObject("c:/Inetpub/wwwro
ot/intranet/powersite_workplace/html_dws
> .pbl", "d_partner")
>
> if (retVal == 1) {
> retVal = dwMine.SetHTMLObjectName("dwMine");
> var browser = Request.ServerVariables("HTTP_USER_AGENT");
> dwMine.SetBrowser(browser);
>
> yata yata yata
> %>
>
> Good luck,
> Jay Shohet ash477@yahoo.com
>
> "Rafa³ Blecharz" <rafal@glowka.pol.pl> wrote in message
> news:kgH8nKIe$GA.149@forums.sybase.com...
>
> > <%
> > var retVal
> >
> > dwMine=Server.CreateObject("PowerBuilder.HTMLDataWindow");
> > ..........
> >
> > I get this Error In Web Browser :
> >
> > Server object error 'ASP 0177 : ffffdf8f'
> > Server.CreateObject Failed
> > /testing/webDb_test.asp, line 11
> > ffffdf8f
> >
> > 1) I run regsvr32.exe pbdwr70.dll
> > 2) I add my web in IIS Virtual Directory
> > 3) I add Package in MTS and import component
> > PowerBuilder.HTMLDataWindow.1.0
> >
> > Any suggestions.
> >
> > Thanks
> > Rafal
> >
> >
>
>