Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

SetColumnLink questions

3 posts in General Discussion (old) Last posting was on 2000-02-23 15:49:25.0Z
BillB Posted on 2000-02-22 17:54:13.0Z
Newsgroups: sybase.public.easerver
From: "BillB" <bill.burtnik@cyrus-solutions.com>
Organization: 209.167.242.235
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: SetColumnLink questions
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Tue, 22 Feb 2000 12:54:13 -0500
Lines: 29
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_qwhbU3Vf$GA.265@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28163
Article PK: 154633

Please indulge me in a couple of SetColumnLink questions:

I'm attemting to link "d_customer_list" to d_customer_orders". The linked
columns are "id" and "sales_order_cust_id", respectively. They are both numeric
and the values above are the column names in the datawindow painter.
The web pages are w_customer.htm and w_orders.htm, respectively. I have trace
on and the SetColumnLink executes OK.

Heres my call:

dwMine.SetColumnLink( "id", "w_orders.htm",
"sales_order_cust_id='String(id)'","")

Questions:
1) Where do I call SetColumnLink? I assume before dwMine.Generate( ). Does it
matter if its done before after dwMine.Retrieve() or dwMine.SetSelfLink()?

2) Does the 2nd parameter to SetColumnLink require the full URL? such as
http://localhost/.....?

When I position my mouse over the id column, the microhelp does not display,
which leads me to believe the link is not recognized on my page. Of course
clicking
on the column does not display the orders either. Please help.

Thanks.
Bill Burtnik
Systems Consultant
Cyrus Solutions Inc
bill.burtnik@cyrus-solutions.com


Larry Cermak[Team Sybase] Posted on 2000-02-23 04:17:36.0Z
Newsgroups: sybase.public.easerver
From: "Larry Cermak[Team Sybase]" <lcermak@ctpartners.com>
Subject: Re: SetColumnLink questions
Date: Tue, 22 Feb 2000 22:17:36 -0600
Lines: 60
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: node49.dhcpchi.dslspeed.zyan.com 208.41.199.49
Message-ID: <347_002l$Xbf$GA.251@forums.sybase.com>
References: <347_qwhbU3Vf$GA.265@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28105
Article PK: 159996

First, have you tried simply putting the link and link arguments right on
the datawindow? That works just fine.

Now for the questions...

> 1) Where do I call SetColumnLink? I assume before dwMine.Generate( ).
Does it
> matter if its done before after dwMine.Retrieve() or dwMine.SetSelfLink()?

Not really. It just needs to occur before you call Generate.

> 2) Does the 2nd parameter to SetColumnLink require the full URL? such as
> http://localhost/?

If you give it a full URL it will work, however, if you ever change the URL
then you'll have to redo the link. So, simply do w_linkpage.html and it
will stay within the same web site and will work when you move away from
localhost.

> When I position my mouse over the id column, the microhelp does not
display,
> which leads me to believe the link is not recognized on my page. Of course
> clicking on the column does not display the orders either. Please help.
>
Did you check the return code from the SetColumnLink method? It will return
a succussful or unsuccessful indicator.

FWIW, I've had better luck placing the links and arguments right in the dw.

Larry Cermak [Team Sybase]
Corporate Technology Partners, Inc.
www.ctpartners.com
Web DataWindow Articles
(http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)

"BillB" <bill.burtnik@cyrus-solutions.com> wrote in message
news:qwhbU3Vf$GA.265@forums.sybase.com...
> Please indulge me in a couple of SetColumnLink questions:
>
> I'm attemting to link "d_customer_list" to d_customer_orders". The linked
> columns are "id" and "sales_order_cust_id", respectively. They are both
numeric
> and the values above are the column names in the datawindow painter.
> The web pages are w_customer.htm and w_orders.htm, respectively. I have
trace
> on and the SetColumnLink executes OK.
>
> Heres my call:
>
> dwMine.SetColumnLink( "id", "w_orders.htm",
> "sales_order_cust_id='String(id)'","")
>

> Thanks.
> Bill Burtnik
> Systems Consultant
> Cyrus Solutions Inc
> bill.burtnik@cyrus-solutions.com


BillB Posted on 2000-02-23 15:49:25.0Z
Newsgroups: sybase.public.easerver
From: "BillB" <bill.burtnik@cyrus-solutions.com>
Organization: 209.167.242.235
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: Re: SetColumnLink questions
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Wed, 23 Feb 2000 10:49:25 -0500
Lines: 69
NNTP-Posting-Host: 207.156.232.4
Message-ID: <347_pqNMPWhf$GA.151@forums.sybase.com>
References: <347_qwhbU3Vf$GA.265@forums.sybase.com> <347_002l$Xbf$GA.251@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28068
Article PK: 159960

On Tue, 22 Feb 2000 22:17:36 -0600,
in powersoft.public.easerver

Larry Cermak[Team Sybase] <lcermak@ctpartners.com> wrote:
>First, have you tried simply putting the link and link arguments right on
>the datawindow? That works just fine.
>
>Now for the questions...
>
>> 1) Where do I call SetColumnLink? I assume before dwMine.Generate( ).
>Does it
>> matter if its done before after dwMine.Retrieve() or dwMine.SetSelfLink()?
>
>Not really. It just needs to occur before you call Generate.
>
>> 2) Does the 2nd parameter to SetColumnLink require the full URL? such as
>> http://localhost/?
>
>If you give it a full URL it will work, however, if you ever change the URL
>then you'll have to redo the link. So, simply do w_linkpage.html and it
>will stay within the same web site and will work when you move away from
>localhost.
>
>> When I position my mouse over the id column, the microhelp does not
>display,
>> which leads me to believe the link is not recognized on my page. Of course
>> clicking on the column does not display the orders either. Please help.
>>
>Did you check the return code from the SetColumnLink method? It will return
>a succussful or unsuccessful indicator.
>
>FWIW, I've had better luck placing the links and arguments right in the dw.
>
>Larry Cermak [Team Sybase]
>Corporate Technology Partners, Inc.
>www.ctpartners.com
>Web DataWindow Articles
>(http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708)
>
>"BillB" <bill.burtnik@cyrus-solutions.com> wrote in message
>news:qwhbU3Vf$GA.265@forums.sybase.com...
>> Please indulge me in a couple of SetColumnLink questions:
>>
>> I'm attemting to link "d_customer_list" to d_customer_orders". The linked
>> columns are "id" and "sales_order_cust_id", respectively. They are both
>numeric
>> and the values above are the column names in the datawindow painter.
>> The web pages are w_customer.htm and w_orders.htm, respectively. I have
>trace
>> on and the SetColumnLink executes OK.
>>
>> Heres my call:
>>
>> dwMine.SetColumnLink( "id", "w_orders.htm",
>> "sales_order_cust_id='String(id)'","")
>>
>
>> Thanks.
>> Bill Burtnik
>> Systems Consultant
>> Cyrus Solutions Inc
>> bill.burtnik@cyrus-solutions.com
>
>

Thanks for the info Larry. I've since solved the linking problem: I needed to
add another column and put the link on "id_1" rather than "id". Looking at the
Powerdynamo demo pointed this out. I could not find anything mentioning this in
the product documentation or in your article. I suspect there is some other
reason and further investigation revealed that the column must have a tab order
of zero to be used a link!
tab order zero