Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

linkargs question

5 posts in General Discussion (old) Last posting was on 2000-02-16 05:25:12.0Z
Jay S. Posted on 2000-02-11 15:38:06.0Z
Newsgroups: sybase.public.easerver
From: "Jay S." <ash477@hotmail.com>
Subject: linkargs question
Date: Fri, 11 Feb 2000 10:38:06 -0500
Lines: 14
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: 209.10.134.2
Message-ID: <347_sn7yLZKd$GA.180@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28893
Article PK: 154729

I have this line of script in my page:
selfLinkArgs = "pa_dept_id='\"" + Request.QueryString("pa_dept_id") + "\"'";

pa_dept_id is an arbitrary name I gave to a variable that comes over as an
arg from another page. My where clause is formed by getting the value from
pa_dept_id. Is that the variable I should be using for my selfLinkArgs? Or
should it be the actual column name, dept_id?

Thanks,
Jay


Larry Cermak [Team Sybase] Posted on 2000-02-14 05:27:52.0Z
Newsgroups: sybase.public.easerver
From: "Larry Cermak [Team Sybase]" <lcermak@ctpartners.com>
Subject: Re: linkargs question
Date: Sun, 13 Feb 2000 23:27:52 -0600
Lines: 29
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
NNTP-Posting-Host: node49.dhcpchi.dslspeed.zyan.com 208.41.199.49
Message-ID: <347_EVnuw0qd$GA.223@forums.sybase.com>
References: <347_sn7yLZKd$GA.180@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28791
Article PK: 154716

document.value.passin_value

--
Larry Cermak [Team Sybase]
Corporate Technology Partners, Inc.
www.ctpartners.com

Web DataWindow Articles
http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708

Jay S. wrote in message ...
>I have this line of script in my page:
>selfLinkArgs = "pa_dept_id='\"" + Request.QueryString("pa_dept_id") +
"\"'";
>
>pa_dept_id is an arbitrary name I gave to a variable that comes over as an
>arg from another page. My where clause is formed by getting the value from
>pa_dept_id. Is that the variable I should be using for my selfLinkArgs?
Or
>should it be the actual column name, dept_id?
>
>Thanks,
>Jay
>
>
>
>


jay Posted on 2000-02-15 03:29:05.0Z
Newsgroups: sybase.public.easerver
From: "jay" <ash477@hotmail.com>
Subject: Re: linkargs question
Date: Mon, 14 Feb 2000 22:29:05 -0500
Lines: 39
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MIMEOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: cc414260-a.etntwn1.nj.home.com 24.3.205.187
Message-ID: <347_zW4#RY2d$GA.324@forums.sybase.com>
References: <347_sn7yLZKd$GA.180@forums.sybase.com> <347_EVnuw0qd$GA.223@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28680
Article PK: 160810

When I last tried it, ASP didn't recognize document.value notation...
Thats why I was forced to use the ASP Request object. But I'll try it
again, since I can't get this to work at all :(

"Larry Cermak [Team Sybase]" <lcermak@ctpartners.com> wrote in message
news:EVnuw0qd$GA.223@forums.sybase.com...
> document.value.passin_value
>
> --
> Larry Cermak [Team Sybase]
> Corporate Technology Partners, Inc.
> www.ctpartners.com
>
> Web DataWindow Articles
> http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708
>
> Jay S. wrote in message ...
> >I have this line of script in my page:
> >selfLinkArgs = "pa_dept_id='\"" + Request.QueryString("pa_dept_id") +
> "\"'";
> >
> >pa_dept_id is an arbitrary name I gave to a variable that comes over as
an
> >arg from another page. My where clause is formed by getting the value
from
> >pa_dept_id. Is that the variable I should be using for my selfLinkArgs?
> Or
> >should it be the actual column name, dept_id?
> >
> >Thanks,
> >Jay
> >
> >
> >
> >
>
>


jay Posted on 2000-02-16 05:25:12.0Z
Newsgroups: sybase.public.easerver
From: "jay" <ash477@hotmail.com>
Subject: Re: linkargs question
Date: Wed, 16 Feb 2000 00:25:12 -0500
Lines: 8
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: cc414260-a.etntwn1.nj.home.com 24.3.205.187
Message-ID: <347_GmLQ29De$GA.332@forums.sybase.com>
References: <347_sn7yLZKd$GA.180@forums.sybase.com> <347_EVnuw0qd$GA.223@forums.sybase.com> <347_zW4#RY2d$GA.324@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28597
Article PK: 160737

Another reason I'm pretty sure setselflink() isn't working in the IIS
environment, is that my updates don't work on datawindows that have a where
clause with a value passed into them. But for dwo's that have one straight
retrieval w/ nothing passed in, they update fine.
Rgds,
Jay


jay Posted on 2000-02-16 05:22:53.0Z
Newsgroups: sybase.public.easerver
From: "jay" <ash477@hotmail.com>
Subject: Re: linkargs question
Date: Wed, 16 Feb 2000 00:22:53 -0500
Lines: 65
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
NNTP-Posting-Host: cc414260-a.etntwn1.nj.home.com 24.3.205.187
Message-ID: <347_loKWj8De$GA.324@forums.sybase.com>
References: <347_sn7yLZKd$GA.180@forums.sybase.com> <347_EVnuw0qd$GA.223@forums.sybase.com> <347_zW4#RY2d$GA.324@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:28598
Article PK: 160738

Sorry Larry, I've got two questions posted that are asking the same thing :)
Anyway... if I have:

args = "user_id='\"" + Request.QueryString("user_id") + "\"'"
retVal=dwMine.setselflink("partner_detail.asp", args);

retVal returns an empty string. Thats probably not correct. Also, I have
to use
Querystring() because I'm in an IIS environment -- but don't wory, that
works fine. It returns the value '1', or '2', or whatever the user_id is.

Any suggestions?

Rgds,
Jay Shohet ash477@hotmail.com

"jay" <ash477@hotmail.com> wrote in message
news:zW4#RY2d$GA.324@forums.sybase.com...
> When I last tried it, ASP didn't recognize document.value notation...
> Thats why I was forced to use the ASP Request object. But I'll try it
> again, since I can't get this to work at all :(
>
> "Larry Cermak [Team Sybase]" <lcermak@ctpartners.com> wrote in message
> news:EVnuw0qd$GA.223@forums.sybase.com...
> > document.value.passin_value
> >
> > --
> > Larry Cermak [Team Sybase]
> > Corporate Technology Partners, Inc.
> > www.ctpartners.com
> >
> > Web DataWindow Articles
> > http://sdn.sybase.com/sdn/appdev/get_doc.stm?loc=1001708
> >
> > Jay S. wrote in message ...
> > >I have this line of script in my page:
> > >selfLinkArgs = "pa_dept_id='\"" + Request.QueryString("pa_dept_id") +
> > "\"'";
> > >
> > >pa_dept_id is an arbitrary name I gave to a variable that comes over as
> an
> > >arg from another page. My where clause is formed by getting the value
> from
> > >pa_dept_id. Is that the variable I should be using for my
selfLinkArgs?
> > Or
> > >should it be the actual column name, dept_id?
> > >
> > >Thanks,
> > >Jay
> > >
> > >
> > >
> > >
> >
> >
>
>