Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

STORED PROC WEB DW with EAS 3.5

2 posts in General Discussion (old) Last posting was on 2000-02-29 18:18:20.0Z
Minhhong Tran Posted on 2000-02-29 16:58:23.0Z
Newsgroups: sybase.public.easerver
Reply-To: "Minhhong Tran" <tran.minhhong@corona.navy.mil>
From: "Minhhong Tran" <tran.minhhong@corona.navy.mil>
Subject: STORED PROC WEB DW with EAS 3.5
Date: Tue, 29 Feb 2000 08:58:23 -0800
Lines: 14
Organization: NWAS QA42
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2314.1300
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
NNTP-Posting-Host: gatekeeper.corona.navy.mil 192.31.174.30
Message-ID: <347_wHUpvbtg$GA.297@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27498
Article PK: 158885

Back in December 2, 99, I had a problem with web dw return data from a store
proc. Jim O'Neil suggested to mark the HTMLGenerator as
Transaction Not Supported, this should go away. I did that and everything
works well under EAS 3.0. Now that I upgrade to EAS 3.5, I mark the
HTMLGenerator to Transaction Not Supported, I have a blank screen - No data
display - no error message.

Does anyone run into the same problem? What else can we do to fix it?

TIA,
Minhhong Tran


Jim O'Neil [Sybase] Posted on 2000-02-29 18:18:20.0Z
Newsgroups: sybase.public.easerver
Date: Tue, 29 Feb 2000 13:18:20 -0500
From: "Jim O'Neil [Sybase]" <joneil@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: STORED PROC WEB DW with EAS 3.5
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 28
NNTP-Posting-Host: joneil-nt.sybase.com 204.167.42.111
Message-ID: <347_38BC0D6C.C06602D5@sybase.com>
References: <347_wHUpvbtg$GA.297@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.easerver:27484
Article PK: 158874


Minhhong Tran wrote:

> Back in December 2, 99, I had a problem with web dw return data from a store
> proc. Jim O'Neil suggested to mark the HTMLGenerator as
> Transaction Not Supported, this should go away. I did that and everything
> works well under EAS 3.0. Now that I upgrade to EAS 3.5, I mark the
> HTMLGenerator to Transaction Not Supported, I have a blank screen - No data
> display - no error message.
>
> Does anyone run into the same problem? What else can we do to fix it?
>
> TIA,
> Minhhong Tran

The other option to get around your problem was to allow ddl in tran on your
database. That's probably a safer way of doing things (well, your DBA may
disagree), because the original component was marked as Requires transaction for
a reason, changing the transactional attribute could have an adverse affect
depending on the implementation. Now I cannot guarantee that this what's
causing the behaviour your are seeing, but it might be worth a shot. Are other
WebDW's working?
--
Jim O'Neil
Senior Technical Support Engineer
Sybase, Inc