Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Unexplained error trying to prompt for criteria

2 posts in PB Infomaker Report Writer Last posting was on 1997-11-07 19:16:16.0Z
Don Whitehead Posted on 1997-11-04 19:15:30.0Z
Newsgroups: sybase.public.infomaker.general
From: "Don Whitehead" <don.whitehea@empire.ca>
Subject: Unexplained error trying to prompt for criteria
Organization: Empire Financial Group
X-Newsreader: Microsoft Internet News 4.70.1157
Date: Tue, 04 Nov 1997 14:15:30 -0500
Lines: 17
Message-ID: <348_01bce95f$278dca60$ac0302a3@dwhitehead.efg_corporate>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:7404
Article PK: 244460

We are running Infomaker 5.0.02 and I am encountering a strange error...We
have a
report that is producing labels. The query to create these labels does a
simple join to 2 tables...The report also prompts for criteria....When I
preview the report it works fine..When I create an .exe and move it to our
NT server, it also runs fine on my machine...However on othe machines we
get the following message:

Cannot apply criteria to a select statement with a union or nested select
or
nested report.


We are running SYBASE 11 as well

Can someone please advise me where to start looking

Thanks in advance
Don Whitehead
(don.whitehead@empire.ca)


Terry Dykstra Posted on 1997-11-07 19:16:16.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra" <tdykstra@cfol.ab.ca>
Subject: Re: Unexplained error trying to prompt for criteria
X-Newsreader: Microsoft Internet News 4.70.1161
Date: Fri, 07 Nov 1997 14:16:16 -0500
Lines: 34
Message-ID: <348_01bcebba$1425d780$8366e4cf@tdykstra.cfol.ab.ca>
References: <348_01bce95f$278dca60$ac0302a3@dwhitehead.efg_corporate>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:7399
Article PK: 244454

I found the following in the infobase:

>>From several Folio issues, this is a bug that was fixed in 5.0.02
Infomaker. Customer's Infomaker says it is 5.0.02. I tried this here, and
my exe worked with prompt for criteria. We used pvers.exe to check his
dlls. They looked good. Found in Delta tracking that this was fixed in
pbdwe050.dll. When he looked at the network files, he saw that there was
an older version of this dll out there (and IM is running off the network).
<<

So it appears that you need to upgrade the deployment kit on th offending
PC's, especially yhe pbdew050.dll

Terry Dykstra (TeamPS)

Don Whitehead <don.whitehea@empire.ca> wrote in article
<01bce95f$278dca60$ac0302a3@dwhitehead.efg_corporate>...
> We are running Infomaker 5.0.02 and I am encountering a strange
error...We
> have a
> report that is producing labels. The query to create these labels does a
> simple join to 2 tables...The report also prompts for criteria....When I
> preview the report it works fine..When I create an .exe and move it to
our
> NT server, it also runs fine on my machine...However on othe machines we
> get the following message:
>
> Cannot apply criteria to a select statement with a union or nested select
> or
> nested report.
>
>
> We are running SYBASE 11 as well