Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problem with $$ returns from Oracle

2 posts in PB Infomaker Report Writer Last posting was on 1998-07-28 18:43:00.0Z
Scott Gipson Posted on 1998-07-28 16:06:33.0Z
Newsgroups: sybase.public.infomaker.general
Date: Tue, 28 Jul 1998 11:06:33 -0500
From: Scott Gipson <sgipson@forgottenlane.com>
Reply-To: sgipson@forgottenlane.com
Organization: Gipson & Associates
X-Mailer: Mozilla 3.0 (Win95; I)
MIME-Version: 1.0
Subject: Problem with $$ returns from Oracle
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 14
Message-ID: <348_35BDF709.2251@forgottenlane.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6969
Article PK: 243003

Using IM 5.0 and 6.0 I run a query against an Oracle table that in one
column (looking into it via Oracle) shows numbers only (i.e. 15000 or
4500) but when returned in the IM query - the 1st and 11th rows show the
correct number but all items in between are zeros or strings of numbers.

All other data returned from that query is fine. Someone suggested that
I find a Sybase ODBC driver versus the Oracle for Windows driver that I
am using.

Any ideas?
--
GIPSON & ASSOCIATES
http://www.forgottenlane.com
817.790.3547.tel


Terry Dykstra [TeamPS] Posted on 1998-07-28 18:43:00.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra [TeamPS]" <no_spam_tdykstra@cfol.ab.ca>
Subject: Re: Problem with $$ returns from Oracle
Date: Tue, 28 Jul 1998 12:43:00 -0600
Lines: 29
Organization: Canadian Forest Oil Ltd.
X-Newsreader: Microsoft Outlook Express 4.72.2106.4
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.2106.4
Message-ID: <348_Doh3k3ku9GA.265@forums.powersoft.com>
References: <348_35BDF709.2251@forgottenlane.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6968
Article PK: 243000

Oracle ODBC drivers tend to be flaky at best. Version 2.003 seems to be one
of the better ones. 2.5 is very buggy.
Why not use one of the native Oracle driver that comes with IM?
Intersolv and Visigenic make good ODBC drivers, but they don't come cheap.
The IM native driver is free with unlimited distribution.
--
Terry Dykstra [TeamPS]
Canadian Forest Oil Ltd.
See you at the Powersoft Conference in L.A.
http://www.sybase.com/Events/psuc98/index.html

Scott Gipson wrote in message <35BDF709.2251@forgottenlane.com>...
>Using IM 5.0 and 6.0 I run a query against an Oracle table that in one
>column (looking into it via Oracle) shows numbers only (i.e. 15000 or
>4500) but when returned in the IM query - the 1st and 11th rows show the
>correct number but all items in between are zeros or strings of numbers.
>
>All other data returned from that query is fine. Someone suggested that
>I find a Sybase ODBC driver versus the Oracle for Windows driver that I
>am using.
>
>Any ideas?
>--
>GIPSON & ASSOCIATES
>http://www.forgottenlane.com
>817.790.3547.tel
>