Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Sort and Filter problem in IM6.0/6.5

4 posts in PB Infomaker Report Writer Last posting was on 1998-10-29 20:01:08.0Z
Peter Kong Posted on 1998-10-12 16:24:06.0Z
Newsgroups: sybase.public.infomaker.general
Date: Tue, 13 Oct 1998 00:24:06 +0800
From: Peter Kong <kfkong@pc.jaring.my>
X-Mailer: Mozilla 4.05 [en] (Win95; I)
MIME-Version: 1.0
Subject: Sort and Filter problem in IM6.0/6.5
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 8
Message-ID: <348_36222D26.DAF6F907@pc.jaring.my>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6849
Article PK: 242879

Hello All!

I am having problem with my IM6.5 report in Win platform during sorting
and filtering. Each time after I filter or sort the report, it will not
come out the same report format as I wanted. Has any one came across
with these problems before? Is this IM's bug or my own bug?


Terry Dykstra (TeamPS) Posted on 1998-10-15 18:21:56.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra (TeamPS)" <dont_spam_me_tdykstra@cfol.ab.ca>
Subject: Re: Sort and Filter problem in IM6.0/6.5
Date: Thu, 15 Oct 1998 12:21:56 -0600
Lines: 18
X-Newsreader: Microsoft Outlook Express 4.72.2106.4
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.2106.4
Message-ID: <348_MBVZF9F#9GA.150@forums.powersoft.com>
References: <348_36222D26.DAF6F907@pc.jaring.my>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6835
Article PK: 242864

Can you be a bit more specific on what happens?
When using filters, be aware that after you reset the filter, IM / PB will
not necessarily put the data in the exact same order. You must resort after
a filter operation. If you have PB6, you can actually modify the
imstyle6.pbl, so the sort happens automatically after each filter operation.

Terry Dykstra (TeamPS)

Peter Kong wrote in message <36222D26.DAF6F907@pc.jaring.my>...
>Hello All!
>
>I am having problem with my IM6.5 report in Win platform during sorting
>and filtering. Each time after I filter or sort the report, it will not
>come out the same report format as I wanted. Has any one came across
>with these problems before? Is this IM's bug or my own bug?
>


Tony Chard Posted on 1998-10-29 13:25:26.0Z
Newsgroups: sybase.public.infomaker.general
Date: Thu, 29 Oct 1998 13:25:26 +0000
From: Tony Chard <tony.chard@rrmc.co.uk>
Reply-To: tony.chard@rrmc.co.uk
Organization: Rolls-Royce Motor Cars Ltd
X-Mailer: Mozilla 4.02 [en] (Win95; I)
MIME-Version: 1.0
To: "Terry Dykstra (TeamPS)" <dont_spam_me_tdykstra@cfol.ab.ca>
Subject: Re: Sort and Filter problem in IM6.0/6.5
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 34
Message-ID: <348_36386CC6.9BBAF0B7@rrmc.co.uk>
References: <348_36222D26.DAF6F907@pc.jaring.my> <348_MBVZF9F#9GA.150@forums.powersoft.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6799
Article PK: 242827

I have had similar problems when sorting on a computed field. Is this the same
problem?? If it is is there a solution? If it is not is there a solution to it
anyway?

The issue is that when a report is run with a sort defined through an
expression, the outcome is not sorted on that expression. If the order of the
sort criteria is changed and then changed back the sort is correct.

Please help as it is not possible to change the sort order within an executable.

Stuart White (borrowed e-mail account)

Terry Dykstra (TeamPS) wrote:

> Can you be a bit more specific on what happens?
> When using filters, be aware that after you reset the filter, IM / PB will
> not necessarily put the data in the exact same order. You must resort after
> a filter operation. If you have PB6, you can actually modify the
> imstyle6.pbl, so the sort happens automatically after each filter operation.
>
> Terry Dykstra (TeamPS)
>
> Peter Kong wrote in message <36222D26.DAF6F907@pc.jaring.my>...
> >Hello All!
> >
> >I am having problem with my IM6.5 report in Win platform during sorting
> >and filtering. Each time after I filter or sort the report, it will not
> >come out the same report format as I wanted. Has any one came across
> >with these problems before? Is this IM's bug or my own bug?
> >


Terry Dykstra [TeamPS] Posted on 1998-10-29 20:01:08.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra [TeamPS]" <no_spam_tdykstra@cfol.ab.ca>
Subject: Re: Sort and Filter problem in IM6.0/6.5
Date: Thu, 29 Oct 1998 13:01:08 -0700
Lines: 51
Organization: Canadian Forest Oil Ltd.
X-Newsreader: Microsoft Outlook Express 4.72.2106.4
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.2106.4
Message-ID: <348_F#ho3z2A#GA.275@forums.powersoft.com>
References: <348_36222D26.DAF6F907@pc.jaring.my> <348_MBVZF9F#9GA.150@forums.powersoft.com> <348_36386CC6.9BBAF0B7@rrmc.co.uk>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6795
Article PK: 242825

I believe that is the same problem. You need PB6 to fix it.
If you want to, send me your imstyle6.pbl and an example pbl with your
report. I'll try to duplicate and fix the imstyle6.pbl.

--
Terry Dykstra [TeamPS]
Canadian Forest Oil Ltd.

Tony Chard wrote in message <36386CC6.9BBAF0B7@rrmc.co.uk>...
>I have had similar problems when sorting on a computed field. Is this the
same
>problem?? If it is is there a solution? If it is not is there a solution to
it
>anyway?
>
>The issue is that when a report is run with a sort defined through an
>expression, the outcome is not sorted on that expression. If the order of
the
>sort criteria is changed and then changed back the sort is correct.
>
>Please help as it is not possible to change the sort order within an
executable.
>
>Stuart White (borrowed e-mail account)
>
>Terry Dykstra (TeamPS) wrote:
>
>> Can you be a bit more specific on what happens?
>> When using filters, be aware that after you reset the filter, IM / PB
will
>> not necessarily put the data in the exact same order. You must resort
after
>> a filter operation. If you have PB6, you can actually modify the
>> imstyle6.pbl, so the sort happens automatically after each filter
operation.
>>
>> Terry Dykstra (TeamPS)
>>
>> Peter Kong wrote in message <36222D26.DAF6F907@pc.jaring.my>...
>> >Hello All!
>> >
>> >I am having problem with my IM6.5 report in Win platform during sorting
>> >and filtering. Each time after I filter or sort the report, it will not
>> >come out the same report format as I wanted. Has any one came across
>> >with these problems before? Is this IM's bug or my own bug?
>> >
>
>
>