Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Field not Found?

3 posts in PB Infomaker Report Writer Last posting was on 1999-02-18 22:10:25.0Z
Rebecca Snyder Posted on 1999-02-15 18:16:41.0Z
Newsgroups: sybase.public.infomaker.general
Date: Mon, 15 Feb 1999 12:16:41 -0600
From: Rebecca Snyder <becky@bumail.bradley.edu>
Organization: Bradley University
X-Mailer: Mozilla 4.01 [en] (Win95; I)
MIME-Version: 1.0
Subject: Field not Found?
X-Priority: 3 (Normal)
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 20
Message-ID: <348_36C86489.F27CD2BB@bumail.bradley.edu>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6564
Article PK: 241549

We're testing Infomaker as our ad hoc tool-of-choice. We have it
working like a charm with ASA 6.0 database. We are also testing it with
Btrieve. I've downloaded a trial version of the Intersolve ODBC drivers
(3.0). I'm able to connect, view my tables, even view the data in my
tables. But when I try to paint a query or report, I consistantly get
'SQLSTATE=S0022 [INTERSOLV][ODBC Btrieve driver] Field not found: (field
name)'
If I'm in the report painter for a single select table, I can get into
'view syntax' and remove the table name from the select (ie: change
'prospect.ident' to 'ident') and my report will run. I can't figure out
what kind of problem it's having with the field name. Any thoughts out
there? Thanks!!
Becky


Terry Dykstra Posted on 1999-02-17 16:16:06.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra" <tdykstra@cfol.ab.ca>
Subject: Re: Field not Found?
Date: Wed, 17 Feb 1999 09:16:06 -0700
Lines: 28
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
Message-ID: <348_#mGeGCpW#GA.303@forums.powersoft.com>
References: <348_36C86489.F27CD2BB@bumail.bradley.edu>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6551
Article PK: 241537

Are there any special characters in the table ort column names. It is a
long time ago since I worked with BTrieve. In the ODBC setup you can
specify how to handle some of these characters.
Also, make sure that your Btrieve data file and definition file are exactly
in sync.
BTW, IM comes with a BTrieve ODBC driver. I believe it is a customized
version of the Intersolv driver. Have you tried it?

--
Terry Dykstra (TeamPS)
Canadian Forest Oil Ltd.

Rebecca Snyder wrote in message <36C86489.F27CD2BB@bumail.bradley.edu>...
>We're testing Infomaker as our ad hoc tool-of-choice. We have it
>working like a charm with ASA 6.0 database. We are also testing it with
>Btrieve. I've downloaded a trial version of the Intersolve ODBC drivers
>(3.0). I'm able to connect, view my tables, even view the data in my
>tables. But when I try to paint a query or report, I consistantly get
>'SQLSTATE=S0022 [INTERSOLV][ODBC Btrieve driver] Field not found: (field
>name)'
>If I'm in the report painter for a single select table, I can get into
>'view syntax' and remove the table name from the select (ie: change
>'prospect.ident' to 'ident') and my report will run. I can't figure out
>what kind of problem it's having with the field name. Any thoughts out
>there? Thanks!!
>Becky
>


Rebecca Snyder Posted on 1999-02-18 22:10:25.0Z
Newsgroups: sybase.public.infomaker.general
Date: Thu, 18 Feb 1999 16:10:25 -0600
From: Rebecca Snyder <becky@bumail.bradley.edu>
Organization: Bradley University
X-Mailer: Mozilla 4.01 [en] (Win95; I)
MIME-Version: 1.0
Subject: Re: Field not Found?
X-Priority: 3 (Normal)
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Lines: 14
Message-ID: <348_36CC8FCF.F3856D2C@bumail.bradley.edu>
References: <348_36C86489.F27CD2BB@bumail.bradley.edu> <348_#mGeGCpW#GA.303@forums.powersoft.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6542
Article PK: 241528


Terry Dykstra wrote:

> BTW, IM comes with a BTrieve ODBC driver. I believe it is a
> customized
> version of the Intersolv driver. Have you tried it?
>

I thought IM came with some ODBC drivers, but none were installed. I
tried the install again, but this time specified 'custom' and made sure
to select ODBC drivers, and sure enough, they appear. This didn't fix
my problem, but sure saves the hassle of ordering extra drivers.
Thanks. I'll look at your other suggestions for my Field not Found
problem.

Becky