Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

GetFullState and SetFullState not working in PB6.0?

2 posts in PB Infomaker Report Writer Last posting was on 1999-07-07 14:23:46.0Z
Liam Caffrey Posted on 1999-07-07 07:55:24.0Z
Newsgroups: sybase.public.infomaker.general
From: "Liam Caffrey" <caffreyl.delete_spam@nortelnetworks.com>
Organization: 192.100.101.16
X-Newsreader: AspNNTP 1.41 (Advent 2000, Inc.)
Subject: GetFullState and SetFullState not working in PB6.0?
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Date: Wed, 07 Jul 1999 03:55:24 -0400
Lines: 26
Message-ID: <348_N0G6R4Ey#GA.206@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.infomaker.general:6127
Article PK: 240063

This seems to be a PB6.0 problem

This is some command button code, returns a blob representing retrieved
data (3 rows - that is the return code of GetFullState in the
uf_retrieve_data method)
However the String (lblb_data) is 'A' !! and Len (String (lblb_data)) is
1
lu_db is explicitly instantiated but it doesn't work either when it is
autoinstantiated

Is there a bug on this? I can work around it but a have to compenstate
with all kinds of crap.

lu_db = CREATE u_db_iface ;

li_rtn = lu_db.uf_retrieve_data (rb_order_no.Checked, sle_search.Text,
lblb_data)
IF li_rtn > 0 THEN
idw_visual_order.Reset ()
li_rtn = idw_visual_order.SetFullState (lblb_data)

// li_rtn = idw_visual_order.RowCount ()
// idw_visual_order.DataObject = ldw_target.DataObject
// idw_visual_order.Object.Data = ldw_target.Object.Data

iw_window.wf_set_result_window_size ()
END IF

DESTROY lu_db ;

Any help would be appreciated

Liam


Regards

Liam Caffrey
caffreyl.delete_this_part@nortelnetworks.com


Terry Dykstra Posted on 1999-07-07 14:23:46.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra" <tdykstra@cfol.ab.ca>
Subject: Re: GetFullState and SetFullState not working in PB6.0?
Date: Wed, 7 Jul 1999 08:23:46 -0600
Lines: 48
X-Newsreader: Microsoft Outlook Express 4.72.3612.1700
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3612.1700
Message-ID: <348_T$8oBPIy#GA.155@forums.sybase.com>
References: <348_N0G6R4Ey#GA.206@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.infomaker.general:6124
Article PK: 240060

Ask PB questions in the PB newsgroups please, like
powersoft.public.powerbuilder.general

--
Terry Dykstra (TeamSybase)
Canadian Forest Oil Ltd.

Liam Caffrey wrote in message ...
>This seems to be a PB6.0 problem
>
>This is some command button code, returns a blob representing retrieved
>data (3 rows - that is the return code of GetFullState in the
>uf_retrieve_data method)
>However the String (lblb_data) is 'A' !! and Len (String (lblb_data)) is
>1
>lu_db is explicitly instantiated but it doesn't work either when it is
>autoinstantiated
>
>Is there a bug on this? I can work around it but a have to compenstate
>with all kinds of crap.
>
>lu_db = CREATE u_db_iface ;
>
>li_rtn = lu_db.uf_retrieve_data (rb_order_no.Checked, sle_search.Text,
>lblb_data)
>IF li_rtn > 0 THEN
> idw_visual_order.Reset ()
> li_rtn = idw_visual_order.SetFullState (lblb_data)
>
>// li_rtn = idw_visual_order.RowCount ()
>// idw_visual_order.DataObject = ldw_target.DataObject
>// idw_visual_order.Object.Data = ldw_target.Object.Data
>
> iw_window.wf_set_result_window_size ()
>END IF
>
>DESTROY lu_db ;
>
>Any help would be appreciated
>
>Liam
>
>
>Regards
>
>Liam Caffrey
>caffreyl.delete_this_part@nortelnetworks.com