Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Report Summary Band Not Processed

2 posts in PB Infomaker Report Writer Last posting was on 1998-11-23 18:00:42.0Z
Michael H Lewis Posted on 1998-11-22 04:10:55.0Z
Newsgroups: sybase.public.infomaker.general
From: "Michael H Lewis" <mike@ssi-louisville.com>
Subject: Report Summary Band Not Processed
Date: Sat, 21 Nov 1998 23:10:55 -0500
Lines: 12
X-Newsreader: Microsoft Outlook Express 4.72.2106.4
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.2106.4
Message-ID: <348_efxQeRcF#GA.150@forums.powersoft.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6710
Article PK: 241697

I recently created a simple report in PowerViewer 3.0. In the summary band
of the report, I placed a statement to print the number of rows printed on
the report, or *** No Data *** if RowCount returns zero. However, it
appears that PV 3.0 does not execute the statement in the Summary band when
the RowCount is zero, therefore I do not get the *** No Data *** line
printed on the report.

There is probably a very simple solution to this problem, but it has been a
few years since I last used PB and there is no documentation for PV where I
am working. Thanks in advance for all suggestions.


Terry Dykstra Posted on 1998-11-23 18:00:42.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra" <tdykstra@cfol.ab.ca>
Subject: Re: Report Summary Band Not Processed
Date: Mon, 23 Nov 1998 11:00:42 -0700
Lines: 22
X-Newsreader: Microsoft Outlook Express 4.72.3110.5
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3110.3
Message-ID: <348_fDhTwEwF#GA.294@forums.powersoft.com>
References: <348_efxQeRcF#GA.150@forums.powersoft.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.infomaker.general:6709
Article PK: 241695

Powerviewer is no longer supported. Together with Powermaker it was
replaced by Infomaker 4. We are now up to version 6. I strongly suggest
getting a copy of IM6.

--
Terry Dykstra (TeamPS)
Canadian Forest Oil Ltd.

Michael H Lewis wrote in message ...
>I recently created a simple report in PowerViewer 3.0. In the summary band
>of the report, I placed a statement to print the number of rows printed on
>the report, or *** No Data *** if RowCount returns zero. However, it
>appears that PV 3.0 does not execute the statement in the Summary band when
>the RowCount is zero, therefore I do not get the *** No Data *** line
>printed on the report.
>
>There is probably a very simple solution to this problem, but it has been a
>few years since I last used PB and there is no documentation for PV where I
>am working. Thanks in advance for all suggestions.
>
>