Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

SQLSTATE = 08S01 ERROR

2 posts in PB Infomaker Report Writer Last posting was on 1999-06-15 21:41:54.0Z
Colin Coleman Posted on 1999-06-15 07:34:21.0Z
Newsgroups: sybase.public.infomaker.general
From: "Colin Coleman" <colinc@ndirect.co.uk>
Subject: SQLSTATE = 08S01 ERROR
Date: Tue, 15 Jun 1999 08:34:21 +0100
Lines: 62
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2014.211
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2014.211
Message-ID: <348_hPNS2Cwt#GA.287@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.infomaker.general:6202
Article PK: 240138

Now we have another problem, The customer wants to use the Infomaker 6.5
software supplied in the ASA Studio software. When I connect it
using our in-house system it works fine, but on the clients site we get the
following error ONLY when trying to connect to ANY datasource from within
Infomaker.

SQLSTATE = 08S01
communications Link: Communication error.

Cannot connect to database.

But
It works Fine using Sybase Interactive SQL
It works Fine using Our software connected Via the Same ODBC
It Works Fine using Sybase Data Modeller using the same ODBC

We cant find any information on the above error in ANY of the manualls
either.

I started a log running from the working ODBC connection, well the same ODBC
connection but OUTSIDE of Infomaker and recorded these results.

THIS IS A "TEST CONNECTION" outside of Infomaker (And it works OK)

MON Jun 14 1999 16:07
Trying to start shared Memory Link...
Shared memory link started successfully
Trying to start TCPIP link ...
Loading wsock32.dll
Loading ws2_32.dll
Could Not load ws_32.Dll
Using Winsock 1.1.
My IP address is 192.168.1.225
My IP address is 127.0.0.1
TCPIP link started successfully
Trying 192.168.1.1:2638
Found database server aesdb1 on TCPIP link
Client Connected
Liveness timeout 120, liveness retransmit period 30
Client disconnected

THIS IS A "TEST CONNECTION" Inside Infomaker 6.5 (IT DOES NOT WORK )

MON Jun 14 1999 16:11
Trying to start TCPIP link ...
Loading wsock32.dll
Loading ws2_32.dll
Could Not load ws_32.Dll
TCPIP communications link not started

The machines are all Win 95 (OSR2) 32 - 128MB ram 2 GB Drives


Terry Dykstra Posted on 1999-06-15 21:41:54.0Z
Newsgroups: sybase.public.infomaker.general
From: "Terry Dykstra" <tdykstra@cfol.ab.ca>
Subject: Re: SQLSTATE = 08S01 ERROR
Date: Tue, 15 Jun 1999 15:41:54 -0600
Lines: 79
X-Newsreader: Microsoft Outlook Express 4.72.3612.1700
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.3612.1700
Message-ID: <348_FP7p#c3t#GA.267@forums.sybase.com>
References: <348_hPNS2Cwt#GA.287@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.infomaker.general:6198
Article PK: 240131

Try adding the sqlanywhere directory to the app path for im60.exe.

Here is mine:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App
Paths\im60.exe]
"Path"="C:\\Program Files\\Powersoft\\shared;C:\\Program
Files\\Powersoft\\im6;c:\\sqlany50\\win32\\;C:\\Program
Files\\Powersoft\\im6\\tutorial"
@="C:\\PROGRAM FILES\\POWERSOFT\\IM6\\IM60.EXE"

--
Terry Dykstra (TeamSybase)
Canadian Forest Oil Ltd.

Colin Coleman wrote in message ...
>
>Now we have another problem, The customer wants to use the Infomaker 6.5
>software supplied in the ASA Studio software. When I connect it
>using our in-house system it works fine, but on the clients site we get the
>following error ONLY when trying to connect to ANY datasource from within
>Infomaker.
>
>SQLSTATE = 08S01
>communications Link: Communication error.
>
>Cannot connect to database.
>
>But
>It works Fine using Sybase Interactive SQL
>It works Fine using Our software connected Via the Same ODBC
>It Works Fine using Sybase Data Modeller using the same ODBC
>
>We cant find any information on the above error in ANY of the manualls
>either.
>
>I started a log running from the working ODBC connection, well the same
ODBC
>connection but OUTSIDE of Infomaker and recorded these results.
>
>THIS IS A "TEST CONNECTION" outside of Infomaker (And it works OK)
>
>MON Jun 14 1999 16:07
>Trying to start shared Memory Link...
> Shared memory link started successfully
>Trying to start TCPIP link ...
>Loading wsock32.dll
>Loading ws2_32.dll
>Could Not load ws_32.Dll
>Using Winsock 1.1.
>My IP address is 192.168.1.225
>My IP address is 127.0.0.1
> TCPIP link started successfully
>Trying 192.168.1.1:2638
>Found database server aesdb1 on TCPIP link
>Client Connected
> Liveness timeout 120, liveness retransmit period 30
>Client disconnected
>
>THIS IS A "TEST CONNECTION" Inside Infomaker 6.5 (IT DOES NOT WORK )
>
>MON Jun 14 1999 16:11
>Trying to start TCPIP link ...
>Loading wsock32.dll
>Loading ws2_32.dll
>Could Not load ws_32.Dll
>TCPIP communications link not started
>
>The machines are all Win 95 (OSR2) 32 - 128MB ram 2 GB Drives
>
>
>
>
>
>
>
>
>
>