Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Command Button Focus

2 posts in Objects Last posting was on 2002-07-02 13:42:44.0Z
Steve_Skidmore Posted on 2002-07-02 12:27:58.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: Steve_Skidmore
Date: Tue, 2 Jul 2002 08:27:58 -0400
Subject: Command Button Focus
Lines: 17
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <364_68E5E0473C2A340B00447A7B85256BEA.00447AB285256BEA@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.powerbuilder.objects:1132
Article PK: 713697

I have both a data window object and a command button on a PB 6.5 form. The
focus does not move from the data window object to the form objects
correctly.

1. The data window has the focus.
2. The user clicks on the command button.
3. The data window looses the focus but the command button does not get
the focus.
4. The user clicks on the command button a second time and finally the
button recieves the focus and teh click event is triggered.

It seems to me that the user should only have to click on the command
button once to trigger the single click event regardless of what has the
focus before hand. If the focus where on a different object outside of the
data window then only the one click would be required. Is there any way to
change this behavior.

Thanks in Advance


Simon Caldwell [TeamSybase] Posted on 2002-07-02 13:42:44.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Simon Caldwell [TeamSybase]" <simonDOTcaldwellATbigfootDOTcom>
Subject: Re: Command Button Focus
Date: Tue, 2 Jul 2002 14:42:44 +0100
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: getreal.demon.co.uk 193.237.14.95
Message-ID: <364_IcIZV$cICHA.378@forums.sybase.com>
References: <364_68E5E0473C2A340B00447A7B85256BEA.00447AB285256BEA@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:1129
Article PK: 713691

The behaviour you require is the default behaviour. I would guess that you
have some code in one or more of the "focus changing" events - getfocus or
losefocus. Check this first.

--
All views expressed in this message are my own and not necessarily those of
my employer

<Steve_Skidmore> wrote in message
news:68E5E0473C2A340B00447A7B85256BEA.00447AB285256BEA@webforums...
>
> I have both a data window object and a command button on a PB 6.5 form.
The
> focus does not move from the data window object to the form objects
> correctly.
>
> 1. The data window has the focus.
> 2. The user clicks on the command button.
> 3. The data window looses the focus but the command button does not get
> the focus.
> 4. The user clicks on the command button a second time and finally the
> button recieves the focus and teh click event is triggered.
>
> It seems to me that the user should only have to click on the command
> button once to trigger the single click event regardless of what has the
> focus before hand. If the focus where on a different object outside of
the
> data window then only the one click would be required. Is there any way
to
> change this behavior.
>
> Thanks in Advance