Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Changing Focus in a Treeview

4 posts in Objects Last posting was on 2002-06-28 15:50:30.0Z
Jason Lipman Posted on 2002-06-28 14:20:26.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Jason Lipman" <Jason.Lipman@state.sd.us>
Subject: Changing Focus in a Treeview
Date: Fri, 28 Jun 2002 09:20:26 -0500
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
NNTP-Posting-Host: 164.154.9.183
Message-ID: <364_81Tg8BrHCHA.654@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:1141
Article PK: 713701

When I select level two, I want to automatically bring focus to the first
level 3 item underneath it.

The code below will identify the item I am looking for, but it will not move
the SelectedPicture to that position. The SelectedPicture stays on level 2.

// Identify the first child in level 3
ll_rtn = This.FindItem(ChildTreeItem!, newhandle)
This.SelectItem(ll_rtn)

How do I move the cursor so it is aligned with level three? And.... gee....
what's the point of Selecting an item if it will not appear selected?

Thanks for the help!

Jason Lipman


Philip_Salgannik Posted on 2002-06-28 15:11:07.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: Philip_Salgannik
Date: Fri, 28 Jun 2002 11:11:07 -0400
Subject: Re: Changing Focus in a Treeview
Lines: 1
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <364_3C86C06A29EB57FB00536A6A85256BE6.0052E7F785256BE6@webforums>
References: <364_81Tg8BrHCHA.654@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.powerbuilder.objects:1140
Article PK: 713707

SelectItem(handle) does it for me 100% provided the handle is valid...


Jason Lipman Posted on 2002-06-28 15:22:20.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Jason Lipman" <Jason.Lipman@state.sd.us>
Subject: Re: Changing Focus in a Treeview
Date: Fri, 28 Jun 2002 10:22:20 -0500
Lines: 8
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
NNTP-Posting-Host: 164.154.9.183
Message-ID: <364_eSzLikrHCHA.196@forums.sybase.com>
References: <364_81Tg8BrHCHA.654@forums.sybase.com> <364_3C86C06A29EB57FB00536A6A85256BE6.0052E7F785256BE6@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:1139
Article PK: 713704

This is what I am doing. Is it possible the focus did change, but the
Pictures are not 'moving'? - Jason

<Philip_Salgannik> wrote in message
news:3C86C06A29EB57FB00536A6A85256BE6.0052E7F785256BE6@webforums...
> SelectItem(handle) does it for me 100% provided the handle is valid...


Jason Lipman Posted on 2002-06-28 15:50:30.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Jason Lipman" <Jason.Lipman@state.sd.us>
Subject: Re: Changing Focus in a Treeview
Date: Fri, 28 Jun 2002 10:50:30 -0500
Lines: 14
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
NNTP-Posting-Host: 164.154.9.183
Message-ID: <364_fjQzR0rHCHA.654@forums.sybase.com>
References: <364_81Tg8BrHCHA.654@forums.sybase.com> <364_3C86C06A29EB57FB00536A6A85256BE6.0052E7F785256BE6@webforums> <364_eSzLikrHCHA.196@forums.sybase.com>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:1138
Article PK: 713699

Got it working. Thanks!

"Jason Lipman" <Jason.Lipman@state.sd.us> wrote in message
news:eSzLikrHCHA.196@forums.sybase.com...
> This is what I am doing. Is it possible the focus did change, but the
> Pictures are not 'moving'? - Jason
>
> <Philip_Salgannik> wrote in message
> news:3C86C06A29EB57FB00536A6A85256BE6.0052E7F785256BE6@webforums...
> > SelectItem(handle) does it for me 100% provided the handle is valid...
>
>