Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

picture disappears at selected treeviewitems

2 posts in Objects Last posting was on 2002-08-13 12:55:32.0Z
Stefan_Hubert Posted on 2002-08-13 11:29:19.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: Stefan_Hubert
Date: Tue, 13 Aug 2002 07:29:19 -0400
Subject: picture disappears at selected treeviewitems
Lines: 18
MIME-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-ID: <364_D9BD7766A366EB2F003F1C0485256C14.003F1C1485256C14@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com!webforums.sybase.com!news
Xref: forums-1-dub sybase.public.powerbuilder.objects:1028
Article PK: 713590

Hi,

We display picures for our treeviewitems in a treeview control. (by setting
the PicureIndex).
The picture is displayed properly for all our treeviewitems

We don't understand why the picture disappears as soon as we select an
item. When we select an other one, the picture reappears. Now the picture
of the newly selected item disappeared.

Does anyone have an idea, what may cause this unwanted behaviour?

thanks a lot,

regards,

Stefan


Arnoud Oortwijk Posted on 2002-08-13 12:55:32.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Arnoud Oortwijk" <aoortwijk@tangram.nl>
Subject: Re: picture disappears at selected treeviewitems
Date: Tue, 13 Aug 2002 14:55:32 +0200
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4522.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4522.1200
NNTP-Posting-Host: tangram.nl 213.84.194.121
Message-ID: <364_TVhuAosQCHA.59@forums.sybase.com>
References: <364_D9BD7766A366EB2F003F1C0485256C14.003F1C1485256C14@webforums>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:1027
Article PK: 713591

On the treeviewitem you also have a property 'selectedpictureindex'. If you
don't want your pictures to change when the item gets focus it must have the
same value as the property PictureIndex.

HTH

Arnoud

Url: http://www.gloriant.be



<Stefan_Hubert> schreef in bericht
news:D9BD7766A366EB2F003F1C0485256C14.003F1C1485256C14@webforums...

> Hi,
>
> We display picures for our treeviewitems in a treeview control. (by
setting
> the PicureIndex).
> The picture is displayed properly for all our treeviewitems
>
> We don't understand why the picture disappears as soon as we select an
> item. When we select an other one, the picture reappears. Now the picture
> of the newly selected item disappeared.
>
> Does anyone have an idea, what may cause this unwanted behaviour?
>
> thanks a lot,
>
> regards,
>
> Stefan
>