Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

RTE print preview problem

2 posts in Objects Last posting was on 2003-04-01 09:47:39.0Z
Alexander Isaev Posted on 2003-03-28 09:48:30.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Alexander Isaev" <isaev@scil.ru>
Subject: RTE print preview problem
Date: Fri, 28 Mar 2003 12:48:30 +0300
Lines: 24
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: 195.209.149.22
Message-ID: <364_OH6F39Q9CHA.317@forums-1-dub>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums-1-dub.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:7295
Article PK: 734582

Hi!

I use pb7.

There are 2 printers installed on my computer. The first one has a4 portrait
page setting
but the second one - envelope #10 landscape.

The default windows printer is the 1st one.
I run my application which opens window with rte control.
I switch rte to preview mode - it displays page as a4 portrait - OK.
I switch rte back to edit mode.
I change current printer using PrintSetup() function. Now 2nd printer is
selected.
I switch rte to preview mode - it displays page as a4 portrait - ????? Why?
Must be envelope #10 landscape!
When I print document it is printed in proper (envelope #10 landscape)
format.

What I have to do to avoid this problem?

Thanks.


Alexander Isaev Posted on 2003-04-01 09:47:39.0Z
Newsgroups: sybase.public.powerbuilder.objects
From: "Alexander Isaev" <isaev@scil.ru>
Subject: RTE print preview problem - additional info - SORRY!
Date: Tue, 1 Apr 2003 13:47:39 +0400
Lines: 12
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: 195.209.149.22
Message-ID: <364_O7Y6IQD#CHA.319@forums-1-dub>
References: <364_OH6F39Q9CHA.317@forums-1-dub>
Path: forums-1-dub!forums-1-dub!forums-master.sybase.com!forums-1-dub.sybase.com
Xref: forums-1-dub sybase.public.powerbuilder.objects:7299
Article PK: 734586

Sorry, all i have written above was my mistake.

Problem has another reason:

At least one instance of RTE is already created -> I select another printer
using PrintSetup() function then turn one of existring RTE to preview mode
or create new RTE and then turn it to preview mode - preview uses previously
selected printer settings (page size, orientation etc.). After calling RTE
Print() function preview is being recovered.