Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Problems with "_" in table names

2 posts in JConnect version 3.0 Last posting was on 1998-11-24 14:08:48.0Z
Mark Newsome Posted on 1998-11-23 23:15:06.0Z
Message-ID: <3659EC7A.EDF19140@nacse.org>
Date: Mon, 23 Nov 1998 15:15:06 -0800
From: Mark Newsome <newsome@nacse.org>
X-Mailer: Mozilla 4.05 [en] (X11; I; SunOS 5.6 sun4u)
MIME-Version: 1.0
Subject: Problems with "_" in table names
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 15
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jconnect30:355
Article PK: 255734

Hello all,

In JDBC, the underscore character "_" is a wildcard meaning any
character. When passed table names with underscores in them, jconnect
3.0 reports an error. (In my case, I'm trying to get the relations
between tables using getExportedKeys()).

I noticed that the jconnect driver reports that the escape string
(getSearchStringEscape()) is "[]" (square brackets). I've tried
enclosing my table names in square brakets, but I still get an error.
getExportedKeys() works fine on table names without underscores...

Any suggestions?

Cheers,
Mark


Carl W. Edwards Posted on 1998-11-24 14:08:48.0Z
Message-ID: <365ABDF0.5F9CFFD5@sybase.com>
Date: Tue, 24 Nov 1998 06:08:48 -0800
From: "Carl W. Edwards" <cedwards@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.07 [en] (WinNT; I)
MIME-Version: 1.0
Subject: Re: Problems with "_" in table names
References: <3659EC7A.EDF19140@nacse.org>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 25
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jconnect30:354
Article PK: 254618

In our latest MetaData scripts (jConnect 4.0, EBF 8144), we have fixed
this problem where we were not allowing the "_" in table names properly.
Also, the getSearchStringEscape has been set to the '\' character.

If you install the new scripts, it is not necessary to update the client.
These scripts can be used for all versions of jConnect.

-Carl

Mark Newsome wrote:

> Hello all,
>
> In JDBC, the underscore character "_" is a wildcard meaning any
> character. When passed table names with underscores in them, jconnect
> 3.0 reports an error. (In my case, I'm trying to get the relations
> between tables using getExportedKeys()).
>
> I noticed that the jconnect driver reports that the escape string
> (getSearchStringEscape()) is "[]" (square brackets). I've tried
> enclosing my table names in square brakets, but I still get an error.
> getExportedKeys() works fine on table names without underscores...
>
> Any suggestions?
>
> Cheers,
> Mark