Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

jconnect & http gateway

5 posts in JConnect version 3.0 Last posting was on 1999-03-24 12:30:45.0Z
Brian Carter Posted on 1999-03-18 15:22:24.0Z
Message-ID: <36F11A30.2766@bcbsal.org>
Date: Thu, 18 Mar 1999 09:22:24 -0600
From: Brian Carter <brcarter@bcbsal.org>
Reply-To: brcarter@bcbsal.org
Organization: BlueCross BlueShield of Alabama
X-Mailer: Mozilla 3.01 (WinNT; I)
MIME-Version: 1.0
Subject: jconnect & http gateway
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 26
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jconnect30:296
Article PK: 255708

I have a db applet that uses jconnect 2.2 and the webserver and db are
on different machines, so I am using the httpd gateway that came with
powerJ... everything seemed to be working fine... however, now that the
use is going from lightly used to moderate use I am having some
problems...

I set up the gateway to run as a service... after some moderate use the
gateway seems to loose its ability to connect to the db server... when I
look at the services list it is still running, but if I stop it and then
restart it, everything is working normally again...

my applet is a 1.02 applet, and the gateway is using jdk1.1

I have the ability to upgrade the jdk on the server, but the applet must
remain a 1.02 applet for now...

does anyone know of a way to get this more stable, or know of another
gateway that is more stable than this one... In a short time this applet
will move from moderate use to high use, so I need to get this fixed
quickly...

any help will be greatly appreciated...

tia


Wolfgang Kunk Posted on 1999-03-19 11:08:20.0Z
Message-ID: <36F23024.C3282109@rtl.de>
Date: Fri, 19 Mar 1999 12:08:20 +0100
From: Wolfgang Kunk <wolfgang.kunk@rtl.de>
Organization: RTL Television
X-Mailer: Mozilla 4.05 [en] (WinNT; I)
MIME-Version: 1.0
To: brcarter@bcbsal.org
Subject: Re: jconnect & http gateway
References: <36F11A30.2766@bcbsal.org>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 40
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jconnect30:295
Article PK: 254599

Hi Brian,
unfortunatly you don't say on which system your http-gateway run.
We had similar problems with the gateway under Sun Solaris 2.6. We fix the
problem starting the gateway with native - threads (the default uses so
called ' green threads'). Therefore we needed to install native thread
support for Solaris.
Additional you can call the Sybase support. They should know that problem.
We handled the problem with the European Support Center in Netherland.

Bye Wolfgang

Brian Carter wrote:

> I have a db applet that uses jconnect 2.2 and the webserver and db are
> on different machines, so I am using the httpd gateway that came with
> powerJ... everything seemed to be working fine... however, now that the
> use is going from lightly used to moderate use I am having some
> problems...
>
> I set up the gateway to run as a service... after some moderate use the
> gateway seems to loose its ability to connect to the db server... when I
> look at the services list it is still running, but if I stop it and then
> restart it, everything is working normally again...
>
> my applet is a 1.02 applet, and the gateway is using jdk1.1
>
> I have the ability to upgrade the jdk on the server, but the applet must
> remain a 1.02 applet for now...
>
> does anyone know of a way to get this more stable, or know of another
> gateway that is more stable than this one... In a short time this applet
> will move from moderate use to high use, so I need to get this fixed
> quickly...
>
> any help will be greatly appreciated...
>
> tia


Lance Andersen Posted on 1999-03-19 12:31:42.0Z
Message-ID: <36F243AE.7C7A77C5@sybase.com>
Date: Fri, 19 Mar 1999 07:31:42 -0500
From: Lance Andersen <lancea@sybase.com>
X-Mailer: Mozilla 4.5 [en] (X11; U; SunOS 5.5.1 sun4m)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: jconnect & http gateway
References: <36F11A30.2766@bcbsal.org> <36F23024.C3282109@rtl.de>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 60
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jconnect30:294
Article PK: 254598

Brian,

We don't really support 2.2 any longer. If what Wolfgang suggests does
not work, then I would suggest moving on to the TDSTunnelServlet(which
requires a higher release of jConnet).

I would not reccommend using Cascade for a high volume website.

Regards,
-Lance

team sybaseWolfgang Kunk wrote:
>
> Hi Brian,
> unfortunatly you don't say on which system your http-gateway run.
> We had similar problems with the gateway under Sun Solaris 2.6. We fix the
> problem starting the gateway with native - threads (the default uses so
> called ' green threads'). Therefore we needed to install native thread
> support for Solaris.
> Additional you can call the Sybase support. They should know that problem.
> We handled the problem with the European Support Center in Netherland.
>
> Bye Wolfgang
>
> Brian Carter wrote:
>
> > I have a db applet that uses jconnect 2.2 and the webserver and db are
> > on different machines, so I am using the httpd gateway that came with
> > powerJ... everything seemed to be working fine... however, now that the
> > use is going from lightly used to moderate use I am having some
> > problems...
> >
> > I set up the gateway to run as a service... after some moderate use the
> > gateway seems to loose its ability to connect to the db server... when I
> > look at the services list it is still running, but if I stop it and then
> > restart it, everything is working normally again...
> >
> > my applet is a 1.02 applet, and the gateway is using jdk1.1
> >
> > I have the ability to upgrade the jdk on the server, but the applet must
> > remain a 1.02 applet for now...
> >
> > does anyone know of a way to get this more stable, or know of another
> > gateway that is more stable than this one... In a short time this applet
> > will move from moderate use to high use, so I need to get this fixed
> > quickly...
> >
> > any help will be greatly appreciated...
> >
> > tia

--
===============================================================================
Lance J. Andersen Email: lancea@sybase.com
Sybase Product Support Engineering Phone:(781) 564-6336
77 South Bedford Street Fax: (781) 564-6148
Burlington, MA 01803

The Dark Knight Returns!!! Let's Go Penguins!!!
===============================================================================


Brian Carter Posted on 1999-03-19 14:13:03.0Z
Message-ID: <36F25B6F.4934@bcbsal.org>
Date: Fri, 19 Mar 1999 08:13:03 -0600
From: Brian Carter <brcarter@bcbsal.org>
Reply-To: brcarter@bcbsal.org
Organization: BlueCross BlueShield of Alabama
X-Mailer: Mozilla 3.01 (WinNT; I)
MIME-Version: 1.0
Subject: Re: jconnect & http gateway
References: <36F11A30.2766@bcbsal.org> <36F23024.C3282109@rtl.de> <36F243AE.7C7A77C5@sybase.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 70
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.jconnect30:293
Article PK: 255707

1) I am running on WinNT4.0 SP3
2) Can I use a higher jConnect and still use jdk1.02 on Client? I was
under the impression that I couldn't... if I can then where do I find
info on TDSTunnelServlet?

thanx for the help

Lance Andersen wrote:
>
> Brian,
>
> We don't really support 2.2 any longer. If what Wolfgang suggests does
> not work, then I would suggest moving on to the TDSTunnelServlet(which
> requires a higher release of jConnet).
>
> I would not reccommend using Cascade for a high volume website.
>
> Regards,
> -Lance
> team sybaseWolfgang Kunk wrote:
> >
> > Hi Brian,
> > unfortunatly you don't say on which system your http-gateway run.
> > We had similar problems with the gateway under Sun Solaris 2.6. We fix the
> > problem starting the gateway with native - threads (the default uses so
> > called ' green threads'). Therefore we needed to install native thread
> > support for Solaris.
> > Additional you can call the Sybase support. They should know that problem.
> > We handled the problem with the European Support Center in Netherland.
> >
> > Bye Wolfgang
> >
> > Brian Carter wrote:
> >
> > > I have a db applet that uses jconnect 2.2 and the webserver and db are
> > > on different machines, so I am using the httpd gateway that came with
> > > powerJ... everything seemed to be working fine... however, now that the
> > > use is going from lightly used to moderate use I am having some
> > > problems...
> > >
> > > I set up the gateway to run as a service... after some moderate use the
> > > gateway seems to loose its ability to connect to the db server... when I
> > > look at the services list it is still running, but if I stop it and then
> > > restart it, everything is working normally again...
> > >
> > > my applet is a 1.02 applet, and the gateway is using jdk1.1
> > >
> > > I have the ability to upgrade the jdk on the server, but the applet must
> > > remain a 1.02 applet for now...
> > >
> > > does anyone know of a way to get this more stable, or know of another
> > > gateway that is more stable than this one... In a short time this applet
> > > will move from moderate use to high use, so I need to get this fixed
> > > quickly...
> > >
> > > any help will be greatly appreciated...
> > >
> > > tia
>
> --
> ===============================================================================
> Lance J. Andersen Email: lancea@sybase.com
> Sybase Product Support Engineering Phone:(781) 564-6336
> 77 South Bedford Street Fax: (781) 564-6148
> Burlington, MA 01803
>
> The Dark Knight Returns!!! Let's Go Penguins!!!
> ===============================================================================


Lance Andersen Posted on 1999-03-24 12:30:45.0Z
Message-ID: <36F8DAF5.B77D7EC8@sybase.com>
Date: Wed, 24 Mar 1999 07:30:45 -0500
From: Lance Andersen <lancea@sybase.com>
X-Mailer: Mozilla 4.51 [en] (X11; I; SunOS 5.5.1 sun4m)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: jconnect & http gateway
References: <36F11A30.2766@bcbsal.org> <36F23024.C3282109@rtl.de> <36F243AE.7C7A77C5@sybase.com> <36F25B6F.4934@bcbsal.org>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 89
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.jconnect30:288
Article PK: 255750

No, you will need to upgrade to jConnect 3.x or higher (though we really
do not any sustaining work on 3.0 as it is a very old release)

lance
team sybase

Brian Carter wrote:
>
> 1) I am running on WinNT4.0 SP3
> 2) Can I use a higher jConnect and still use jdk1.02 on Client? I was
> under the impression that I couldn't... if I can then where do I find
> info on TDSTunnelServlet?
>
> thanx for the help
>
> Lance Andersen wrote:
> >
> > Brian,
> >
> > We don't really support 2.2 any longer. If what Wolfgang suggests does
> > not work, then I would suggest moving on to the TDSTunnelServlet(which
> > requires a higher release of jConnet).
> >
> > I would not reccommend using Cascade for a high volume website.
> >
> > Regards,
> > -Lance
> > team sybaseWolfgang Kunk wrote:
> > >
> > > Hi Brian,
> > > unfortunatly you don't say on which system your http-gateway run.
> > > We had similar problems with the gateway under Sun Solaris 2.6. We fix the
> > > problem starting the gateway with native - threads (the default uses so
> > > called ' green threads'). Therefore we needed to install native thread
> > > support for Solaris.
> > > Additional you can call the Sybase support. They should know that problem.
> > > We handled the problem with the European Support Center in Netherland.
> > >
> > > Bye Wolfgang
> > >
> > > Brian Carter wrote:
> > >
> > > > I have a db applet that uses jconnect 2.2 and the webserver and db are
> > > > on different machines, so I am using the httpd gateway that came with
> > > > powerJ... everything seemed to be working fine... however, now that the
> > > > use is going from lightly used to moderate use I am having some
> > > > problems...
> > > >
> > > > I set up the gateway to run as a service... after some moderate use the
> > > > gateway seems to loose its ability to connect to the db server... when I
> > > > look at the services list it is still running, but if I stop it and then
> > > > restart it, everything is working normally again...
> > > >
> > > > my applet is a 1.02 applet, and the gateway is using jdk1.1
> > > >
> > > > I have the ability to upgrade the jdk on the server, but the applet must
> > > > remain a 1.02 applet for now...
> > > >
> > > > does anyone know of a way to get this more stable, or know of another
> > > > gateway that is more stable than this one... In a short time this applet
> > > > will move from moderate use to high use, so I need to get this fixed
> > > > quickly...
> > > >
> > > > any help will be greatly appreciated...
> > > >
> > > > tia
> >
> > --
> > ===============================================================================
> > Lance J. Andersen Email: lancea@sybase.com
> > Sybase Product Support Engineering Phone:(781) 564-6336
> > 77 South Bedford Street Fax: (781) 564-6148
> > Burlington, MA 01803
> >
> > The Dark Knight Returns!!! Let's Go Penguins!!!
> > ===============================================================================

--
===============================================================================
Lance J. Andersen Email: lancea@sybase.com
Sybase Product Support Engineering Phone:(781) 564-6336
77 South Bedford Street Fax: (781) 564-6148
Burlington, MA 01803

The Dark Knight Returns!!! Let's Go Penguins!!!
===============================================================================