Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

sybase11 server problem

4 posts in Windows NT Last posting was on 2000-01-02 13:23:59.0Z
Priyanka Posted on 1999-12-30 07:03:16.0Z
Message-ID: <386B03B4.6E1C843@velos.ssind.com>
Date: Thu, 30 Dec 1999 12:33:16 +0530
From: Priyanka <pdeswal@velos.ssind.com>
X-Mailer: Mozilla 4.6 [en] (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: sybase11 server problem
Content-Type: multipart/alternative; boundary="------------C100014589081E941B7BA49A"
Newsgroups: sybase.public.sqlserver.nt
Lines: 52
NNTP-Posting-Host: 12.10.197.165
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2758
Article PK: 1090195

Problem:Not able to backup databases  on a sybase 11 server as the remote server (which is created by default while creating a new server) has been deleted accidently.
Details:
In Sybase Server 11,remote server( which is created by default when we create a new server) has been deleted accidently.An attempt to create a new remote server does not help as  an error message saying that referenced server(remote server) not found in table sysservers is displayed.Again if we  make an entry into table sysservers for the created remote server does not help,again the same error message is displayed,where as after inserting row into table sysserver for the created remote server the table sysserver shows the entry for added the remote server.So,do we need to update some other system objects or something else.
Thanks.


Eric McGrane Posted on 1999-12-30 14:10:01.0Z
Message-ID: <386B67B9.30E5E53F@sybase.com>
Date: Thu, 30 Dec 1999 09:10:01 -0500
From: Eric McGrane <mcgrane@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
To: Priyanka <pdeswal@velos.ssind.com>
Subject: Re: sybase11 server problem
References: <386B03B4.6E1C843@velos.ssind.com>
Content-Type: multipart/mixed; boundary="------------979D510C650324545143FDC1"
Newsgroups: sybase.public.sqlserver.nt
Lines: 71
NNTP-Posting-Host: 157.133.126.171
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2756
Article PK: 1090189

Priyanka,

Technically speaking the remote backup server does not need to be in
sysservers as the local SQL Server does not communicate with the remote
backup server. The SQL server talks with the local backup server and
the local backup server communicates with the remote backup server. In
order for a remote backup to work the following must be true:

1) local SQL Server, local backup server, and remote backup server are
all up and running
2) an entry must exist in the local interfaces files for the remote
backup server (so that the local backup server can locate and
communicate with the remote backup server)
3) the local SQL server must be able to comunicate with the local backup
server, i.e an entry must exist in sysservers for the local backup
server (SYB_BACKUP)
4) there must be communication between the local machine and the remote
machine (where the remote backup server resides)

Assuming this is all true you should be able to dump to a device on the
remote machine (file or tape) via the remote backup server.

Verify that all of the above is true and you should get it working
again.

E

Priyanka wrote:

> Problem:Not able to backup databases on a sybase 11 server as the
> remote server (which is created by default while creating a new
> server) has been deleted accidently.
> Details:
> In Sybase Server 11,remote server( which is created by default when we
> create a new server) has been deleted accidently.An attempt to create
> a new remote server does not help as an error message saying that
> referenced server(remote server) not found in table sysservers is
> displayed.Again if we make an entry into table sysservers for the
> created remote server does not help,again the same error message is
> displayed,where as after inserting row into table sysserver for the
> created remote server the table sysserver shows the entry for added
> the remote server.So,do we need to update some other system objects or
> something else.
> Thanks.


Download VCard mcgrane.vcf


Alan Ramsay Posted on 1999-12-30 20:08:13.0Z
From: "Alan Ramsay" <alan@dotdash.org.uk>
References: <386B03B4.6E1C843@velos.ssind.com> <386B67B9.30E5E53F@sybase.com>
Subject: Re: sybase11 server problem
Date: Thu, 30 Dec 1999 20:08:13 -0000
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6600
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
Message-ID: <3afLPIwU$GA.299@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: 212.67.134.210
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2752
Article PK: 1090184


"Eric McGrane" <mcgrane@sybase.com> wrote in message
news:386B67B9.30E5E53F@sybase.com...
> Priyanka,
>
> Technically speaking the remote backup server does not need to be in
> sysservers as the local SQL Server does not communicate with the remote
> backup server. The SQL server talks with the local backup server and
> the local backup server communicates with the remote backup server. In
> order for a remote backup to work the following must be true:
>
> 1) local SQL Server, local backup server, and remote backup server are
> all up and running
> 2) an entry must exist in the local interfaces files for the remote
> backup server (so that the local backup server can locate and
> communicate with the remote backup server)

The entry in the interfaces file must have the same name as the backup
server on the remote server.

Therefore, you're remote backup server can not just be called SYB_BACKUP if
your local backup server is caller SYB_BACKUP.

You would first need to create a backup server on the 'remote' machine,
called something like SERVERA_BACKUP, and then put an entry in the
interfaces file on Server B with SERVERA_BACKUP in it too.

Hope this helps.

Alan


Samer Mestom Posted on 2000-01-02 13:23:59.0Z
From: "Samer Mestom" <smestom@hotmail.com>
References: <386B03B4.6E1C843@velos.ssind.com>
Subject: Re: sybase11 server problem
Date: Sun, 2 Jan 2000 16:23:59 +0300
Lines: 124
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0026_01BF553D.C639DC70"
X-Newsreader: Microsoft Outlook Express 4.72.2106.4
X-MimeOLE: Produced By Microsoft MimeOLE V4.72.2106.4
Message-ID: <L5aRbTSV$GA.295@forums.sybase.com>
Newsgroups: sybase.public.sqlserver.nt
NNTP-Posting-Host: ngh108.eu.info.net 195.213.248.108
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:2748
Article PK: 1090191

Hello Priyanka
 
When you issue a dump database command to a remote server you should specify the backup server using "at <remote bck server>" option. This means that the SQL server tries to identify the bck server from sysservers tables and directs the task to its local bck server to communicate with the remote bck server. Try to use :
    sp_addserver "bck server name",NULL,"bck server name in interfaces"
then add an entry to the interfaces identifying the remote bck server.
 
You do not have to add an entry for the local bck server in the remote interfaces file since it is acting as a client.
 
Also be sure that SYB_BACKUP has an entry in sysservers and remove any old entry for the remote backup server from sysservers using sp_dropserver.
 
Best regards,
 
Samer Mestom (AA115)
 
 
Priyanka wrote in message <386B03B4.6E1C843@velos.ssind.com>...
Problem:Not able to backup databases  on a sybase 11 server as the remote server (which is created by default while creating a new server) has been deleted accidently.
Details:
In Sybase Server 11,remote server( which is created by default when we create a new server) has been deleted accidently.An attempt to create a new remote server does not help as  an error message saying that referenced server(remote server) not found in table sysservers is displayed.Again if we  make an entry into table sysservers for the created remote server does not help,again the same error message is displayed,where as after inserting row into table sysserver for the created remote server the table sysserver shows the entry for added the remote server.So,do we need to update some other system objects or something else.
Thanks.