Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Can't drop text index using ASE 11.9.2 and full text search add in

2 posts in ,  Windows NT General Discussion Last posting was on 2000-06-12 16:45:51.0Z
Jonathan Cates Posted on 2000-06-05 18:51:11.0Z
Message-ID: <393BF69D.D57E24F5@activated.com>
Date: Mon, 05 Jun 2000 14:51:11 -0400
From: Jonathan Cates <jon@activated.com>
X-Mailer: Mozilla 4.72 [en] (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Can't drop text index using ASE 11.9.2 and full text search add in
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.general,sybase.public.sqlserver.nt
Lines: 12
NNTP-Posting-Host: vipe.activated.com 216.27.54.17
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.general:3725 sybase.public.sqlserver.nt:583
Article PK: 1074682

Hello,

We are having a problem dropping a full text retrieval index from our
database. When we issue the command sp_drop_text_index indexName, we
get the following error:

Index 'indexName' is not a Text Index
(1 row affected)
(return status = 0)

And yet if I do an sp_help_text_index, the index is there and I can see
information on it.

Has anyone else run into this problem? Any help is greatly appreciated.

Thanks

Jon


Gordon R Sams Posted on 2000-06-12 16:45:51.0Z
Message-ID: <394513BF.2D5DE64F@aol.com>
Date: Mon, 12 Jun 2000 10:45:51 -0600
From: Gordon R Sams <gordon0412@aol.com>
Reply-To: gsams@sybase.com
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.7 [en]C-CCK-MCD (WinNT; I)
X-Accept-Language: en
MIME-Version: 1.0
To: Jonathan Cates <jon@activated.com>
Subject: Re: Can't drop text index using ASE 11.9.2 and full text search add in
References: <393BF69D.D57E24F5@activated.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.general,sybase.public.sqlserver.nt
Lines: 18
NNTP-Posting-Host: gsams-pc2.sybase.com 157.133.215.54
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.general:3724 sybase.public.sqlserver.nt:582
Article PK: 1074680

Jonathan,

In sp_drop_text_index the text index name must be fully qualified in the
format "table_name.index_name" as shown in Appendix A of the FTS User's
Guide.

Gordon

Jonathan Cates wrote:

> Hello,
>
> We are having a problem dropping a full text retrieval index from our
> database. When we issue the command sp_drop_text_index indexName, we
> get the following error:
>
> Index 'indexName' is not a Text Index
> (1 row affected)
> (return status = 0)
>
> And yet if I do an sp_help_text_index, the index is there and I can see
> information on it.
>
> Has anyone else run into this problem? Any help is greatly appreciated.
>
> Thanks
>
> Jon