Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Help ! no connection with jconnect3.0 to OSG db

2 posts in JConnect version 3.0 Last posting was on 2000-06-21 10:57:18.0Z
TheDuDE Posted on 2000-06-20 18:40:18.0Z
Message-ID: <394FBA92.99938823@web.de>
Date: Tue, 20 Jun 2000 20:40:18 +0200
From: TheDuDE <stephan.weiss@web.de>
Organization: DuDEsWoRlD
X-Mailer: Mozilla 4.7 [en] (X11; I; Linux 2.2.13 i686)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Help ! no connection with jconnect3.0 to OSG db
Content-Type: multipart/mixed; boundary="------------D9285993CE82EA615A34CF84"
Newsgroups: sybase.public.jconnect30
Lines: 37
NNTP-Posting-Host: A0234.pppool.de 213.6.2.52
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.jconnect30:218
Article PK: 256635

hi,

its quite tricky, what has happened to me yesterday:
i have written an applet with powerj2.5, that, with the help of the Open
Server Gateway,
should connect to a database over the internet...
i used the powersoft.powerj.db.transaction class and the sybase driver
(URL jdbc:sybase:Tds:DB:7373) - the weird thing in this problem is:
the applet is running perfectly with the sun appletviewer, but not
in internetexplorer nor in netscape...
the i call transaction.connect() to connect to the osg.
it returns true, when connected and false, if not. But in a browser the
function ( connect() ) has an ArrayOutOfBoundsException and returns
false - but opens a connection...
the connection is open, but i cant use it, because my applet "believes"
that there is no connection... thats #*+#*!#...

please help me... ! Dude


Download VCard stephan.weiss.vcf


Lance Andersen Posted on 2000-06-21 10:57:18.0Z
Message-ID: <39509F8E.BB6DAB75@sybase.com>
Date: Wed, 21 Jun 2000 06:57:18 -0400
From: Lance Andersen <lancea@sybase.com>
X-Mailer: Mozilla 4.73 [en] (X11; I; SunOS 5.7 sun4u)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Re: Help ! no connection with jconnect3.0 to OSG db
References: <394FBA92.99938823@web.de>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.jconnect30
Lines: 35
NNTP-Posting-Host: alder.sybase.com 157.133.125.15
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.jconnect30:217
Article PK: 254568


TheDuDE wrote:
>
> hi,
>
> its quite tricky, what has happened to me yesterday:
> i have written an applet with powerj2.5, that, with the help of the Open
> Server Gateway,
> should connect to a database over the internet...
> i used the powersoft.powerj.db.transaction class and the sybase driver
> (URL jdbc:sybase:Tds:DB:7373) - the weird thing in this problem is:
> the applet is running perfectly with the sun appletviewer, but not
> in internetexplorer nor in netscape...
> the i call transaction.connect() to connect to the osg.
> it returns true, when connected and false, if not. But in a browser the
> function ( connect() ) has an ArrayOutOfBoundsException and returns
> false - but opens a connection...
> the connection is open, but i cant use it, because my applet "believes"
> that there is no connection... thats #*+#*!#...
>
> please help me... ! Dude

I think you need to try the powerj newsgroup for this one.

Lance
--
===============================================================================
Lance J. Andersen Email: lancea@sybase.com
Sybase Product Support Engineering Phone:(781) 564-6336
77 South Bedford Street Fax: (781) 564-7001
Burlington, MA 01803

The Dark Knight Returns!!! Let's Go Penguins!!!
===============================================================================